Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » error in project after using e4 wizard
error in project after using e4 wizard [message #664002] Thu, 07 April 2011 07:16 Go to next message
Holger Sachse is currently offline Holger SachseFriend
Messages: 12
Registered: February 2011
Location: Hamburg
Junior Member
Hi all,

since m5 i get the following error when I try to run a e4 wizard generated application:

!SESSION 2011-04-07 09:08:47.802 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_23
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Framework arguments: -product testme.product
Command-line arguments: -product testme.product -data D:\Development\e4_empty/../runtime-testme.product -dev file:D:/Development/e4_empty/.metadata/.plugins/org.eclipse. pde.core/testme.product/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.equinox.app 0 0 2011-04-07 09:08:48.703
!MESSAGE Product testme.product could not be found.

!ENTRY org.eclipse.osgi 2 0 2011-04-07 09:08:48.740
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-07 09:08:48.740
!MESSAGE Bundle initial@reference:file:plugins/org.apache.batik.css_1.6.0.v201011041432.jar/ was not resolved.
!SUBENTRY 2 org.apache.batik.css 2 0 2011-04-07 09:08:48.740
!MESSAGE Missing required bundle org.apache.batik.util_[1.6.0,1.7.0).

!ENTRY org.eclipse.osgi 2 0 2011-04-07 09:08:48.745
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-07 09:08:48.752
!MESSAGE Bundle org.eclipse.e4.ui.css.swt.theme_0.9.0.v20100723-1830 was not resolved.
!SUBENTRY 2 org.eclipse.e4.ui.css.swt.theme 2 0 2011-04-07 09:08:48.752
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt_0.9.1.
!SUBENTRY 2 org.eclipse.e4.ui.css.swt.theme 2 0 2011-04-07 09:08:48.752
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-07 09:08:48.752
!MESSAGE Bundle org.eclipse.e4.ui.css.swt_0.9.1.v20110331-2030 was not resolved.
!SUBENTRY 2 org.eclipse.e4.ui.css.swt 2 0 2011-04-07 09:08:48.752
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-07 09:08:48.753
!MESSAGE Bundle testme_1.0.0.1 was not resolved.
!SUBENTRY 2 testme 2 0 2011-04-07 09:08:48.753
!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench.swt_0.9.1.
!SUBENTRY 2 testme 2 0 2011-04-07 09:08:48.753
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-07 09:08:48.753
!MESSAGE Bundle org.eclipse.e4.ui.workbench.renderers.swt_0.9.1.v20110331-20 30 was not resolved.
!SUBENTRY 2 org.eclipse.e4.ui.workbench.renderers.swt 2 0 2011-04-07 09:08:48.754
!MESSAGE Missing required bundle org.eclipse.e4.ui.workbench.swt_0.9.0.
!SUBENTRY 2 org.eclipse.e4.ui.workbench.renderers.swt 2 0 2011-04-07 09:08:48.754
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt.theme_0.9.0.
!SUBENTRY 2 org.eclipse.e4.ui.workbench.renderers.swt 2 0 2011-04-07 09:08:48.754
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-07 09:08:48.754
!MESSAGE Bundle org.eclipse.e4.ui.css.core_0.9.0.v20110303-1630 was not resolved.
!SUBENTRY 2 org.eclipse.e4.ui.css.core 2 0 2011-04-07 09:08:48.754
!MESSAGE Missing required bundle org.apache.batik.css_[1.6.0,1.7.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-07 09:08:48.755
!MESSAGE Bundle org.eclipse.e4.ui.workbench.swt_0.9.1.v20110331-2030 was not resolved.
!SUBENTRY 2 org.eclipse.e4.ui.workbench.swt 2 0 2011-04-07 09:08:48.755
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.core_0.9.0.
!SUBENTRY 2 org.eclipse.e4.ui.workbench.swt 2 0 2011-04-07 09:08:48.755
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt_0.9.0.
!SUBENTRY 2 org.eclipse.e4.ui.workbench.swt 2 0 2011-04-07 09:08:48.755
!MESSAGE Missing required bundle org.eclipse.e4.ui.css.swt.theme_0.9.0.
!SUBENTRY 2 org.eclipse.e4.ui.workbench.swt 2 0 2011-04-07 09:08:48.756
!MESSAGE Missing imported package org.apache.batik.css.engine_1.6.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-07 09:08:48.756
!MESSAGE Bundle org.apache.batik.css_1.6.0.v201011041432 [53] was not resolved.
!SUBENTRY 2 org.apache.batik.css 2 0 2011-04-07 09:08:48.756
!MESSAGE Missing required bundle org.apache.batik.util_[1.6.0,1.7.0).

!ENTRY org.eclipse.osgi 4 0 2011-04-07 09:08:48.757
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run (MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)

E4 version : eclipse-SDK-I20110405-2200-win32
Operating system. Win 7 32 bit.

Any idea what I did wrong during the installation?

Holger

Re: error in project after using e4 wizard [message #664045 is a reply to message #664002] Thu, 07 April 2011 09:39 Go to previous messageGo to next message
Soenke Brightside is currently offline Soenke BrightsideFriend
Messages: 41
Registered: January 2011
Member
Same problem here. Latest 4.1 / e4 build.

kw3r
Re: error in project after using e4 wizard [message #664054 is a reply to message #664045] Thu, 07 April 2011 09:58 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5487
Registered: July 2009
Senior Member
When you open the run-configuration are there any problems reported when
hitting validate?

Tom

Am 07.04.11 11:39, schrieb kw3r:
> Same problem here. Latest 4.1 / e4 build.
>
> kw3r
Re: error in project after using e4 wizard [message #664061 is a reply to message #664054] Thu, 07 April 2011 11:05 Go to previous messageGo to next message
Soenke Brightside is currently offline Soenke BrightsideFriend
Messages: 41
Registered: January 2011
Member
org.apache.batik.css->
Missing Constraint: Require Bundle: org.apache.batik.util; bundle-version=[1.6.0,1.7.0)

Tom Schindl wrote on Thu, 07 April 2011 05:58
When you open the run-configuration are there any problems reported when
hitting validate?

Tom

Am 07.04.11 11:39, schrieb kw3r:
> Same problem here. Latest 4.1 / e4 build.
>
> kw3r

[Updated on: Thu, 07 April 2011 11:11]

Report message to a moderator

Re: error in project after using e4 wizard [message #664066 is a reply to message #664061] Thu, 07 April 2011 11:27 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5487
Registered: July 2009
Senior Member
Are there 2 different batik-versions and you runtime config holds 1.7.0,
instead of the required 1.6.0?

Tom

Am 07.04.11 13:05, schrieb kw3r:
> Missing Constraint: Require Bundle: org.apache.batik.util;
> bundle-version=[1.6.0,1.7.0)
>
> Tom Schindl wrote on Thu, 07 April 2011 05:58
>> When you open the run-configuration are there any problems reported when
>> hitting validate?
>>
>> Tom
>>
>> Am 07.04.11 11:39, schrieb kw3r:
>> > Same problem here. Latest 4.1 / e4 build.
>> > > kw3r
>
>
Re: error in project after using e4 wizard [message #664068 is a reply to message #664066] Thu, 07 April 2011 11:41 Go to previous messageGo to next message
Soenke Brightside is currently offline Soenke BrightsideFriend
Messages: 41
Registered: January 2011
Member
batik.util 1.7.0 and batik.util.gui 1.7.0 was used by the runtime config. I switched to 1.6.0.

Now it runs fine.
Tom Schindl wrote on Thu, 07 April 2011 07:27
Are there 2 different batik-versions and you runtime config holds 1.7.0,
instead of the required 1.6.0?

Tom

Am 07.04.11 13:05, schrieb kw3r:
> Missing Constraint: Require Bundle: org.apache.batik.util;
> bundle-version=[1.6.0,1.7.0)
>
> Tom Schindl wrote on Thu, 07 April 2011 05:58
>> When you open the run-configuration are there any problems reported when
>> hitting validate?
>>
>> Tom
>>
>> Am 07.04.11 11:39, schrieb kw3r:
>> > Same problem here. Latest 4.1 / e4 build.
>> > > kw3r
>
>

[Updated on: Thu, 07 April 2011 11:45]

Report message to a moderator

Re: error in project after using e4 wizard [message #665508 is a reply to message #664068] Thu, 14 April 2011 20:42 Go to previous message
Michael M.P. Schubert is currently offline Michael M.P. SchubertFriend
Messages: 1
Registered: July 2009
Junior Member

Hi,
I opened "run configurations"/Plug-ins and selected all Plug-ins org.apache.batic.*
After that, the e4 wizard generated application rans.

Michael
Previous Topic:XWT visual designer cannot load class from workspace
Next Topic:XWT locked on initialization in 4.1 / Linux GTK
Goto Forum:
  


Current Time: Sun Dec 21 16:41:43 GMT 2014

Powered by FUDForum. Page generated in 0.06148 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software