Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » [Resolved] Require-Bundle could not be resolved(both bundles are in my Eclipse workspace)
[Resolved] Require-Bundle could not be resolved [message #663202] Mon, 04 April 2011 10:06 Go to next message
Ahmed EL AMINE is currently offline Ahmed EL AMINE
Messages: 13
Registered: March 2011
Location: Casablanca, Morocco
Junior Member
Hi everybody, I'm still new to Virgo runtime.

I created tow bundles in my Eclipse workspace, one requiring the other. But i get an error alert that the bundle could not be resolved despite that it exists on workspace Smile

this is a screenshot about it:

http://img4.hostingpics.net/pics/254497Capture.png


I'll be very grateful for any help Smile

[Updated on: Mon, 04 April 2011 10:33]

Report message to a moderator

Re: Require-Bundle could not be resolved [message #663207 is a reply to message #663202] Mon, 04 April 2011 10:19 Go to previous messageGo to next message
Frieder Heugel is currently offline Frieder Heugel
Messages: 61
Registered: October 2010
Location: Basel, CH
Member
Hi,

take a look here. Sometimes you have to update the manifest afterwards and save it for the tooling to recognize the new bundle.

Bye
Frieder
Re: Require-Bundle could not be resolved [message #663208 is a reply to message #663207] Mon, 04 April 2011 10:32 Go to previous messageGo to next message
Ahmed EL AMINE is currently offline Ahmed EL AMINE
Messages: 13
Registered: March 2011
Location: Casablanca, Morocco
Junior Member
Oh, it works fine for me, thank you very much dear Frieder

Best Rgrds
Ahmed
Re: Require-Bundle could not be resolved [message #663217 is a reply to message #663208] Mon, 04 April 2011 11:28 Go to previous messageGo to next message
Hristo Iliev is currently offline Hristo Iliev
Messages: 156
Registered: May 2010
Location: Sofia, Bulgaria
Senior Member

Using Require-Bundle is not recommended, because of the numerous issues enumerated in the OSGi specification.

Is it possible to use Import-Package instead? This should be quite easy since you are in control of the bundles. Furthermore Eclipse supports Import-Package header in the manifest editor and the conversion should be a matter of several clicks Smile
Re: Require-Bundle could not be resolved [message #663692 is a reply to message #663217] Wed, 06 April 2011 08:35 Go to previous message
Ahmed EL AMINE is currently offline Ahmed EL AMINE
Messages: 13
Registered: March 2011
Location: Casablanca, Morocco
Junior Member
it's very nice of you, thank you for your recommendation Smile

Best Rgrds,
Ahmed
Previous Topic:Configuring Virgo for multiple instances
Next Topic:[Solved]Help with import-package
Goto Forum:
  


Current Time: Sat Oct 25 16:47:53 GMT 2014

Powered by FUDForum. Page generated in 0.02074 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software