Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Communications Framework (ECF) » XMPPS connection fails on handshake(XMPPSContainer fails to connect if server requires client certificate)
Re: XMPPS connection fails on handshake [message #663117 is a reply to message #663008] Sun, 03 April 2011 14:24 Go to previous messageGo to next message
Teddy Yueh is currently offline Teddy Yueh
Messages: 5
Registered: October 2010
Junior Member
Posted a enhancement requests here:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=341724

Since the patch would have to address the smack code error as well, would a temporary solution such as subclassing XmppConnection be acceptable?

The smack ppl seem to know about this already, but I don't see any work being done: http://issues.igniterealtime.org/browse/SMACK-322

Thanks,
Teddy

[Updated on: Sun, 03 April 2011 14:25]

Report message to a moderator

Re: XMPPS connection fails on handshake [message #663119 is a reply to message #663117] Sun, 03 April 2011 14:43 Go to previous message
Scott Lewis is currently offline Scott Lewis
Messages: 966
Registered: July 2009
Senior Member
Teddy Yueh wrote on Sun, 03 April 2011 14:24
Posted a enhancement requests here:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=341724

Since the patch would have to address the smack code error as well, would a temporary solution such as subclassing XmppConnection be acceptable?




Yes...if this would address both issues it could be done. For the first/certificate issue, my suggestion is to enhance the ECF xmpp provider to take a certificate in the IConnectContext callbacks.

Quote:


The smack ppl seem to know about this already, but I don't see any work being done: http://issues.igniterealtime.org/browse/SMACK-322

Thanks,
Teddy


I/Scott have a personal connection with Matt Tucker, Jive CTO...and could bring this up with him if it's an identifiable problem with Smack that's not being addressed. Even better would be to give them/Jive a patch with the fix for the XmppConnection issue. Feel free to connect/coordinate directly with me via the bug and/or slewis at composent.com and we'll figure out how to get this addressed.

Thanks,

Scott

Previous Topic:Eclipse CORBA Plugin problem ....
Next Topic:EDEF xml Multiple endpoint problem
Goto Forum:
  


Current Time: Mon Jul 28 02:32:43 EDT 2014

Powered by FUDForum. Page generated in 0.02832 seconds