Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Tomcat export package error(Could not find matching export for Import-Package: org.apache.tomcat; version="[6.0.29.S2-r1559,6.0.29.S2-r1559]")
Tomcat export package error [message #662877] Fri, 01 April 2011 10:53 Go to next message
Ahmed EL AMINE is currently offline Ahmed EL AMINEFriend
Messages: 13
Registered: March 2011
Location: Casablanca, Morocco
Junior Member
Hi every one,

when I deploy my web application (WAR) on Virgo, I get the following error on Tomcat's logs:

Could not find matching export for Import-Package: org.apache.tomcat; version="[6.0.29.S2-r1559,6.0.29.S2-r1559]"

I'll be very grateful if someone had a clue about that Smile

Re: Tomcat export package error [message #662880 is a reply to message #662877] Fri, 01 April 2011 11:10 Go to previous messageGo to next message
Violeta Georgieva is currently offline Violeta GeorgievaFriend
Messages: 243
Registered: October 2010
Senior Member
Hi,

This should not be a problem.
Here you can find more about this:
http://dev.eclipse.org/mhonarc/lists/virgo-dev/msg00747.html

Do you experience some problems with running your application?

Regards
Violeta
Re: Tomcat export package error [message #662965 is a reply to message #662880] Fri, 01 April 2011 15:40 Go to previous messageGo to next message
Ahmed EL AMINE is currently offline Ahmed EL AMINEFriend
Messages: 13
Registered: March 2011
Location: Casablanca, Morocco
Junior Member
Effectively it's not a problem and the application is running pretty well, but I just wanted a clean resolution for my application.

In the other hand I'm afraid that it may cause an exception in the future when the application will be much bigger.

Best Rgrds,
Ahmed
Re: Tomcat export package error [message #662972 is a reply to message #662965] Fri, 01 April 2011 16:15 Go to previous messageGo to next message
Violeta Georgieva is currently offline Violeta GeorgievaFriend
Messages: 243
Registered: October 2010
Senior Member
IMHO I don't think that the application size matters.
Also we are working on migrating to tomcat 7 then we will fix the catalina and jasper versions of import/export packages.
Re: Tomcat export package error [message #662985 is a reply to message #662972] Fri, 01 April 2011 18:01 Go to previous message
Ahmed EL AMINE is currently offline Ahmed EL AMINEFriend
Messages: 13
Registered: March 2011
Location: Casablanca, Morocco
Junior Member
Thank you for your support, that' very nice of you Smile

Rgdrs
Ahmed
Previous Topic:Shutdown issues
Next Topic:Aspectj + spring source tools + Virgo
Goto Forum:
  


Current Time: Thu Nov 20 20:58:43 GMT 2014

Powered by FUDForum. Page generated in 0.01950 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software