Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » EclipseRCP + JavaWS (problem with opening one Bundle jar)
EclipseRCP + JavaWS (problem with opening one Bundle jar) [message #662570] Thu, 31 March 2011 07:34
No real name is currently offline No real nameFriend
Messages: 1
Registered: March 2011
Junior Member
Hello everyone.
I am new to EclipseRCP platform. I have project, where I need to start EclipseRCP application with the help of javaws. I have read a lot of tutorials and documentations and finally get it to work, but ...

I am having issues when I try to use JWS + Eclipse RCP.
I have in project some external jars imported(they are osgi correct prepared bundles). Everything works perfectly good, when I run my project from inside
Eclipse IDE. (Product -> overview -> Testing -> Launch an Eclipse application). Everything works good, no exceptions.

Things get complicated, when I export my project to work with JWS(Jawa Web Start). I observe on console such a behaviour:

!ENTRY <my_plugin_name>
!STACK 0 Exception in opening zip file: C:\Users\username\Application Data\helloworld\org.eclipse.osgi\bundles\18\1\.cp\my.plugin. name.plugin.jar
at org.eclipse.osgi.framework.util.SecureAction.getZipFile(Secu
at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleFile.basicO pen(
at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleFile.getZip File(
at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleFile.checke dOpen(
at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleFile.getEnt ry(
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findCla ssImpl(
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClassImpl(
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass_LockClassLoader(
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass(
at com.sun.javaws.Launcher.doLaunchApp(
at Source)
Caused by: error in opening zip file
at Method)
at<init>(Unknown Source)
at<init>(Unknown Source)
at org.eclipse.osgi.framework.util.SecureAction.getZipFile(Secu
... 54 more

When I open my bundle under:
C:\Users\username\Application Data\helloworld\org.eclipse.osgi\bundles\18\1\.cp
and try to unpack it with other tool, it says archive is destroied or not correct.(It's capacity is much smaller from orginal *.jar file, which I have recently imported to my project)

Funny thing is some of the code works fine, some not(even when the exception is thrown).

I don't know what is going on here. Can smby help me? I can give yoiu more details, but I am not sure which one can be helpfull.
Previous Topic:how to remove context menu items of a MultiPageEditor
Next Topic:empty uncloseable views
Goto Forum:

Current Time: Wed Nov 25 04:37:33 GMT 2015

Powered by FUDForum. Page generated in 0.05140 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software