Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » e4 Workbenchmodel Editor in 3.6
e4 Workbenchmodel Editor in 3.6 [message #662172] Tue, 29 March 2011 15:38 Go to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 356
Registered: December 2010
Location: Germany
Senior Member
Hello,

is it possible to install and use the "e4 Workbenchmodel Editor" in Eclipse SDK 3.6?

I would like to write an RCP Application with Helios, that uses e4. This seems to work fine except that there is no Editor for the Workbenchmodel. Using an XML Editor to edit by hand is no good, since the Workbenchmodel is quite cryptic.

Thanks,
Christoph
Re: e4 Workbenchmodel Editor in 3.6 [message #662232 is a reply to message #662172] Tue, 29 March 2011 19:06 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5344
Registered: July 2009
Senior Member
At least it works in 3.7 so I guess it might work on 3.6 as well but why
not use Eclipse 4.1?

Tom

Am 29.03.11 08:38, schrieb Christoph Keimel:
> Hello,
>
> is it possible to install and use the "e4 Workbenchmodel Editor" in
> Eclipse SDK 3.6?
> I would like to write an RCP Application with Helios, that uses e4. This
> seems to work fine except that there is no Editor for the
> Workbenchmodel. Using an XML Editor to edit by hand is no good, since
> the Workbenchmodel is quite cryptic.
>
> Thanks,
> Christoph
Re: e4 Workbenchmodel Editor in 3.6 [message #662319 is a reply to message #662232] Wed, 30 March 2011 09:03 Go to previous messageGo to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 356
Registered: December 2010
Location: Germany
Senior Member
At the moment you could call it an experiment. If you could point me to the right plug-ins to install, I would be very grateful.

Christoph

Re: e4 Workbenchmodel Editor in 3.6 [message #662360 is a reply to message #662319] Wed, 30 March 2011 11:32 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

On 03/30/2011 05:03 AM, Christoph Keimel wrote:
> At the moment you could call it an experiment. If you could point me to
> the right plug-ins to install, I would be very grateful.

you'd probably have to add at least 2 repos:
http://download.eclipse.org/modeling/emf/emf/updates/2.7mile stones
http://download.eclipse.org/e4/updates/0.11-I-builds

Then install eclipse e4 tools ...

Later,
PW


--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/guide/workbench.htm


Re: e4 Workbenchmodel Editor in 3.6 [message #662392 is a reply to message #662172] Wed, 30 March 2011 13:59 Go to previous messageGo to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 356
Registered: December 2010
Location: Germany
Senior Member
Thanks,

it doesn't work, because there are dependencies, that go deeper:

Quote:
Missing requirement:
org.eclipse.e4.tools.compat 1.0.0.v20110217-1700)
requires 'bundle org.eclipse.core.databinding 1.4.0


I am now using Indigo 3.7 which works great.

Christoph
Re: e4 Workbenchmodel Editor in 3.6 [message #662436 is a reply to message #662392] Wed, 30 March 2011 16:20 Go to previous messageGo to next message
Kevin Smit is currently offline Kevin Smit
Messages: 8
Registered: March 2011
Junior Member
Cannot install it on 4.1 M6 also:

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse e4 Modeled Workbench (Incubation) 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOibp2U-26CA4 (org.eclipse.e4.ui.feature.feature.group 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOibp2U-26CA4)
Software currently installed: Eclipse SDK 4.1.0.I20110329-2200 (org.eclipse.sdk.ide 4.1.0.I20110329-2200)
Only one of the following can be installed at once:
Eclipse Bindings Support 0.9.0.v20110312-1200 (org.eclipse.e4.ui.bindings 0.9.0.v20110312-1200)
Eclipse Bindings Support 0.9.0.v20110217-1730 (org.eclipse.e4.ui.bindings 0.9.0.v20110217-1730)
Eclipse Bindings Support 0.9.0.v20110320-2300 (org.eclipse.e4.ui.bindings 0.9.0.v20110320-2300)
Eclipse Bindings Support 0.9.0.v20101201-1400 (org.eclipse.e4.ui.bindings 0.9.0.v20101201-1400)
Cannot satisfy dependency:
From: Eclipse e4 Rich Client Platform 1.0.0.v20101206-1400-7IA37CFTy21UqDMStkB6mt (org.eclipse.e4.rcp.feature.group 1.0.0.v20101206-1400-7IA37CFTy21UqDMStkB6mt)
To: org.eclipse.e4.ui.bindings [0.9.0.v20110320-2300]
Cannot satisfy dependency:
From: Eclipse e4 Modeled Workbench (Incubation) 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOibp2U-26CA4 (org.eclipse.e4.ui.feature.feature.group 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOibp2U-26CA4)
To: org.eclipse.e4.ui.bindings [0.9.0.v20110312-1200]
Cannot satisfy dependency:
From: Eclipse Platform 4.1.0.v20110303-9IF70GdNFnUTMd2-CFDz-QD_eAInESefNt9ARU0xgcHG f (org.eclipse.platform.feature.group 4.1.0.v20110303-9IF70GdNFnUTMd2-CFDz-QD_eAInESefNt9ARU0xgcHG f)
To: org.eclipse.rcp.feature.group [4.1.0.v20110303-9ECRFiuFqGX6Kbfv0kTa7OeNTulC]
Cannot satisfy dependency:
From: Eclipse RCP 4.1.0.v20110303-9ECRFiuFqGX6Kbfv0kTa7OeNTulC (org.eclipse.rcp.feature.group 4.1.0.v20110303-9ECRFiuFqGX6Kbfv0kTa7OeNTulC)
To: org.eclipse.e4.rcp.feature.group [1.0.0.v20101206-1400-7IA37CFTy21UqDMStkB6mt]
Cannot satisfy dependency:
From: Eclipse Project SDK 4.1.0.v20110303-7T7fA7F8Yw_bVbIsTz-gFcejoUNkZRssWoR7mCPz0215 Y (org.eclipse.sdk.feature.group 4.1.0.v20110303-7T7fA7F8Yw_bVbIsTz-gFcejoUNkZRssWoR7mCPz0215 Y)
To: org.eclipse.platform.feature.group [4.1.0.v20110303-9IF70GdNFnUTMd2-CFDz-QD_eAInESefNt9ARU0xgcH Gf]
Cannot satisfy dependency:
From: Eclipse SDK 4.1.0.I20110329-2200 (org.eclipse.sdk.ide 4.1.0.I20110329-2200)
To: org.eclipse.sdk.feature.group [4.1.0.v20110303-7T7fA7F8Yw_bVbIsTz-gFcejoUNkZRssWoR7mCPz021 5Y]
Re: e4 Workbenchmodel Editor in 3.6 [message #662453 is a reply to message #662436] Wed, 30 March 2011 16:44 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5344
Registered: July 2009
Senior Member
Looks like you try to install the Modeled Workbench-Feature. This is not
needed to get the model tooling working.

Tom

Am 30.03.11 09:20, schrieb Kevin Smit:
> Cannot install it on 4.1 M6 also:
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Eclipse e4 Modeled Workbench (Incubation)
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOibp2U-26CA4
> (org.eclipse.e4.ui.feature.feature.group
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOibp2U-26CA4)
> Software currently installed: Eclipse SDK 4.1.0.I20110329-2200
> (org.eclipse.sdk.ide 4.1.0.I20110329-2200)
> Only one of the following can be installed at once: Eclipse Bindings
> Support 0.9.0.v20110312-1200 (org.eclipse.e4.ui.bindings
> 0.9.0.v20110312-1200)
> Eclipse Bindings Support 0.9.0.v20110217-1730
> (org.eclipse.e4.ui.bindings 0.9.0.v20110217-1730)
> Eclipse Bindings Support 0.9.0.v20110320-2300
> (org.eclipse.e4.ui.bindings 0.9.0.v20110320-2300)
> Eclipse Bindings Support 0.9.0.v20101201-1400
> (org.eclipse.e4.ui.bindings 0.9.0.v20101201-1400)
> Cannot satisfy dependency:
> From: Eclipse e4 Rich Client Platform
> 1.0.0.v20101206-1400-7IA37CFTy21UqDMStkB6mt
> (org.eclipse.e4.rcp.feature.group
> 1.0.0.v20101206-1400-7IA37CFTy21UqDMStkB6mt)
> To: org.eclipse.e4.ui.bindings [0.9.0.v20110320-2300]
> Cannot satisfy dependency:
> From: Eclipse e4 Modeled Workbench (Incubation)
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOibp2U-26CA4
> (org.eclipse.e4.ui.feature.feature.group
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOibp2U-26CA4)
> To: org.eclipse.e4.ui.bindings [0.9.0.v20110312-1200]
> Cannot satisfy dependency:
> From: Eclipse Platform
> 4.1.0.v20110303-9IF70GdNFnUTMd2-CFDz-QD_eAInESefNt9ARU0xgcHG f
> (org.eclipse.platform.feature.group
> 4.1.0.v20110303-9IF70GdNFnUTMd2-CFDz-QD_eAInESefNt9ARU0xgcHG f)
> To: org.eclipse.rcp.feature.group
> [4.1.0.v20110303-9ECRFiuFqGX6Kbfv0kTa7OeNTulC]
> Cannot satisfy dependency:
> From: Eclipse RCP 4.1.0.v20110303-9ECRFiuFqGX6Kbfv0kTa7OeNTulC
> (org.eclipse.rcp.feature.group
> 4.1.0.v20110303-9ECRFiuFqGX6Kbfv0kTa7OeNTulC)
> To: org.eclipse.e4.rcp.feature.group
> [1.0.0.v20101206-1400-7IA37CFTy21UqDMStkB6mt]
> Cannot satisfy dependency:
> From: Eclipse Project SDK
> 4.1.0.v20110303-7T7fA7F8Yw_bVbIsTz-gFcejoUNkZRssWoR7mCPz0215 Y
> (org.eclipse.sdk.feature.group
> 4.1.0.v20110303-7T7fA7F8Yw_bVbIsTz-gFcejoUNkZRssWoR7mCPz0215 Y)
> To: org.eclipse.platform.feature.group
> [4.1.0.v20110303-9IF70GdNFnUTMd2-CFDz-QD_eAInESefNt9ARU0xgcH Gf]
> Cannot satisfy dependency:
> From: Eclipse SDK 4.1.0.I20110329-2200 (org.eclipse.sdk.ide
> 4.1.0.I20110329-2200)
> To: org.eclipse.sdk.feature.group
> [4.1.0.v20110303-7T7fA7F8Yw_bVbIsTz-gFcejoUNkZRssWoR7mCPz021 5Y]
Re: e4 Workbenchmodel Editor in 3.6 [message #662546 is a reply to message #662453] Thu, 31 March 2011 04:55 Go to previous message
Kevin Smit is currently offline Kevin Smit
Messages: 8
Registered: March 2011
Junior Member
OK, thanks for the support
Previous Topic:obsolete plugins in e4?
Next Topic:adding a ILookupStrategy in an AddOn (to provide access to spring beans)
Goto Forum:
  


Current Time: Tue Sep 30 13:50:58 GMT 2014

Powered by FUDForum. Page generated in 0.03297 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software