Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Supported UML versio in Indigo release
Supported UML versio in Indigo release [message #662058] Tue, 29 March 2011 02:40 Go to next message
Timothy Marc is currently offline Timothy Marc
Messages: 547
Registered: July 2009
Senior Member
Hi all,

I was wondering what UML version will be supported within the Indigo
release? Hopefully, it'll be UML 2.3, won't it?

Thanks a lot
Timothy
Re: Supported UML versio in Indigo release [message #662064 is a reply to message #662058] Tue, 29 March 2011 03:12 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4003
Registered: July 2009
Senior Member
Hi Timothy

I doubt that there will be 2.3 support for Indigo, since it's not in the
M6 API freeze milestone build.

It is perhaps more likely that there will a jump straight to UML 2.4 for
Juno since OMG is using Eclipse modeling for its development. These will
be used by OCL 2.4 and Eclipse OCL.

Regards

Ed Willink


On 29/03/2011 07:40, Timothy Marc wrote:
> Hi all,
>
> I was wondering what UML version will be supported within the Indigo
> release? Hopefully, it'll be UML 2.3, won't it?
>
> Thanks a lot
> Timothy
Re: Supported UML versio in Indigo release [message #662269 is a reply to message #662058] Tue, 29 March 2011 19:37 Go to previous messageGo to next message
Vlad Varnica is currently offline Vlad Varnica
Messages: 546
Registered: July 2009
Location: Milton Keynes - UK
Senior Member
The upgrade is not really a big job therefore few tools will do it sooner or later.
If modeling plugins are not upgraded then only compilation and plugin dependencies errors would have to be fixed for Indigo with the Helios previous code as source.

Re: Supported UML versio in Indigo release [message #685316 is a reply to message #662269] Fri, 17 June 2011 05:02 Go to previous messageGo to next message
st oehm is currently offline st oehm
Messages: 79
Registered: October 2009
Member
hi
i have a kind of noob question?
what is the actual supported uml version?
is it 2.2?
and espacially what is the version of the uml.ecore?
thanks for help

stoehm

[Updated on: Fri, 17 June 2011 05:08]

Report message to a moderator

Re: Supported UML versio in Indigo release [message #685352 is a reply to message #685316] Fri, 17 June 2011 06:07 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4003
Registered: July 2009
Senior Member
Hi

The UML2 project is currently UML 2.2. The model changes for 2.3/2.4 are
pretty small, so using 2.2 is not a problem.

There is talk of a UML 2.4 move soon, which should be much simplified by
the use of Eclipse by the OMG representatives to model UML 2.4.

Regards

Ed Willink

On 17/06/2011 10:02, stoehm wrote:
> hi
> i have a kind of noob question?
> what is the actual supported uml version?
> is it 2.2?
> thanks for help
>
> stoehm
Re: Supported UML versio in Indigo release [message #685370 is a reply to message #685352] Fri, 17 June 2011 07:30 Go to previous messageGo to next message
st oehm is currently offline st oehm
Messages: 79
Registered: October 2009
Member
thanks, that was the information i needed
Re: Supported UML versio in Indigo release [message #693799 is a reply to message #685352] Thu, 07 July 2011 04:26 Go to previous messageGo to next message
Timothy Marc is currently offline Timothy Marc
Messages: 547
Registered: July 2009
Senior Member
Ed,

well, any change within the UML 2.x series will be small, but in fact for
UML 2.2 -> 2.3/2.4 there are some very significant changes regarding port
handling and the definitions of interactions.

I'd really appreciate a migration/support for at least UML 2.3. That would
ease my work tremendously.

Timothy

"Ed Willink" schrieb im Newsbeitrag news:itf8f5$c1d$1@news.eclipse.org...

Hi

The UML2 project is currently UML 2.2. The model changes for 2.3/2.4 are
pretty small, so using 2.2 is not a problem.

There is talk of a UML 2.4 move soon, which should be much simplified by
the use of Eclipse by the OMG representatives to model UML 2.4.

Regards

Ed Willink

On 17/06/2011 10:02, stoehm wrote:
> hi
> i have a kind of noob question?
> what is the actual supported uml version?
> is it 2.2?
> thanks for help
>
> stoehm
Re: Supported UML versio in Indigo release [message #693845 is a reply to message #693799] Thu, 07 July 2011 05:13 Go to previous message
Ed Willink is currently offline Ed Willink
Messages: 4003
Registered: July 2009
Senior Member
Hi Timothy

When I wrote that the changes are small, I meant that the changes in the
class-defining behaviour that defines UML's own behaviour are small.
Ports and interactions are part of the modelled functionality that might
just work once a UML-2.3.ecore is used to re-build the UML2 models. You
can certainly find a UML-2.4.ecore in the UML 2.4 distributions, and be
moderately confident that it will work; it's what the OMG
representatives did in order to produce it in the first place.

Regards

Ed Willink

On 07/07/2011 09:26, Timothy Marc wrote:
> Ed,
>
> well, any change within the UML 2.x series will be small, but in fact
> for UML 2.2 -> 2.3/2.4 there are some very significant changes
> regarding port handling and the definitions of interactions.
>
> I'd really appreciate a migration/support for at least UML 2.3. That
> would ease my work tremendously.
>
> Timothy
>
> "Ed Willink" schrieb im Newsbeitrag
> news:itf8f5$c1d$1@news.eclipse.org...
>
> Hi
>
> The UML2 project is currently UML 2.2. The model changes for 2.3/2.4 are
> pretty small, so using 2.2 is not a problem.
>
> There is talk of a UML 2.4 move soon, which should be much simplified by
> the use of Eclipse by the OMG representatives to model UML 2.4.
>
> Regards
>
> Ed Willink
>
> On 17/06/2011 10:02, stoehm wrote:
>> hi
>> i have a kind of noob question?
>> what is the actual supported uml version?
>> is it 2.2?
>> thanks for help
>>
>> stoehm
>
Previous Topic:Implementation of (all) constraints - is it intended?
Next Topic:UML2 installation question
Goto Forum:
  


Current Time: Tue Jul 22 09:25:52 EDT 2014

Powered by FUDForum. Page generated in 0.01847 seconds