Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0.0)
Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0.0) [message #661495] Thu, 24 March 2011 22:42 Go to next message
Olivier Croquette is currently offline Olivier CroquetteFriend
Messages: 4
Registered: February 2011
Junior Member
Hi !

I am currently reading the book Eclipse RCP. I went through the chapters 1 to 14 without any big issue, but now I am completely blocked at chapter 17.

The problem is the following :
Full log

Excerpt :
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0.0)"
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.5.0.v20090525.jar/ was not resolved.
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.update.configurator_3.3.0.v20090312.jar/ was not resolved.
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-03-24 23:30:06.768
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.5.0.v20090525.jar/ was not resolved.
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.update.configurator_3.3.0.v20090312.jar/ was not resolved.
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-03-24 23:30:06.770
!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-03-24 23:30:06.770
!MESSAGE Missing imported package org.eclipse.core.internal.runtime.auth_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-03-24 23:30:06.770
!MESSAGE Bundle org.eclipse.update.configurator_3.3.0.v20090312 [2] was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2011-03-24 23:30:06.770
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).



The workspace can be found there :
http://ocroquette.fr/a/eclipse-rcp/workspace4.zip

I have already spent hours on this issue. I can reproduce it under both MacOS X and Windows, with a clean Eclipse installation (I tried both Galileo and Helios). What is especially ununderstandable is that the difference between chapter 14 and 17 is really not that big.

I am really stuck and would appreciate any help...

Thanks !

Best regards

Olivier
Re: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0. [message #661730 is a reply to message #661495] Sat, 26 March 2011 20:27 Go to previous messageGo to next message
Olivier Croquette is currently offline Olivier CroquetteFriend
Messages: 4
Registered: February 2011
Junior Member
Hi again !

Could anyone help me with this issue ? I am really blocked. Thanks in advance for any hint !

Re: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0. [message #661897 is a reply to message #661495] Mon, 28 March 2011 13:17 Go to previous messageGo to next message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

What if you delete and re-create your launch config? Then if that
doesn't work, have a look at your launch config and make sure
org.eclipse.equinox.common bundle is included.

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/guide/workbench.htm


Re: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0. [message #662002 is a reply to message #661897] Mon, 28 March 2011 20:06 Go to previous message
Olivier Croquette is currently offline Olivier CroquetteFriend
Messages: 4
Registered: February 2011
Junior Member
Many thanks Paul, you put me on the right track.
I used to right click on my product, and do "Run as / Eclipse application" from there. It used to work with the previous samples from the book, but starting with chapter 16, it doesn't anymore obviously.

I have created a brand new configuration and it worked. I still have to investigate what's wrong exactly, but at least my application is starting now. Many plugins I don't need are contributing to the toolbars, indicating that the application is still carrying too much plugins, and I will have to look into this too.

Thanks again !
Previous Topic:Product configuration (features included)
Next Topic:Dynamic menu pagination
Goto Forum:
  


Current Time: Sun Dec 21 16:49:56 GMT 2014

Powered by FUDForum. Page generated in 0.01960 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software