Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » [AGR] Capturing odd selection in workbench
[AGR] Capturing odd selection in workbench [message #66280] Thu, 13 April 2006 16:02 Go to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-Schwartz
Messages: 448
Registered: July 2009
Senior Member
Hi.

I have a couple of actions that are listeners for selection change
events in a custom built view. For reasons I do not understand, when I
run my plugin within AGR, it appears as though my actions catch a
selection change event where the object that is being propagated in the
event is of type:

org.eclipse.hyades.models.common.testprofile.impl.TPFTestSui teImpl

What is this about? Any suggestion on why is it happening? I do not run
into a similar situation when I run my plugin independently of AGR.

TIA,
Barbara
Re: [AGR] Capturing odd selection in workbench [message #66551 is a reply to message #66280] Thu, 13 April 2006 19:52 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 404
Registered: July 2009
Senior Member
Hmmm...
All I can tell you is that
org.eclipse.hyades.models.common.testprofile.impl.TPFTestSui teImpl is the
model representation of a test suite. I have no idea what your selection
listeners are listening on. I'm assuming that your actions are listening on
some selection that is bounded to your view. If the selections are strictly
bounded by the view (e.g. they're not shared resources), then this shouldn't
be happening.
Sorry Barbara, I'm really puzzled by this.


"Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
news:e1lspi$3do$1@utils.eclipse.org...
> Hi.
>
> I have a couple of actions that are listeners for selection change
> events in a custom built view. For reasons I do not understand, when I
> run my plugin within AGR, it appears as though my actions catch a
> selection change event where the object that is being propagated in the
> event is of type:
>
> org.eclipse.hyades.models.common.testprofile.impl.TPFTestSui teImpl
>
> What is this about? Any suggestion on why is it happening? I do not run
> into a similar situation when I run my plugin independently of AGR.
>
> TIA,
> Barbara
Re: [AGR] Capturing odd selection in workbench [message #66679 is a reply to message #66551] Fri, 14 April 2006 10:08 Go to previous messageGo to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-Schwartz
Messages: 448
Registered: July 2009
Senior Member
Ali Mehregani wrote:
> Hmmm...
> All I can tell you is that
> org.eclipse.hyades.models.common.testprofile.impl.TPFTestSui teImpl is the
> model representation of a test suite. I have no idea what your selection
> listeners are listening on. I'm assuming that your actions are listening on
> some selection that is bounded to your view. If the selections are strictly
> bounded by the view (e.g. they're not shared resources), then this shouldn't
> be happening.
> Sorry Barbara, I'm really puzzled by this.
>
>
> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
> news:e1lspi$3do$1@utils.eclipse.org...
>> Hi.
>>
>> I have a couple of actions that are listeners for selection change
>> events in a custom built view. For reasons I do not understand, when I
>> run my plugin within AGR, it appears as though my actions catch a
>> selection change event where the object that is being propagated in the
>> event is of type:
>>
>> org.eclipse.hyades.models.common.testprofile.impl.TPFTestSui teImpl
>>
>> What is this about? Any suggestion on why is it happening? I do not run
>> into a similar situation when I run my plugin independently of AGR.
>>
>> TIA,
>> Barbara
>
>

Ali,

Thanks for your reply.

My actions are listening to a JFace TreeViewer that is registered as a
selection provider with the workbench and I do not believe they should
be listening to anything else. Should I enter an issue in Bugzilla under
TPTP? What do you suggest?

Thanks,
B.
Re: [AGR] Capturing odd selection in workbench [message #66804 is a reply to message #66679] Mon, 17 April 2006 14:42 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 404
Registered: July 2009
Senior Member
You can open a bugzilla if you can provide me with a way to reproduce the
problem (e.g. isolating the problem in a simple plug-in that creates a
similar tree viewer. You can attach the plug-in and provide me with steps
of reproducing it). I can't fix this if I don't have any clue of how to
reproduce it.

Thanks.


"Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
news:e1nscn$t3e$1@utils.eclipse.org...
> Ali Mehregani wrote:
> > Hmmm...
> > All I can tell you is that
> > org.eclipse.hyades.models.common.testprofile.impl.TPFTestSui teImpl is
the
> > model representation of a test suite. I have no idea what your
selection
> > listeners are listening on. I'm assuming that your actions are
listening on
> > some selection that is bounded to your view. If the selections are
strictly
> > bounded by the view (e.g. they're not shared resources), then this
shouldn't
> > be happening.
> > Sorry Barbara, I'm really puzzled by this.
> >
> >
> > "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in
message
> > news:e1lspi$3do$1@utils.eclipse.org...
> >> Hi.
> >>
> >> I have a couple of actions that are listeners for selection change
> >> events in a custom built view. For reasons I do not understand, when I
> >> run my plugin within AGR, it appears as though my actions catch a
> >> selection change event where the object that is being propagated in the
> >> event is of type:
> >>
> >> org.eclipse.hyades.models.common.testprofile.impl.TPFTestSui teImpl
> >>
> >> What is this about? Any suggestion on why is it happening? I do not run
> >> into a similar situation when I run my plugin independently of AGR.
> >>
> >> TIA,
> >> Barbara
> >
> >
>
> Ali,
>
> Thanks for your reply.
>
> My actions are listening to a JFace TreeViewer that is registered as a
> selection provider with the workbench and I do not believe they should
> be listening to anything else. Should I enter an issue in Bugzilla under
> TPTP? What do you suggest?
>
> Thanks,
> B.
Re: [AGR] Capturing odd selection in workbench [message #66867 is a reply to message #66804] Mon, 17 April 2006 19:15 Go to previous message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-Schwartz
Messages: 448
Registered: July 2009
Senior Member
Ali Mehregani wrote:
> You can open a bugzilla if you can provide me with a way to reproduce the
> problem (e.g. isolating the problem in a simple plug-in that creates a
> similar tree viewer. You can attach the plug-in and provide me with steps
> of reproducing it). I can't fix this if I don't have any clue of how to
> reproduce it.
>
> Thanks.
>
>

Ali,

I do understand your need to have a test case for this problem. I will
see if I can come up with something illustrative.

Thanks,
B.
Previous Topic:Total time spent in method
Next Topic:AGR: How to locate one widget in EditorPart when setting verfiy point
Goto Forum:
  


Current Time: Thu Oct 30 18:20:33 GMT 2014

Powered by FUDForum. Page generated in 0.06235 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software