Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Problem w/ Virgo 'updated manifest' after deployment
Problem w/ Virgo 'updated manifest' after deployment [message #659996] Wed, 16 March 2011 14:16 Go to next message
gkontos  is currently offline gkontos Friend
Messages: 10
Registered: January 2011
Junior Member
It appears as though one of the manifest import packages is dropped after I deploy my bundle. The original bundle manifest (as published in the logs) has an import package directive of org.quartz, but later in the log files it appears as though virgo creates and uses an updated manifest file which no longer has this imported package. I am assuming at this point that this manifest update is done by virgo, but I don't really know.

In any event, this causes a ClassNotFoundException. Is there a way for me to get virgo to keep this imported package in the manifest?

I've kept copies of the relevant parts of the log files if the additional information will be useful.

Thanks!
Re: Problem w/ Virgo 'updated manifest' after deployment [message #660019 is a reply to message #659996] Wed, 16 March 2011 14:56 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Virgo is not supposed to remove imports from manifests. However there are known issues where the tooling clobbers the manifest. Please would you check the stage directory to see what manifest the tooling has produced.
Re: Problem w/ Virgo 'updated manifest' after deployment [message #660031 is a reply to message #660019] Wed, 16 March 2011 15:29 Go to previous messageGo to next message
gkontos  is currently offline gkontos Friend
Messages: 10
Registered: January 2011
Junior Member
No problem. Here's what it looks like. The import package is in there.
Re: Problem w/ Virgo 'updated manifest' after deployment [message #660040 is a reply to message #660031] Wed, 16 March 2011 16:00 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Ok, then that's strange, so please could you attach the log (serviceability/logs/log.log) for me to take a look? The forum software seems not to like files with no extension, so it may be best to zip the log first.
Re: Problem w/ Virgo 'updated manifest' after deployment [message #660438 is a reply to message #660040] Fri, 18 March 2011 12:46 Go to previous messageGo to next message
gkontos  is currently offline gkontos Friend
Messages: 10
Registered: January 2011
Junior Member
Unfortunately I didn't save the whole log file, just part of it. I ended up switching things around so that the quartz jar was in the WEB-INF/lib directory and then my bundle exported those packages. Attached is the part of the log that I saved...
Re: Problem w/ Virgo 'updated manifest' after deployment [message #660467 is a reply to message #660438] Fri, 18 March 2011 14:43 Go to previous message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Unfortunately that log doesn't show the problem. org.quartz is imported before and after the import expansion handler has run. Please confirm you see the same.
Previous Topic:Problem with JDBC driver not being found after bundle refresh
Next Topic:[Solved]RAP and Virgo
Goto Forum:
  


Current Time: Mon Dec 22 20:02:34 GMT 2014

Powered by FUDForum. Page generated in 0.06479 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software