Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » [Solved]RAP and Virgo
[Solved]RAP and Virgo [message #659959] Wed, 16 March 2011 07:26 Go to next message
Tidus is currently offline Tidus
Messages: 16
Registered: March 2011
Junior Member
Hello,

I need help to do RAP working with Virgo.
I follow all instructions there: http://eclipsesource.com/blogs/2010/10/28/running-rap-on-vir go/

But i get some error and i don't understand why. All packages are here. Could you help me?

[2011-03-16 12:21:02.879] startup-tracker              <KE0001I> Kernel starting. 
[2011-03-16 12:21:06.966] startup-tracker              <KE0002I> Kernel started. 
[2011-03-16 12:21:07.099] system-artifacts             <DE0000I> Installing plan 'org.eclipse.virgo.kernel.userregion.springdm' version '2.1.0'. 
[2011-03-16 12:21:07.215] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-03-16 12:21:07.257] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-03-16 12:21:07.276] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-03-16 12:21:07.291] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.agent.dm' version '2.1.0.RELEASE'. 
[2011-03-16 12:21:07.305] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.deployer.dm' version '2.1.0.RELEASE'. 
[2011-03-16 12:21:08.279] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-03-16 12:21:08.283] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-03-16 12:21:08.288] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-03-16 12:21:08.292] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.agent.dm' version '2.1.0.RELEASE'. 
[2011-03-16 12:21:08.295] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.deployer.dm' version '2.1.0.RELEASE'. 
[2011-03-16 12:21:08.298] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.kernel.userregion.springdm' version '2.1.0'. 
[2011-03-16 12:21:08.321] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.kernel.userregion.springdm' version '2.1.0'. 
[2011-03-16 12:21:08.328] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-03-16 12:21:08.332] start-signalling-1           <DE0005I> Started bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-03-16 12:21:08.335] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-03-16 12:21:08.680] start-signalling-1           <DE0005I> Started bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-03-16 12:21:08.690] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-03-16 12:21:08.699] start-signalling-1           <DE0005I> Started bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-03-16 12:21:08.710] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.kernel.agent.dm' version '2.1.0.RELEASE'. 
[2011-03-16 12:21:08.726] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.kernel.agent.dm' version '2.1.0.RELEASE'. 
[2011-03-16 12:21:08.737] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.kernel.deployer.dm' version '2.1.0.RELEASE'. 
[2011-03-16 12:21:08.857] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.kernel.deployer.dm' version '2.1.0.RELEASE'. 
[2011-03-16 12:21:08.861] start-signalling-1           <DE0005I> Started plan 'org.eclipse.virgo.kernel.userregion.springdm' version '2.1.0'. 
[2011-03-16 12:21:08.867] Thread-2                     <UR0001I> User region ready. 
[2011-03-16 12:21:09.875] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'rap-demo.plan'. 
[2011-03-16 12:21:09.918] fs-watcher                   <DE0000I> Installing plan 'virgo-rap-demo' version '1.3.1'. 
[2011-03-16 12:21:09.939] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.osgi.services' version '3.3.0.v20110110'. 
[2011-03-16 12:21:09.958] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.equinox.preferences' version '3.4.0.v20110124-0830'. 
[2011-03-16 12:21:09.971] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.equinox.app' version '1.3.100.v20110110'. 
[2011-03-16 12:21:09.991] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.core.commands' version '3.6.0.I20110111-0800'. 
[2011-03-16 12:21:10.006] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.core.jobs' version '3.5.100.v20101008'. 
[2011-03-16 12:21:10.022] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.core.contenttype' version '3.4.100.v20101203-1034'. 
[2011-03-16 12:21:10.033] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.core.runtime' version '3.7.0.v20110110'. 
[2011-03-16 12:21:10.046] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.core.expressions' version '3.4.200.v20100505'. 
[2011-03-16 12:21:10.056] fs-watcher                   <DE0000I> Installing bundle 'com.ibm.icu.base' version '4.2.1.v20100412'. 
[2011-03-16 12:21:10.081] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.help' version '3.5.0.v20100524'. 
[2011-03-16 12:21:10.129] fs-watcher                   <DE0000I> Installing bundle 'org.mortbay.jetty.util' version '6.1.23.v201012071420'. 
[2011-03-16 12:21:10.170] fs-watcher                   <DE0000I> Installing bundle 'org.mortbay.jetty.server' version '6.1.23.v201012071420'. 
[2011-03-16 12:21:10.189] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.equinox.registry' version '3.5.100.v20101101'. 
[2011-03-16 12:21:10.205] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.equinox.http.registry' version '1.1.100.v20101101'. 
[2011-03-16 12:21:10.216] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.equinox.http.servlet' version '1.1.100.v20101204'. 
[2011-03-16 12:21:10.226] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.equinox.http.jetty' version '2.0.0.v20100503'. 
[2011-03-16 12:21:10.356] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.rap.rwt' version '1.4.0.20110201-1534'. 
[2011-03-16 12:21:10.456] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.rap.rwt.q07' version '1.4.0.20110201-1534'. 
[2011-03-16 12:21:10.579] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.rap.jface' version '1.4.0.20110201-1534'. 
[2011-03-16 12:21:10.931] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.rap.ui.workbench' version '1.4.0.20110201-1534'. 
[2011-03-16 12:21:11.139] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.rap.ui' version '1.4.0.20110201-1534'. 
[2011-03-16 12:21:11.151] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.rap.ui.views' version '1.4.0.20110201-1534'. 
[2011-03-16 12:21:11.218] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.rap.demo' version '1.4.0.20110201-1534'. 
[2011-03-16 12:21:12.622] fs-watcher                   <ME0001W> A message with the key 'ME0003I' was not found. The inserts for the message were '[serviceability/dump/2011-03-16-12-21-267]' 
[2011-03-16 12:21:12.631] fs-watcher                   <DE0002E> Installation of plan 'virgo-rap-demo' version '1.3.1' failed. org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'org.eclipse.equinox.preferences' at version '3.4.0.v20110124-0830': Cannot resolve: org.eclipse.equinox.preferences
    Resolver report:
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.equinox.preferences_3.4.0.v20110124-0830>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.contenttype_3.4.100.v20101203-1034>
             constraint: <Require-Bundle: org.eclipse.equinox.preferences; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.runtime_3.7.0.v20110110>
             constraint: <Require-Bundle: org.eclipse.osgi; bundle-version="[3.7.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.expressions_3.4.200.v20100505>
             constraint: <Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.3.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.help_3.5.0.v20100524>
             constraint: <Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.6.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.equinox.registry_3.5.100.v20101101>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.equinox.http.registry_1.1.100.v20101101>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="0.0.0">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.jface_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.core.commands; bundle-version="[3.4.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.ui.workbench_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.6.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.ui_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.6.0,4.0.0)">
        An Import-Package could not be resolved. Caused by missing constraint in bundle <org.eclipse.equinox.common_3.6.0.v20110110>
             constraint: <Import-Package: org.eclipse.equinox.log; version="[1.0.0,2.0.0)">
        The bundle could not be resolved because another singleton bundle was selected. In bundle <org.eclipse.osgi_3.7.0.v20110124-0830>
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.jface.databinding_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.rap.jface; bundle-version="[1.2.0,2.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.databinding_1.4.0.I20110111-0800>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.equinox.app_1.3.100.v20110110>
             constraint: <Require-Bundle: org.eclipse.equinox.registry; bundle-version="[3.4.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.jobs_3.5.100.v20101008>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.commands_3.6.0.I20110111-0800>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.demo_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.rap.ui; bundle-version="0.0.0">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.ui.views_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.databinding.observable_1.3.0.I20100824-0800>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.databinding.property_1.3.0.I20110111-0800>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">

	at org.eclipse.virgo.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiResolveStage.java:45)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:271)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:151)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:123)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:190)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deployIfNotDeployed(HotDeploymentFileSystemListener.java:186)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:87)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:636)

[Updated on: Sat, 19 March 2011 13:12]

Report message to a moderator

Re: RAP and Virgo [message #659966 is a reply to message #659959] Wed, 16 March 2011 08:27 Go to previous messageGo to next message
Florian Waibel is currently offline Florian Waibel
Messages: 94
Registered: June 2010
Member
Hi Tidus,

please download RAP 1.3 [1] to use with Virgo 2.1.0.RELEASE. The current milestone version of RAP 1.4 depends on Equinox 3.7.x

...
constraint: <Require-Bundle: org.eclipse.osgi; bundle-version="[3.7.0,4.0.0)">
...


Virgo 2.1.0.RELEASE uses Equinox 3.6.1
0	ACTIVE      org.eclipse.osgi_3.6.1.R36x_v20100806


Note: With the instructions from the blog post it is *not* possible to run RAP 1.4.x on Virgo 3.0.x (@see [2]). I'll write a followup post as soon as we manage to run RAP 1.4 on Virgo 3.0.

Hope this helps,
florian

[1] http://eclipse.org/rap/downloads/1.3/
[2] http://www.eclipse.org/forums/index.php?t=msg&th=205622& amp;start=0
Re: RAP and Virgo [message #660589 is a reply to message #659959] Sat, 19 March 2011 13:12 Go to previous message
Tidus is currently offline Tidus
Messages: 16
Registered: March 2011
Junior Member
That works perfectly.
Thanks Smile
Previous Topic:Problem w/ Virgo 'updated manifest' after deployment
Next Topic:VIRGO is a wrong name!
Goto Forum:
  


Current Time: Wed Aug 20 04:51:42 EDT 2014

Powered by FUDForum. Page generated in 0.01571 seconds