Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » ETL - How to Handle Metamodel Extensions
ETL - How to Handle Metamodel Extensions [message #659732] Tue, 15 March 2011 12:10 Go to next message
As Sa is currently offline As Sa
Messages: 5
Registered: February 2010
Junior Member
Hi Dimitris,

I have a metamodel with a containment called extensions of type = meta-class 'AbstractExtension'
AbstractExtension can be extended in new metamodels to extend the modelling notation.

I have recently changed to use Helios and this version of Epsilon: 0.9.0.201101251228

The problem is that my ETL rules no longer trigger when source is a metaclass of the new extension metamodel.

e.g. Neither of these rules are triggered...

rule test
transform s : Source!NewMetaClass
to t : Target!OldMetaClass{
"TEST".println();
}
rule test2
transform s : SourceExtension!NewMetaClass
to t : Target!OldMetaClass{
"TEST".println();
}

Where NewMetaClass extends AbstractExtension.
Source is the source model with the old Metamodel
SourceExtension is the same source model with the new extension metamodel.

By the way, if you type NewMetaClass incorrectly it gives an exception so it is finding this metaclass.

Also, the following finds an instance of the new metaclass...
@greedy
rule test
transform s : Source!AbstractExtension
to t : Target!NewMetaClass{
"TEST".println();
s.name.println();
}


The same rules used to work ok in the old Galileo version of Epsilon 0.8.9.201004151115

Has something changed? Am I doing something wrong?

Regards
Asieh

Re: ETL - How to Handle Metamodel Extensions [message #660017 is a reply to message #659732] Wed, 16 March 2011 14:54 Go to previous message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 867
Registered: July 2009
Senior Member
Hi Asiah,

Could you please send me a minimal configuration I can use to reproduce this at epsilon.devs gmail com?

Cheers,
Dimitris
Previous Topic:[EVL] NoSuchMethodError in exported plugin
Next Topic:[Eugenia] link creation problem
Goto Forum:
  


Current Time: Sat Sep 20 00:01:59 GMT 2014

Powered by FUDForum. Page generated in 0.04109 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software