Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » e4.1 M6 missing requirements
e4.1 M6 missing requirements [message #659704] Tue, 15 March 2011 09:54 Go to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello,

I just downloaded e4.1M6 and tried to install some additional features
using the latest available version. This fails because of missing
requirements.

A) feature to install:
Eclipse e4 Modeled Workbench (Incubation)
0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4

error message:
Cannot complete the install because one or more required items could not
be found.
Software being installed: Eclipse e4 Modeled Workbench (Incubation)
0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4
(org.eclipse.e4.ui.feature.feature.group
0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4)
Missing requirement: Eclipse e4 Modeled Workbench (Incubation)
0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4
(org.eclipse.e4.ui.feature.feature.group
0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4) requires
'org.eclipse.emf.databinding.feature.group [1.0.0.v200808251517,2.0.0)'
but it could not be found



B) feature to install:
Eclipse e4 Tools (Incubation) 0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD

error message:
Cannot complete the install because one or more required items could not
be found.
Software being installed: Eclipse e4 Tools (Incubation)
0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD
(org.eclipse.e4.core.tools.feature.feature.group
0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD)
Missing requirement: Liveeditor 0.9.0.v20110309-1400
(org.eclipse.e4.tools.emf.liveeditor 0.9.0.v20110309-1400) requires
'bundle org.eclipse.emf.edit 2.6.0' but it could not be found
Cannot satisfy dependency:
From: Eclipse e4 Tools (Incubation)
0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD
(org.eclipse.e4.core.tools.feature.feature.group
0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD)
To: org.eclipse.e4.tools.emf.liveeditor [0.9.0.v20110309-1400]


I use only the default configured update sites:
- e4 0.11 IBuild Updates
http://download.eclipse.org/e4/updates/0.11-I-builds
- e4 build 20110310-1400
http://download.eclipse.org/e4/updates/0.11-I-builds/I201103 10-1400
- Indigo http://download.eclipse.org/releases/indigo
- The Eclipse IBuild Updates
http://download.eclipse.org/eclipse/updates/4.1-I-builds


Do I have to add some additional update sites?

Regards,
Lars
Re: e4.1 M6 missing requirements [message #659710 is a reply to message #659704] Tue, 15 March 2011 10:07 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5487
Registered: July 2009
Senior Member
Is the "contact other updatesites" checked? The problem might be that
you the Indigo repo does not contain the latest EMF-Bundles could you
try adding
http://download.eclipse.org/modeling/emf/emf/updates/2.7mile stones/base/
and see if this helps?

Tom

Am 15.03.11 10:54, schrieb Lars Fischer:
> Hello,
>
> I just downloaded e4.1M6 and tried to install some additional features
> using the latest available version. This fails because of missing
> requirements.
>
> A) feature to install:
> Eclipse e4 Modeled Workbench (Incubation)
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4
>
> error message:
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: Eclipse e4 Modeled Workbench (Incubation)
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4
> (org.eclipse.e4.ui.feature.feature.group
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4)
> Missing requirement: Eclipse e4 Modeled Workbench (Incubation)
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4
> (org.eclipse.e4.ui.feature.feature.group
> 0.9.1.v20110121-1000-7B9n7DFPJtAHosNOdbq4U-26CA4) requires
> 'org.eclipse.emf.databinding.feature.group [1.0.0.v200808251517,2.0.0)'
> but it could not be found
>
>
>
> B) feature to install:
> Eclipse e4 Tools (Incubation) 0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD
>
> error message:
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: Eclipse e4 Tools (Incubation)
> 0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD
> (org.eclipse.e4.core.tools.feature.feature.group
> 0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD)
> Missing requirement: Liveeditor 0.9.0.v20110309-1400
> (org.eclipse.e4.tools.emf.liveeditor 0.9.0.v20110309-1400) requires
> 'bundle org.eclipse.emf.edit 2.6.0' but it could not be found
> Cannot satisfy dependency:
> From: Eclipse e4 Tools (Incubation)
> 0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD
> (org.eclipse.e4.core.tools.feature.feature.group
> 0.9.0.v20110309-1330-57f1EVVFNMFaKy8PoFD)
> To: org.eclipse.e4.tools.emf.liveeditor [0.9.0.v20110309-1400]
>
>
> I use only the default configured update sites:
> - e4 0.11 IBuild Updates
> http://download.eclipse.org/e4/updates/0.11-I-builds
> - e4 build 20110310-1400
> http://download.eclipse.org/e4/updates/0.11-I-builds/I201103 10-1400
> - Indigo http://download.eclipse.org/releases/indigo
> - The Eclipse IBuild Updates
> http://download.eclipse.org/eclipse/updates/4.1-I-builds
>
>
> Do I have to add some additional update sites?
>
> Regards,
> Lars
>
Re: e4.1 M6 missing requirements [message #659720 is a reply to message #659710] Tue, 15 March 2011 10:45 Go to previous message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello Tom,

On 15.03.2011 11:07, Tom Schindl wrote:
> Is the "contact other updatesites" checked? The problem might be that
> you the Indigo repo does not contain the latest EMF-Bundles could you
> try adding
> http://download.eclipse.org/modeling/emf/emf/updates/2.7mile stones/base/
> and see if this helps?

The "contact other updatesites" flag was checked.

After adding your suggested update site I still got the error. But now
there is an other automatically added update site, which was not
enabled: "http://www.eclipse.org/modeling/updates/".
Activating it, the calculation of dependencies has passed and now the
installation is (still) running.

Thank you for your help!

Regards,
Lars
Previous Topic:How to add property in existing SWT component
Next Topic:Exception on startup after siwtching to M6
Goto Forum:
  


Current Time: Sun Dec 21 02:08:23 GMT 2014

Powered by FUDForum. Page generated in 0.01593 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software