Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » AM3 » Newbie: Can't install AM3
Newbie: Can't install AM3 [message #658445] Tue, 08 March 2011 14:50 Go to next message
Sergey Metcherin is currently offline Sergey Metcherin
Messages: 14
Registered: February 2011
Junior Member
Good day, colleagues!

I need to install AM3 because I had following error when running ATL UML2OWL build.xml script:

UML2OWL\build.xml:33: Problem: failed to create task or type am3.loadModel

So, I followed all the instructions there: http://wiki.eclipse.org/AM3/How_Install_New_AM3_From_SVN

But I completely don't undestand last step:

AM3 is ready to be tested. Just open the "Plug-in Development perspective" and launch a Run-time workbench (Click on Run -> Run as -> Run-time workbench).

I open Plug-in Development perspective, open Plug-ins tab, see AM3 packages, but I don't see, where should I click to obtain Run -> Run as -> Run-time workbench? What is Run-time workbench?
Re: Newbie: Can't install AM3 [message #658453 is a reply to message #658445] Tue, 08 March 2011 15:12 Go to previous messageGo to next message
Guillaume Doux is currently offline Guillaume Doux
Messages: 56
Registered: July 2009
Member
Hello Sergey,

First, thanks for your interest Smile

To use ANT scripts, you do not need to use the new AM3, you should use the old one.

You can find the installation instructions on this page:
http://wiki.eclipse.org/AM3/How_Install_AM3_From_SVN

For the "Click on Run -> Run as -> Run-time workbench", you have to go in the "run" menu of Eclipse (on the same bar than "file" "edit",...). After that it should start a fresh eclipse from the first one.
The fresh Eclipse, will be your runtime workbench. It is used when you develop plug-ins. It allows you to develop the plug-ins in a first Eclipse and then to test and use them in a second one. As a consequence, you have to use this when you are using the plug-ins from sources and not from jars.
To be able to launch your script, you should put the project containing your script in the new Eclipse, and not in the one containing the plug-ins sources.

I hope my answer will help you.

Best regards,

Guillaume
Re: Newbie: Can't install AM3 [message #658520 is a reply to message #658453] Tue, 08 March 2011 19:58 Go to previous messageGo to next message
Sergey Metcherin is currently offline Sergey Metcherin
Messages: 14
Registered: February 2011
Junior Member
Thank you for the quick answer.

Now I've done all instructions from http://wiki.eclipse.org/AM3/How_Install_AM3_From_SVN

again except the last step. The problem is when I go to the Run -> Run As, I see only inactive option "(none applicable)"

If I go to the Run -> Run Configurations and then press "Run", it seems that AM3 is not installed because there are no AM3 Plugins in Help -> About Eclipse -> Installation Details and my ATL script gives the same error.

If I just go to Run -> Run, I see "The selection cannot be launched and there are no recent launches".

So, I'm in deadlock.

One more question - should I launch second Eclipse instance every time to work with AM3? Is there a way to just install AM3 and forget about it?

[Updated on: Tue, 08 March 2011 20:02]

Report message to a moderator

Re: Newbie: Can't install AM3 [message #670403 is a reply to message #658445] Fri, 13 May 2011 21:39 Go to previous messageGo to next message
soha  is currently offline soha
Messages: 1
Registered: May 2011
Junior Member
I am having the same problem .. i hope you found a solution for this problem
and if the tool worked correctly at some point.
Thanks
Re: Newbie: Can't install AM3 [message #690072 is a reply to message #658445] Tue, 28 June 2011 22:55 Go to previous message
miryam  is currently offline miryam
Messages: 2
Registered: May 2011
Junior Member
Hi.
i have a project which is the generation of an ontology owl using the mda approach.so i have downloaded the projects UML2OWL and UML2OWL update, i tried to use the second one, now it works. but the resulted ontology it is not a valid ontology when i use protégé. the resulted ontology with the first project it was valid. would you plz help me choosing the right project, my purpose is to optain a valid owl ontology.

Miryam
Previous Topic:[AM3] AM3-Injector "xml to ecore" doesn't work!
Next Topic:Can't get AM3 to work with ATL 3.2 in Indigo
Goto Forum:
  


Current Time: Sat Oct 25 13:31:47 GMT 2014

Powered by FUDForum. Page generated in 0.09099 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software