Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Shortcuts are gone after reopening the diagram file
Shortcuts are gone after reopening the diagram file [message #658431] Tue, 08 March 2011 13:50 Go to next message
Thomas Buchmann is currently offline Thomas BuchmannFriend
Messages: 53
Registered: November 2010
Member
Hi,

i added shortcuts to domain model elements already present in other diagrams to my GMF Editor following these instructions:

http://www.eclipse.org/newsportal/article.php?id=14391&g roup=eclipse.modeling.gmf#14391

It works fine, but i'm facing the problem that after reopening my editor, all shortcuts are gone. What can i do to solve this problem?

Regards,
Thomas
Re: Shortcuts are gone after reopening the diagram file [message #658680 is a reply to message #658431] Wed, 09 March 2011 13:15 Go to previous messageGo to next message
Thomas Buchmann is currently offline Thomas BuchmannFriend
Messages: 53
Registered: November 2010
Member
I found out that the shortcuts are being persisted in the diagram file. However, once i reopen it, the editor does not display the shortcut and also the editor gets dirty.

Maybe someone has a clue what's wrong.
Re: Shortcuts are gone after reopening the diagram file [message #658912 is a reply to message #658431] Thu, 10 March 2011 12:32 Go to previous messageGo to next message
Thomas Buchmann is currently offline Thomas BuchmannFriend
Messages: 53
Registered: November 2010
Member
The reason was the generated code in the CanonicalEditPolicy of the container object. The method refreshSemantic() removes all views that can not be associated with a semantic element that is contained in the respective container.

After manual code adjustments, it works fine now.

[Updated on: Thu, 10 March 2011 12:33]

Report message to a moderator

Re: Shortcuts are gone after reopening the diagram file [message #664702 is a reply to message #658912] Mon, 11 April 2011 16:08 Go to previous messageGo to next message
Elle  is currently offline Elle Friend
Messages: 6
Registered: April 2011
Location: Cairo, Egypt
Junior Member

Were you able to add the shortcuts to the domain model? Because I am now facing the some problem =(
Re: Shortcuts are gone after reopening the diagram file [message #664764 is a reply to message #658912] Mon, 11 April 2011 21:40 Go to previous message
LD  is currently offline LD Friend
Messages: 28
Registered: March 2011
Junior Member
Hi. Which manual code adjustments you did? I'm facing the same problem.

Is it on eclipse modeling 3.6, isn't?

Thanks.
Previous Topic:Create Diagram with initial Content
Next Topic:Using Ecorediag Resources Headless
Goto Forum:
  


Current Time: Fri Dec 19 22:53:46 GMT 2014

Powered by FUDForum. Page generated in 0.02051 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software