Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » GWT missing requirement
GWT missing requirement [message #658379] Tue, 08 March 2011 09:16 Go to next message
fehrin2  is currently offline fehrin2
Messages: 4
Registered: April 2010
Junior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello,

I am trying to install the latest Orbit p2 bundle over eclipse 3.6.2
(Vista/JDK 64bit) but i get an error for
Google Web Toolkit User Library (with source)
saying
Cannot complete the install because one or more required items could not
be found.
Software being installed: Google Web Toolkit User Library (with
source) 2.1.0.v20101206-1430 (com.google.gwt.user 2.1.0.v20101206-1430)
Missing requirement: Google Web Toolkit User Library (with source)
2.1.0.v20101206-1430 (com.google.gwt.user 2.1.0.v20101206-1430) requires
'com.google.gwt.user com.google.gwt.user.browser.runtime [1.0.0,2.0.0)'
but it could not be found
I cannot find the latter anywhere in the net.

Best regards

Franz
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNdfPeAAoJEETPNNlkrKDy8x0H/3koUU3o7YoG6qgmzKkF 7ism
fcNw2iBbvP9fnD3OA0TtOpUkXTs3tvPnb7GC5vw0ObfVG09nnby1Pkawj+Hq gHv1
Wu0SPy/R5RHnIT15tBidzeS/zuOqZd1grdBJIbgrkUzkCil6WMM/aSecSgOD YS87
YcZqMjok1DGrAaHv5/0S3LtehlRiSdyFWkUtkS5FjGM8u0dMAWeSNaQR8IWD LscA
1yb8qDUVcIcGAyoazyp9EoviyBAuw5dxFSrmbTtiQN4oEfzQc4AonYCYb3+3 Ln5z
WJDNfjhvvm6l1Pk2ALVP7v5LQx3HwAi4hENu3n19okd8jSmJ/q/UJmfB41BW Rl4=
=SfdK
-----END PGP SIGNATURE-----
Re: GWT missing requirement [message #658380 is a reply to message #658379] Tue, 08 March 2011 09:18 Go to previous messageGo to next message
fehrin2  is currently offline fehrin2
Messages: 4
Registered: April 2010
Junior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I used
http://download.eclipse.org/tools/orbit/downloads/drops/S201 10304120314/repository/
as update site but the issue was present with all Orbit p2 bundles i
tried so far.


Am 08.03.2011 10:16, schrieb Franz Fehringer:
> Hello,
>
> I am trying to install the latest Orbit p2 bundle over eclipse 3.6.2
> (Vista/JDK 64bit) but i get an error for
> Google Web Toolkit User Library (with source)
> saying
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: Google Web Toolkit User Library (with
> source) 2.1.0.v20101206-1430 (com.google.gwt.user 2.1.0.v20101206-1430)
> Missing requirement: Google Web Toolkit User Library (with source)
> 2.1.0.v20101206-1430 (com.google.gwt.user 2.1.0.v20101206-1430) requires
> 'com.google.gwt.user com.google.gwt.user.browser.runtime [1.0.0,2.0.0)'
> but it could not be found
> I cannot find the latter anywhere in the net.
>
> Best regards
>
> Franz
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNdfR4AAoJEETPNNlkrKDyqtoH/R/wZbUWTYHOzXNrC+jx /MwH
r+JZrB/qHFCy9vIW12XTeFwhZR9bjEo/glpjUqs13YTKr8UHZUKrrnmXcDCd L6eS
ckh9gVc5qKzjPexeZmC8tTfLsfnUJ5FlV4I7bBXkb75xZV59QuRV4bCMDxTo 4lv9
WHfuyYLGyRGb4EF54ElnUh3UCMBN5ATb3GGfHGJlayMb40rBRAFtMVaMf1Ui V8in
iW1xyWwgU14qVxP/jQBvfurS6BSvD2qrllN3IM2HBdpZxiSO4zMa56N9uOc/ +ptb
xSWq7h7iyTYAxnahTzymPyBy6eWzhmJOB6PvLT8aGDTKCJ70S/AFdm2BIaBv Vn4=
=fJ5U
-----END PGP SIGNATURE-----
Re: GWT missing requirement [message #658419 is a reply to message #658379] Tue, 08 March 2011 13:02 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 451
Registered: July 2009
Senior Member
Hi,

Am 08.03.2011 10:16, schrieb Franz Fehringer:
> I am trying to install the latest Orbit p2 bundle over eclipse 3.6.2
> (Vista/JDK 64bit) but i get an error for
> Google Web Toolkit User Library (with source)

The GWT User Library must not be installed _into_ an Eclipse
installation. It's only of use in a target platform.

http://www.modumind.com/2008/04/21/why-create-a-custom-targe t-platform/

-Gunnar

--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
Re: GWT missing requirement [message #658423 is a reply to message #658419] Tue, 08 March 2011 13:20 Go to previous messageGo to next message
fehrin2  is currently offline fehrin2
Messages: 4
Registered: April 2010
Junior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

So how do i know which Orbit plugins are to be installed into an Eclipse
installation?

Am 08.03.2011 14:02, schrieb Gunnar Wagenknecht:
> Hi,
>
> Am 08.03.2011 10:16, schrieb Franz Fehringer:
>> I am trying to install the latest Orbit p2 bundle over eclipse 3.6.2
>> (Vista/JDK 64bit) but i get an error for
>> Google Web Toolkit User Library (with source)
>
> The GWT User Library must not be installed _into_ an Eclipse
> installation. It's only of use in a target platform.
>
> http://www.modumind.com/2008/04/21/why-create-a-custom-targe t-platform/
>
> -Gunnar
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNdi0SAAoJEETPNNlkrKDyPsEH/ilM4a14hSFzM/1vVX+w F7SN
JsL9kJnngjJkTcgorTI0VA8ft5cK4LYzU5ef6P3M8h3QXqfiKT+NONIUgb2z 75v/
3RHK9p+BswMEhQ1kdLKdqbHRIJPhAH+L6HGlLJoTz8DfT0LZF4G5s4x2JfG7 3BCs
S5SEilzD6JYi2I7CJ6RkZCNl0xehJeeN+13MVWlMrL2uk/8IBUiPOk/xjyhV FxmD
+hOVCecoMe7mxreQ3qq/jvIwWdqdkTZoFShblNObl9MYsiFlPQC82OIyG1Nj ZDiH
kaJjyQ+ElP8e3cvlOn+ordL5ZTIhq9ejGOWqrJoSG1dP1HFcBvUfr9RqZ/AZ HZk=
=3z2s
-----END PGP SIGNATURE-----
Re: GWT missing requirement [message #658508 is a reply to message #658423] Tue, 08 March 2011 19:02 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 451
Registered: July 2009
Senior Member
Am 08.03.2011 14:20, schrieb Franz Fehringer:
> So how do i know which Orbit plugins are to be installed into an Eclipse
> installation?

Usually you don't need to care. When you install plug-ins into Eclipse
p2 will automatically resolve any dependencies from referenced/known
sites. P2 will also ensure that only working bundles will be installed.
The things in Orbit don't provide any functionality to Eclipse
out-of-the box. They are 3rdparty libraries packed as OSGi bundles which
are then used by Eclipse plug-ins.

-Gunnar


--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
Re: GWT missing requirement [message #903417 is a reply to message #658508] Thu, 23 August 2012 14:44 Go to previous messageGo to next message
Oliver Koch is currently offline Oliver Koch
Messages: 40
Registered: June 2012
Member
Am 08.03.2011 20:02, schrieb Gunnar Wagenknecht:
> Am 08.03.2011 14:20, schrieb Franz Fehringer:
>> So how do i know which Orbit plugins are to be installed into an Eclipse
>> installation?
>
> Usually you don't need to care. When you install plug-ins into Eclipse
> p2 will automatically resolve any dependencies from referenced/known
> sites. P2 will also ensure that only working bundles will be installed.
> The things in Orbit don't provide any functionality to Eclipse
> out-of-the box. They are 3rdparty libraries packed as OSGi bundles which
> are then used by Eclipse plug-ins.
>
> -Gunnar
>
>
So far, when adding certain features of orbit to an eclipse target
platform, there happen to be no errors in resolving any dependencies.
But when selecting the all orbit entry on the update site, the error
with GWT appears when resolving the target platform contents
Re: GWT missing requirement [message #903576 is a reply to message #903417] Fri, 24 August 2012 11:52 Go to previous message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 451
Registered: July 2009
Senior Member
Am 23.08.2012 16:44, schrieb Oliver Koch:
> So far, when adding certain features of orbit to an eclipse target
> platform, there happen to be no errors in resolving any dependencies.
> But when selecting the all orbit entry on the update site, the error
> with GWT appears when resolving the target platform contents

The GWT user bundle has a dependency that will never be satisfiable. It
was introduced in order to prevent it ever from being installed and
started into a running framework.

Thus, whenever you want to work with the GWT User bundle you need to
uncheck "Include required software" and check "Include all environments".

HTH,
Gunnar

--
Gunnar Wagenknecht
gunnar@xxxxxxxx
http://wagenknecht.org/
Previous Topic:org.w3c.dom.svg broken in Eclipse 3.7?
Next Topic:How to use logback Orbit bundles?
Goto Forum:
  


Current Time: Fri Sep 19 07:50:22 GMT 2014

Powered by FUDForum. Page generated in 0.02283 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software