Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Installation of EGit - Error("An error occurred while collecting items to be installed")
Installation of EGit - Error [message #658310] Mon, 07 March 2011 15:03 Go to next message
Steve Ardis is currently offline Steve Ardis
Messages: 3
Registered: March 2011
Junior Member
Receiving error message:
An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.egit,0.11.3
No repository found containing: osgi.bundle,org.eclipse.egit.core,0.11.3
No repository found containing: osgi.bundle,org.eclipse.egit.core.source,0.11.3
No repository found containing: osgi.bundle,org.eclipse.egit.doc,0.11.3
No repository found containing: org.eclipse.update.feature,org.eclipse.egit,0.11.3
No repository found containing: org.eclipse.update.feature,org.eclipse.egit.mylyn,0.11.3
No repository found containing: osgi.bundle,org.eclipse.egit.mylyn.ui,0.11.3
No repository found containing: osgi.bundle,org.eclipse.egit.mylyn.ui.source,0.11.3
No repository found containing: org.eclipse.update.feature,org.eclipse.egit.source,0.11.3
No repository found containing: osgi.bundle,org.eclipse.egit.ui,0.11.3
No repository found containing: osgi.bundle,org.eclipse.egit.ui.source,0.11.3
No repository found containing: osgi.bundle,org.eclipse.jgit,0.11.3
No repository found containing: org.eclipse.update.feature,org.eclipse.jgit,0.11.3


Using the update site: http://download.eclipse.org/egit/updates

Eclipse Version: Helios Service Release 2
Build id: 20110301-1815

The eclipse installation is fully up to date.

Any suggestions?


Thanks -
Steve Ardis
Re: Installation of EGit - Error [message #658323 is a reply to message #658310] Mon, 07 March 2011 16:17 Go to previous messageGo to next message
Steve Ardis is currently offline Steve Ardis
Messages: 3
Registered: March 2011
Junior Member
Note, I was able to install EGit through the Eclipse Marketplace after updating STS from 2.5.1 to 2.5.2 (was receiving a mylyn issue without doing this update).

But, could still not install through the update site.


Steve Ardis
Re: Installation of EGit - Error [message #658560 is a reply to message #658310] Tue, 08 March 2011 19:07 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 548
Registered: July 2009
Senior Member
Do you also have helios [1] in the list of p2 repositories for installation ?
This only has egit 0.11.1 as 0.11.3 was too late to get included into Helios SR2. 0.11.3 is only available from [2] or the marketplace. Maybe you didn't check the option "Contact all update sites during install to find required software". Alternatively you may try to disable [1] and try installing from [2] only.

[1] http://download.eclipse.org/releases/helios
[2] http://download.eclipse.org/egit/updates
Re: Installation of EGit - Error [message #658770 is a reply to message #658560] Wed, 09 March 2011 13:08 Go to previous messageGo to next message
Steve Ardis is currently offline Steve Ardis
Messages: 3
Registered: March 2011
Junior Member
I'm not quite sure I understand.


    In "Available Software Sites", I had [1] and [2] "Enabled".

    In the "Work with" section, I had selected [2] and chose "Eclipse Git Team Provider (Incubation)".

    "Contact all updates sites during install to find required software" was selected


[1] http://download.eclipse.org/releases/helios
[2] http://download.eclipse.org/egit/updates


I have since installed EGit through the Eclipse Marketplace and everything works perfectly.

If I have to reinstall Eclipse at any point and have problems again, I will try disabling [1] and only installing from [2].


Thank you for your quick response -
Steve Ardis



Re: Installation of EGit - Error [message #666826 is a reply to message #658770] Fri, 22 April 2011 16:52 Go to previous message
Dave M is currently offline Dave M
Messages: 1
Registered: April 2011
Junior Member
Installing Egit through Eclipse was giving me problems as well, however it worked flawlessly through the marektplace.
Many, many thanks for updating the thread with that bit of info.
Previous Topic:CheckoutConflictException during Pull
Next Topic:Missing requirement while installing EGit Mylyn GitHub
Goto Forum:
  


Current Time: Wed Jul 30 23:22:19 EDT 2014

Powered by FUDForum. Page generated in 0.01618 seconds