Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Internal error GitDecoratorJob NullPointerException(I get an internal error when I try to use EGit)
Internal error GitDecoratorJob NullPointerException [message #658024] Sat, 05 March 2011 07:28 Go to next message
Kustaa Nyholm is currently offline Kustaa Nyholm
Messages: 10
Registered: July 2009
Junior Member
I got this error when I tried to deploy EGit in my project:

An internal error occurred during: "GitDecoratorJob[/Users/nyholku/jDraftProject/.git]".
java.lang.NullPointerException

this is with the latest Helios and EGit


Eclipse JGit (Incubation) 0.11.3 org.eclipse.jgit.feature.group

Eclipse SDK 3.6.2.M20110210-1200 org.eclipse.sdk.ide

Anything I could try or should I file a bug?

br Kusti
Re: Internal error GitDecoratorJob NullPointerException [message #658230 is a reply to message #658024] Mon, 07 March 2011 13:59 Go to previous messageGo to next message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
Hi Kusti,

please open a bug with the stacktrace of the Exception from the Eclipse
Error Log view.

Thanks and Best Regards,
Stefan

"Kustaa Nyholm" <kustaa.nyholm@planmeca.com> wrote in message
news:iksoad$mjm$1@news.eclipse.org...
>I got this error when I tried to deploy EGit in my project:
>
> An internal error occurred during:
> "GitDecoratorJob[/Users/nyholku/jDraftProject/.git]".
> java.lang.NullPointerException
>
> this is with the latest Helios and EGit
>
>
> Eclipse JGit (Incubation) 0.11.3 org.eclipse.jgit.feature.group
>
> Eclipse SDK 3.6.2.M20110210-1200 org.eclipse.sdk.ide
>
> Anything I could try or should I file a bug?
>
> br Kusti
>
Re: Internal error GitDecoratorJob NullPointerException [message #658241 is a reply to message #658024] Mon, 07 March 2011 14:49 Go to previous message
Kustaa Nyholm is currently offline Kustaa Nyholm
Messages: 10
Registered: July 2009
Junior Member
Hi Stefan,

thanks for answering. I will see if I can re-procude the case (to generate the stack trace) as I've 'solved' the problem.

The problem was that there was file in the project which I think was actually a link/alias and which was somehow damaged. I could not even delete it from the workspace/project. In the end I opened the '.project' file and deleted every reference to that file, I think it was in a section called 'linked something'

I will see if my Time Machine has a copy of the damager .project file so I can file a proper bug report.

Anyway, it looks clear that GitDecoratorJob chokes on a bad file in the 'project' and does not gracefully ignore or report it.

br Kusti
Previous Topic:Team -> Share Project not decorating associating with Git Repostiory
Next Topic:How to use Merge Tool
Goto Forum:
  


Current Time: Tue Oct 21 20:01:46 GMT 2014

Powered by FUDForum. Page generated in 0.03084 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software