Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » IncompatibleClassChangeError when upgrading to 2.6.2(Upgrade woes)
IncompatibleClassChangeError when upgrading to 2.6.2 [message #657778] Fri, 04 March 2011 01:14 Go to next message
Mike  is currently offline Mike
Messages: 2
Registered: March 2011
Junior Member
Hi,

I'm getting an IncompatibleClassChangeError when I try to render a report using 2.6.2 after upgrading from 2.5.

I have all the jars from ReportEngine/lib in my classpath and my eclipse Report Designer is 2.6.2 too.

Any ideas? Thanks.

java.lang.IncompatibleClassChangeError: Expecting non-static method org.eclipse.birt.report.model.metadata.MetaDataDictionary.in tializeExtension()V
at org.eclipse.birt.report.model.api.impl.DesignEngineImpl.init ialize(DesignEngineImpl.java:99)
at org.eclipse.birt.report.model.api.impl.DesignEngineImpl.newS essionHandle(DesignEngineImpl.java:147)
at org.eclipse.birt.report.model.api.DesignEngine.newSessionHan dle(DesignEngine.java:120)
at org.eclipse.birt.report.engine.parser.ReportParser.getDesign Handle(ReportParser.java:143)
at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.o penReportDesign(ReportEngineHelper.java:255)
at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.o penReportDesign(ReportEngineHelper.java:183)
at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.o penReportDesign(ReportEngineHelper.java:160)
at org.eclipse.birt.report.engine.api.impl.ReportEngine.openRep ortDesign(ReportEngine.java:398)

Re: IncompatibleClassChangeError when upgrading to 2.6.2 [message #657930 is a reply to message #657778] Fri, 04 March 2011 16:19 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Mike,

Is your birt home set to a 2.6.2 runtime?

Jason

On 3/3/2011 8:14 PM, Mike wrote:
> Hi,
>
> I'm getting an IncompatibleClassChangeError when I try to render a
> report using 2.6.2 after upgrading from 2.5.
>
> I have all the jars from ReportEngine/lib in my classpath and my eclipse
> Report Designer is 2.6.2 too.
> Any ideas? Thanks.
>
> java.lang.IncompatibleClassChangeError: Expecting non-static method
> org.eclipse.birt.report.model.metadata.MetaDataDictionary.in
> tializeExtension()V
> at org.eclipse.birt.report.model.api.impl.DesignEngineImpl.init
> ialize(DesignEngineImpl.java:99)
> at org.eclipse.birt.report.model.api.impl.DesignEngineImpl.newS
> essionHandle(DesignEngineImpl.java:147)
> at org.eclipse.birt.report.model.api.DesignEngine.newSessionHan
> dle(DesignEngine.java:120)
> at org.eclipse.birt.report.engine.parser.ReportParser.getDesign
> Handle(ReportParser.java:143)
> at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.o
> penReportDesign(ReportEngineHelper.java:255)
> at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.o
> penReportDesign(ReportEngineHelper.java:183)
> at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.o
> penReportDesign(ReportEngineHelper.java:160)
> at org.eclipse.birt.report.engine.api.impl.ReportEngine.openRep
> ortDesign(ReportEngine.java:398)
>
Re: IncompatibleClassChangeError when upgrading to 2.6.2 [message #657967 is a reply to message #657930] Fri, 04 March 2011 18:26 Go to previous message
Mike  is currently offline Mike
Messages: 2
Registered: March 2011
Junior Member
Doh! Embarrassed That's it. Thanks for the quick reply.


Previous Topic:Proxy error
Next Topic:BIRT EXCEL OUTPUT
Goto Forum:
  


Current Time: Fri Oct 31 23:06:22 GMT 2014

Powered by FUDForum. Page generated in 0.01723 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software