Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Code comments broken ?
Code comments broken ? [message #657117] Tue, 01 March 2011 16:08 Go to next message
Tomasz Rakowski is currently offline Tomasz Rakowski
Messages: 2
Registered: October 2009
Junior Member
I've downloaded a fresh release of eclipse, then updated it using the build in update tool to version:

Eclipse IDE for PHP Developers 1.3.1.20100916-1202

After the upgrade, I'm unable to comment block of code, using menu or keyboard shortcut.

I'm on mac, using 64 bit version.

Anyone else experienced this problem ?

Is there a way to fix it ?

Thanks
Re: Code comments broken ? [message #657417 is a reply to message #657117] Wed, 02 March 2011 17:39 Go to previous messageGo to next message
Eclipse User
Originally posted by: ng.tomo.at

yes, toggle comments is broken on windows too:

Eclipse IDE for PHP Developers 1.3.2.20110301-1807
Eclipse Platform 3.6.2.M20110210-1200
EPP PHP Feature 1.3.2.20110301-1807

Error Log does not show any errors.


Am 01.03.2011 17:08, schrieb Tomasz Rakowski:
> I've downloaded a fresh release of eclipse, then updated it using the
> build in update tool to version:
>
> Eclipse IDE for PHP Developers 1.3.1.20100916-1202
>
> After the upgrade, I'm unable to comment block of code, using menu or
> keyboard shortcut.
> I'm on mac, using 64 bit version.
> Anyone else experienced this problem ?
>
> Is there a way to fix it ?
>
> Thanks
Re: Code comments broken ? [message #658834 is a reply to message #657417] Wed, 09 March 2011 23:24 Go to previous messageGo to next message
Toby Lieven is currently offline Toby Lieven
Messages: 1
Registered: March 2011
Junior Member
Sigh, I just updated to fix the compare editor not working bug and now Rolling Eyes . Oh well, yucky /* */ comments here I come Smile

If anyone finds a fix, that'd be lovely.
Re: Code comments broken ? [message #658837 is a reply to message #658834] Wed, 09 March 2011 23:38 Go to previous messageGo to next message
Eclipse User
Originally posted by: ng.tomo.at

see this post: news://news.eclipse.org:119/ikhfao$fsb$1@news.eclipse.org
download url is http://sourceforge.jp/projects/pdt-tools/releases/51060


Am 01.03.2011 01:47, schrieb Toshihiro Izumi:
> I noticed another issue...
> Toggle Comment, Add/Remove Block Comment, they don't work in PHP Editor.
>
> I added bug fixed plugin org.eclipse.php.ui_2.2.1.v20101001-2300.jar.
> Try it when you were blown down by this malfunction.
>


Am 10.03.2011 00:24, schrieb Toby Lieven:
> Sigh, I just updated to fix the compare editor not working bug and now
> :roll: . Oh well, yucky /* */ comments here I come :)
> If anyone finds a fix, that'd be lovely.
icon10.gif  Re: Code comments broken ? [message #673234 is a reply to message #658837] Mon, 23 May 2011 00:11 Go to previous messageGo to next message
Derby  is currently offline Derby
Messages: 1
Registered: May 2011
Junior Member
I tried the listed repair and it worked perfectly. I can now toggle comments on the selected text using the [Source->Toggle Comments] menu item in Eclipse PDT. I can also toggle comments using Ctrl + /

I have updated the entire Eclipse PDT program earlier this year.

I have noticed this problem many many times.

The system I have is: Windows XP Home Edition on a Celeron CPU.

Here is what I did:

1) I went to the url listed in the message I am replying to. I can describe the
url as follows: It is at source forge dot jp projects pdt-tools releases 51060
At this url I left clicked the php ui jar file as
this filename: org.eclipse.php.ui_2.2.1.v20101001-2300.jar and saved the file
to my hard disk.

2) I moved the original file with the same name from the following location:
C:\Program Files\eclipse\plugins
to a different location on my hard disk for safe keeping
(although I did not need this file ever again).

3) I copied the download jar file to C:\Program Files\eclipse\plugins.

4) I opened up a command prompt window and typed the following:
C:\>cd\Program Files
C:\>cd eclipse
C:\>eclipse -clean

Now it is fixed and working perfect. Such a beautiful solution, I just wanted
a nice description for others. Thanks everyone for this wonderful solution.
Re: Code comments broken ? [message #725887 is a reply to message #673234] Fri, 16 September 2011 05:31 Go to previous message
Freddy Angel is currently offline Freddy Angel
Messages: 4
Registered: April 2011
Location: Brisbane, Australia
Junior Member
it worked for me!

Thanks
Previous Topic:UTF-8 - without BOM
Next Topic:CSS code editor assist suggest not working
Goto Forum:
  


Current Time: Thu Oct 23 06:11:01 GMT 2014

Powered by FUDForum. Page generated in 0.27122 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software