Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » (Resolved) Subversive integration for m2eclipse fail, won't install
(Resolved) Subversive integration for m2eclipse fail, won't install [message #656490] Fri, 25 February 2011 16:42 Go to next message
Jordan Hein is currently offline Jordan Hein
Messages: 8
Registered: July 2009
Junior Member
I have installed m2eclipse (0.12.1.20110112-1712 org.maven.ide.eclipse.feature.feature.group) and am now attempting to install the subversive integration for m2eclipse plugin using this update site ( http://www.polarion.org/projects/subversive/download/integra tions/update-site/) but the installation fails with this error.

Cannot complete the install because of a conflicting dependency.
Software being installed: Subversive Integration for the M2Eclipse Project 1.0.2.I20110223-1700 (org.polarion.eclipse.team.svn.m2eclipse.feature.group 1.0.2.I20110223-1700)
Software currently installed: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)
Only one of the following can be installed at once:
Maven Integration for Eclipse 0.12.1.20110112-1712 (org.maven.ide.eclipse 0.12.1.20110112-1712)
Maven Integration for Eclipse 0.12.0.20101115-1102 (org.maven.ide.eclipse 0.12.0.20101115-1102)
Maven Integration for Eclipse 0.10.2.20100623-1649 (org.maven.ide.eclipse 0.10.2.20100623-1649)
Maven Integration for Eclipse 0.10.0.20100209-0800 (org.maven.ide.eclipse 0.10.0.20100209-0800)
Cannot satisfy dependency:
From: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)
To: org.maven.ide.eclipse [0.12.1.20110112-1712]
Cannot satisfy dependency:
From: Subversive Integration for the M2Eclipse Project 1.0.2.I20110223-1700 (org.polarion.eclipse.team.svn.m2eclipse.feature.group 1.0.2.I20110223-1700)
To: org.maven.ide.eclipse [0.10.0,0.11.0)



[Updated on: Mon, 28 February 2011 12:58]

Report message to a moderator

Re: Subversive integration for m2eclipse fail, won't install [message #656546 is a reply to message #656490] Sat, 26 February 2011 12:16 Go to previous messageGo to next message
Michael Pellaton is currently offline Michael Pellaton
Messages: 289
Registered: July 2009
Senior Member
Hi

Please refer to this [1] Bug and see the workaround I found in comment
14 [2].

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=330896
[2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=330896#c14

HTH
Michael
PS: If somebody knows how to reopen the bug, please let me know...
Re: Subversive integration for m2eclipse fail, won't install [message #656605 is a reply to message #656490] Sun, 27 February 2011 09:09 Go to previous messageGo to next message
Alexander Gurov is currently offline Alexander Gurov
Messages: 76
Registered: July 2009
Member
There is the new version of the Subversive-m2eclipse integration available, it contains fix for the issue.
Re: Subversive integration for m2eclipse fail, won't install [message #656827 is a reply to message #656490] Mon, 28 February 2011 12:58 Go to previous message
Jordan Hein is currently offline Jordan Hein
Messages: 8
Registered: July 2009
Junior Member
Thank you, its working like a champ now. Smile
Previous Topic:How to reopen a subversive bug?
Next Topic:Check-out failed before completion, now what?
Goto Forum:
  


Current Time: Wed Apr 16 16:00:40 EDT 2014

Powered by FUDForum. Page generated in 0.01883 seconds