Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Force uninstall of legacy feature
Force uninstall of legacy feature [message #656036] Wed, 23 February 2011 20:21
David  is currently offline David Friend
Messages: 4
Registered: February 2011
Junior Member
Let me try and give a simple example which illustrates my problem::

Version 1.0 of my Eclipse PDE product contained two features:
- Feature1 contains a load of plug-ins
- Feature2 contains one plug-in "PluginX" (version 1.0)

With version 2.0 of my product, I want to remove Feature2 altogether, and move PluginX (now at version 2.0) to Feature1.

However, I think this means that a user of version 1.0 of my product must firstly uninstall Feature2 v1.0 before updating to version 2.0. Otherwise, if Feature2 remains installed, it depends on PluginX version 1.0, so Eclipse refuses to install PluginX version 2.0 over it.

Does anyone know of any way around this problem, other than continuing to provide Feature2, or requiring users to uninstall v1.0 before updating to 2.0?

Hope this isn't too abstract Smile Thanks in advance
Previous Topic:Feature Versioning
Next Topic:Getting nullpointerexception while fetching current runtime project
Goto Forum:
  


Current Time: Thu Nov 27 23:23:44 GMT 2014

Powered by FUDForum. Page generated in 0.01440 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software