Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Eclipse hangs when opening specific files(Some more complex PHP files take between 30 and 300 seconds to open)
Eclipse hangs when opening specific files [message #655976] Wed, 23 February 2011 10:37 Go to next message
Richard L. is currently offline Richard L.
Messages: 4
Registered: February 2011
Junior Member
Hi.
I have had this issue on Windows Vista and now on Windows 7 64bit using Eclipse 32bit (couldn't get 64bit to work).
Java 6 Update 23.

Most files are perfectly fine, but there are a few files (created by my predecessor) that hang Eclipse for anything between half a minute to 5 minutes. Eclipse becomes unresponsive, and my computer's fans speed up considerably after a bit.

I have a suspicion it has to do with the error/syntax checking feature, but I haven't quite figured out which of the many features to turn off to make the pages load faster.

I also haven't figured out yet what makes one page load normally and others not - it could simply be the amount of complexity in the page, i.e. mixing PHP, HTML and JavaScript code, sometimes using echo and sometimes closing PHP tags.

Is there anything I can do about this?

Which options/settings are the most likely to help speed up loading these pages?

Thanks!

[edit]
... oh, forgot - once such a file opens, making changes to it is also very slow - sometimes it takes 2 seconds per typed character for it to show up. That's another thing that I am hoping someone has a remedy for. My guess is that the two issues are linked and that the same solution will apply to both.

Thanks!

[Updated on: Wed, 23 February 2011 10:48]

Report message to a moderator

Re: Eclipse hangs when opening specific files [message #656734 is a reply to message #655976] Mon, 28 February 2011 05:26 Go to previous messageGo to next message
dominik is currently offline dominik
Messages: 122
Registered: July 2009
Senior Member
On 2011-02-23 16:37, Richard L. wrote:
> Is there anything I can do about this?
>
> Which options/settings are the most likely to help speed up loading these pages?

Probably You have to less memory set for eclipse. Then it will struggle to
allocate something. Try to increase this.

/dmc
Re: Eclipse hangs when opening specific files [message #656770 is a reply to message #656734] Mon, 28 February 2011 09:35 Go to previous messageGo to next message
Richard L. is currently offline Richard L.
Messages: 4
Registered: February 2011
Junior Member
Thanks for the reply.
I read up on it a little and made changes in the eclipse.ini file - no change so far, it is still hanging for the same file. But I don't know if the changes I made are sufficient.

Here's my eclipse.ini file:
-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.1.R36x_v20100810
-product
org.eclipse.epp.package.php.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
512M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
512m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms256m
-Xmx512m
- 


I changed every value with an "m" at the end, but didn't add anything else since I have no idea what else I might need.

Any thoughts?

Thanks!

Re: Eclipse hangs when opening specific files [message #656780 is a reply to message #656770] Mon, 28 February 2011 10:00 Go to previous messageGo to next message
dominik is currently offline dominik
Messages: 122
Registered: July 2009
Senior Member
On 2011-02-28 15:35, Richard L. wrote:
> Thanks for the reply.
> I read up on it a little and made changes in the eclipse.ini file - no change so
> far, it is still hanging for the same file. But I don't know if the changes I
> made are sufficient.
(...)
> I changed every value with an "m" at the end, but didn't add anything else since
> I have no idea what else I might need.
>
> Any thoughts?

Use Eclipse memory debug tool, this is small widget that shows used memory. Also
You need to run eclipse in debug mode.
Watch Error Log for events, probably something is going on there and that
information might be useful.

/dmc
Re: Eclipse hangs when opening specific files [message #656781 is a reply to message #656780] Mon, 28 February 2011 10:10 Go to previous messageGo to next message
Richard L. is currently offline Richard L.
Messages: 4
Registered: February 2011
Junior Member
Not sure if I can run it in Debug mode - I am only editing local files with Eclipse, then I upload them using a different program...

Will debug still work?
If so, can you point me towards a tutorial for using debugging mode?

Thanks!
Re: Eclipse hangs when opening specific files [message #657015 is a reply to message #656781] Tue, 01 March 2011 06:20 Go to previous messageGo to next message
dominik is currently offline dominik
Messages: 122
Registered: July 2009
Senior Member
On 2011-02-28 16:10, Richard L. wrote:
> Not sure if I can run it in Debug mode - I am only editing local files with
> Eclipse, then I upload them using a different program...
>
> Will debug still work?
> If so, can you point me towards a tutorial for using debugging mode?

Sure:
http://www.eclipse.org/eclipse/platform-core/documents/3.1/d ebug.html

I don't mean debugging local/remote application - just eclipse :)
This will help You to resolve eclipse problems, not any in application. That's
different :)

/dmc
Re: Eclipse hangs when opening specific files [message #657076 is a reply to message #657015] Tue, 01 March 2011 09:38 Go to previous messageGo to next message
Richard L. is currently offline Richard L.
Messages: 4
Registered: February 2011
Junior Member
Thanks!

I think I got the information you might be able to figure out.

I started with -console -consoleLog -debug.
Got a whole bunch of Java errors - more than one double CMD page size at a time.
After some searching, I found the Error Log with tons of entries like this:

eclipse.buildId=M20100909-0800
java.version=1.6.0_23
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.php.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.php.product -console -consoleLog -debug

This is a continuation of log file C:\Users\Richard\workspace\.metadata\.bak_1.log
Created Time: 2011-03-01 08:30:15.771


Error
Tue Mar 01 08:32:27 CST 2011
Zero or negative length StyleRange 46492:0

java.lang.IllegalArgumentException: Zero or negative length StyleRange 46492:0
at org.eclipse.php.internal.ui.editor.configuration.PresentationCollector.add(PresentationCollector.java:41)
at org.eclipse.wst.sse.ui.internal.provisional.style.AbstractLineStyleProvider.prepareTextRegion(AbstractLineStyleProvider.java:298)
at org.eclipse.wst.sse.ui.internal.provisional.style.AbstractLineStyleProvider.prepareTextRegions(AbstractLineStyleProvider.java:331)
at org.eclipse.wst.sse.ui.internal.provisional.style.AbstractLineStyleProvider.prepareRegions(AbstractLineStyleProvider.java:249)
at org.eclipse.php.internal.ui.editor.configuration.StructuredDocumentDamagerRepairer.createPresentation(StructuredDocumentDamagerRepairer.java:27)
at org.eclipse.php.internal.ui.editor.configuration.PHPStructuredPresentationReconciler.createPresentation(PHPStructuredPresentationReconciler.java:268)
at org.eclipse.wst.sse.ui.internal.provisional.style.StructuredPresentationReconciler.createRepairDescription(StructuredPresentationReconciler.java:931)
at org.eclipse.wst.sse.ui.internal.style.SemanticHighlightingPresenter.createPresentation(SemanticHighlightingPresenter.java:371)
at org.eclipse.wst.sse.ui.internal.style.SemanticHighlightingReconciler.reconcile(SemanticHighlightingReconciler.java:150)
at org.eclipse.wst.sse.ui.internal.reconcile.DocumentRegionProcessor.endProcessing(DocumentRegionProcessor.java:119)
at org.eclipse.wst.sse.ui.internal.reconcile.DirtyRegionProcessor.run(DirtyRegionProcessor.java:682)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)



Does that help you at all? I'll leave Eclipse open - so far I haven't found any Memory entries yet, so maybe you can point me in that direction, too?

Thanks!
Re: Eclipse hangs when opening specific files [message #657322 is a reply to message #657076] Wed, 02 March 2011 07:52 Go to previous messageGo to next message
dominik is currently offline dominik
Messages: 122
Registered: July 2009
Senior Member
On 2011-03-01 15:39, Richard L. wrote:
> Does that help you at all? I'll leave Eclipse open - so far I haven't found any
> Memory entries yet, so maybe you can point me in that direction, too?

Error log always help, You probably got this:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=326293
It is reported that after upgrade problem is gone. Hope it will fix your.

/dmc
Re: Eclipse hangs when opening specific files [message #657325 is a reply to message #657076] Wed, 02 March 2011 08:01 Go to previous message
dominik is currently offline dominik
Messages: 122
Registered: July 2009
Senior Member
On 2011-03-01 15:39, Richard L. wrote:
(...)

There is another raport in bugzilla - not yet fixed.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=335562
Author claims that issue is connected with "javascript support" option, so maybe
You can edit files without that. Sure it's better than hang.

/dmc
Previous Topic:Content Assist doesn't display some mysql functions
Next Topic:Insert and automatically update "last modified" date in comments
Goto Forum:
  


Current Time: Sat Aug 30 02:39:16 EDT 2014

Powered by FUDForum. Page generated in 0.01907 seconds