Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo 3] Problems with the 'automatically build' : false errors
[Acceleo 3] Problems with the 'automatically build' : false errors [message #655107] Fri, 18 February 2011 05:58 Go to next message
Alexandre Cortier is currently offline Alexandre Cortier
Messages: 9
Registered: January 2011
Junior Member
Hy,

I've got a problem with my project. I have 27 .mtl files in my project.
When I made a modification on a template which is imported by several other mtl modules, many errors appear
(Notice that the modification I talk about is quite elementary : adding a whitespace).

I need to call a 'clean action' on my project to remove Acceleo errors...

Have you ever had this problem?

It seems that the dependencies between modules are not properly taken into account during automatic build ...
Re: [Acceleo 3] Problems with the 'automatically build' : false errors [message #655154 is a reply to message #655107] Fri, 18 February 2011 09:03 Go to previous message
Stephane Begaudeau is currently offline Stephane Begaudeau
Messages: 406
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi Alexandre,

There is a known bug with compilation errors that appears when the file is not saved and that disappear when you save the file. But I don't think that we have an opened bug for this. I'll open an entry on the bugzilla and we will investigate it.

Thanks.

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau
Acceleo wiki: http://wiki.eclipse.org/Acceleo
Blogs: http://stephanebegaudeau.tumblr.com & http://sbegaudeau.tumblr.com



Previous Topic:[Acceleo] eliminate warnings
Next Topic:Need some help to understand the process Papyrus => Acceleo => java code
Goto Forum:
  


Current Time: Fri Jul 11 07:23:34 EDT 2014

Powered by FUDForum. Page generated in 0.02020 seconds