Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Exporting product fails to load classes
Exporting product fails to load classes [message #655104] Fri, 18 February 2011 10:47 Go to next message
AppleJus Mising name is currently offline AppleJus Mising name
Messages: 46
Registered: July 2010
Member
Hi ,

I am trying to export an e4 app as a product and it fails to export well... I tried "launching a test product " and I got the following errors, which seem to cause the bad export:

I have a few of those errors similar to this one (for a few classes). Here is the one for the LifecycleHandler class:

"ERROR: Unable to load class 'com.myapp.handlers.LifecycleHandler' from bundle '1065'"

What is weird is that my app works fine if launched from within eclipse (not exported as a product).

I checked the plugin.xml and the myapp.application.product and everything seems fine, with all the required plugins...

I tried this using e4.0 and e4.1M5, and in both cases the same problem happens.

Thanks for your help!
Re: Exporting product fails to load classes [message #655110 is a reply to message #655104] Fri, 18 February 2011 11:06 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5419
Registered: July 2009
Senior Member
Is your .product up-to-date? I'd try to create an application using the
e4-project wizard, export it and if that fails too file a bug report.

In case this application works you can compare them to spot the error.

Tom

Am 18.02.11 11:47, schrieb AppleJus:
> Hi ,
>
> I am trying to export an e4 app as a product and it fails to export
> well... I tried "launching a test product " and I got the following
> errors, which seem to cause the bad export:
>
> I have a few of those errors similar to this one (for a few classes).
> Here is the one for the LifecycleHandler class:
>
> "ERROR: Unable to load class 'com.myapp.handlers.LifecycleHandler' from
> bundle '1065'"
>
> What is weird is that my app works fine if launched from within eclipse
> (not exported as a product).
>
> I checked the plugin.xml and the myapp.application.product and
> everything seems fine, with all the required plugins...
>
> I tried this using e4.0 and e4.1M5, and in both cases the same problem
> happens.
>
> Thanks for your help!
Previous Topic:Updating to 4.1 messed things up
Next Topic:Error Upgrading from 4.0 to 4.1M5
Goto Forum:
  


Current Time: Thu Oct 23 14:45:31 GMT 2014

Powered by FUDForum. Page generated in 0.13891 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software