Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT Runtime Localizations Not Working
icon5.gif  BIRT Runtime Localizations Not Working [message #654735] Wed, 16 February 2011 21:13 Go to next message
Teemu Nousiainen is currently offline Teemu NousiainenFriend
Messages: 1
Registered: February 2011
Junior Member
Hi,

I installed and setup jBoss 6.0.0 Final and Birt Runtime 2.6.1. Birt.war deployment worked fine without problems and the reports are viewed properly. However, when I tried to install Finnish localizations (BabelLanguagePack-birt-fi_3.6.0.v20101211043401.zip) the classloader doesn't seem to load messages_fi.properties - files or anything from the jars.

I unzipped the language pack zip-file and copied the jars to birt.war/WEB-INF/platform/plugins‚ set BIRT_VIEWER_LOCALE to fi in web.xml and restarted JBoss.

I tried the report http://myserver:8080/birt/frameset?__report=MyReport.rptdesi gn&__locale=fi but the Report Viewer's GUI is still in english. I inspected JBoss log for loaded classfiles and it's not loading any of these language pack jars. I moved the jars to WEB-INF/lib, but it didn't help.

What am I doing wrong?
Re: BIRT Runtime Localizations Not Working [message #654748 is a reply to message #654735] Wed, 16 February 2011 22:31 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Teemu,

Can you log a bug for this? You should have been able to download the
file extract the zip and copy
org.eclipse.birt.report.viewer.nl_fi_3.6.0.v20101211043401 to the
WEB-INF/lib directory of the deployed viewer. Then enter &__locale=fi
or &__locale=fi_FI and it should work, but for some reason it is not
with that locale. I tried others like the french download and it worked
fine.

Jason


On 2/16/2011 4:13 PM, Teemu Nousiainen wrote:
> Hi,
>
> I installed and setup jBoss 6.0.0 Final and Birt Runtime 2.6.1. Birt.war
> deployment worked fine without problems and the reports are viewed
> properly. However, when I tried to install Finnish localizations
> (BabelLanguagePack-birt-fi_3.6.0.v20101211043401.zip) the classloader
> doesn't seem to load messages_fi.properties - files or anything from the
> jars.
>
> I unzipped the language pack zip-file and copied the jars to
> birt.war/WEB-INF/platform/plugins‚ set BIRT_VIEWER_LOCALE to fi in
> web.xml and restarted JBoss.
>
> I tried the report
> http://myserver:8080/birt/frameset?__report=MyReport.rptdesi gn&__locale=fi
> but the Report Viewer's GUI is still in english. I inspected JBoss log
> for loaded classfiles and it's not loading any of these language pack
> jars. I moved the jars to WEB-INF/lib, but it didn't help.
>
> What am I doing wrong?
>
Previous Topic:Is there a way to set the display format of a date in the dataset data preview?
Next Topic:Formatting Date as String in script
Goto Forum:
  


Current Time: Mon Dec 22 17:06:28 GMT 2014

Powered by FUDForum. Page generated in 0.01574 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software