Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Run->Run as Server generates HTTP 404 error
Run->Run as Server generates HTTP 404 error [message #653878] Fri, 11 February 2011 12:16 Go to next message
No real name is currently offline No real name
Messages: 1
Registered: February 2011
Junior Member
Currently, I am using the following Eclipse version 3.5 SR2 with both axis 2 1.4 and tomcat v6.0.30 installed.
Java jdk is jdk1.6.0_23.

Tomcat server is setup as an local host server using port 8081. To test if the localhost Tomcat was up and running
entered the following url http:// localhost:8081. The proper page was displayed.

Then based on the following tutorial ( http://www.vogella.de/articles/Webservice/article.html#wssim ple ) using the following
section "4. Create a complex Web Service".

Was able to create an web service and I believe this was deployed properly after restarting Tomcat.
This belief was based on the following information in the console view.

[INFO] Deploying Web service: CarService - file:/X:/Eclipse_jee_galileo-SR2/eclipse/ws_workspace/.metad ata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/de. vogella.webservice.complex.soap.axis2/WEB-INF/services/CarSe rvice/

My next step was to create a client for the web service.

Tried to determine the url for the next step by first highlighting the project and then select run -> run as server,
the following message is generated.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ +++++++++++++++++++++++++++++
HTTP Status 404 - /de.vogella.webservice.complex.soap.axis2/
------------------------------------------------------------ --------------------
type Status report
message /de.vogella.webservice.complex.soap.axis2/
description The requested resource (/de.vogella.webservice.complex.soap.axis2/) is not available.
------------------------------------------------------------ --------------------
Apache Tomcat/6.0.30
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ ++++++++++++++++++++++++++++++++

Very new to Tomcat and web development and not sure where to look. Is there any other information that can be provided that would be helpful.

Any suggestion would be appreciated.
Re: Run->Run as Server generates HTTP 404 error [message #653896 is a reply to message #653878] Fri, 11 February 2011 12:56 Go to previous message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1287
Registered: July 2009
Senior Member
On 2/11/2011 12:16 PM, LUKEYSAN@COMCAST.NET wrote:
> Currently, I am using the following Eclipse version 3.5 SR2 with both
> axis 2 1.4 and tomcat v6.0.30 installed.
> Java jdk is jdk1.6.0_23.
>
> Tomcat server is setup as an local host server using port 8081. To test
> if the localhost Tomcat was up and running entered the following url
> http:// localhost:8081. The proper page was displayed.
>
> Then based on the following tutorial (
> http://www.vogella.de/articles/Webservice/article.html#wssim ple ) using
> the following section "4. Create a complex Web Service".
>
> Was able to create an web service and I believe this was deployed
> properly after restarting Tomcat.
> This belief was based on the following information in the console view.
>
> [INFO] Deploying Web service: CarService -
> file:/X:/Eclipse_jee_galileo-SR2/eclipse/ws_workspace/.metad
> ata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/de.
> vogella.webservice.complex.soap.axis2/WEB-INF/services/CarSe rvice/
>
> My next step was to create a client for the web service.
>
> Tried to determine the url for the next step by first highlighting the
> project and then select run -> run as server,
> the following message is generated.
>
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> +++++++++++++++++++++++++++++
> HTTP Status 404 - /de.vogella.webservice.complex.soap.axis2/
> ------------------------------------------------------------
> --------------------
> type Status report
> message /de.vogella.webservice.complex.soap.axis2/
> description The requested resource
> (/de.vogella.webservice.complex.soap.axis2/) is not available.
> ------------------------------------------------------------
> --------------------
> Apache Tomcat/6.0.30
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> ++++++++++++++++++++++++++++++++
>
> Very new to Tomcat and web development and not sure where to look. Is
> there any other information that can be provided that would be helpful.
> Any suggestion would be appreciated.
>

Selecting a project and executing Run As -> Run on Server opens the
browser with the "base" URL for that project running on the selected
server. The typical result of requesting the "base" URL is that the
webapp will forward or redirect the request to a welcome file, such as
index.html or index.jsp, provided such a file exists. If you have no
such welcome file included in your project, then 404 is the expected
result. If you select a JSP page or servlet, you can execute Run As ->
Run on Server for that resource, and it will invoke the browser with the
URL that requests that resource.

Cheers,
Larry
Previous Topic:Canonical Annotation Processing Helios WTP
Next Topic:Where can I get org.eclipse.wst.jsdt.debug.crossfire?
Goto Forum:
  


Current Time: Sun Apr 20 04:31:01 EDT 2014

Powered by FUDForum. Page generated in 0.02756 seconds