Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » oAW 4 migration to oAW5
oAW 4 migration to oAW5 [message #653735] Thu, 10 February 2011 21:47 Go to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
Hello,

i want to migrate my oaw4 project to oaw5. Now iam looking for the package org.openarchitectureware.meta.uml.classifier in oaw5. Does anybody know where these classes (e.g. org.openarchitectureware.meta.uml.classifier.Class or org.openarchitectureware.meta.uml.classifier.Attribute) are in the plugins?

Thanks
Re: oAW 4 migration to oAW5 [message #653738 is a reply to message #653735] Thu, 10 February 2011 22:20 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
Hi,

oAW Classic (the Built-in UML Metamodel that comes with XMI-Adapters foreach tool vendor) is not part of oAW5. oAW5 support Eclipse UML2 Compatible UML Exports. Which UML tool do you use?

~Christian

[Updated on: Thu, 10 February 2011 23:00]

Report message to a moderator

Re: oAW 4 migration to oAW5 [message #654182 is a reply to message #653738] Mon, 14 February 2011 14:18 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
Hi Christian,

thanks for your answer.
Iam using Enterprice Architecture 8.0.

Currently the oaw4 workflow is:
	<cartridge
		file="org/openarchitectureware/workflow/oawclassic/classicstart.oaw">
		<metaEnvironmentSlot value="me" />
		<instantiatorEnvironmentSlot value="ie" />
	</cartridge>

	<component
			class="org.openarchitectureware.core.frontends.xmi.workflow.XMIInstantiator">
		<instantiatorEnvironmentSlot value="ie" />
		<modelFile value="${model.xmi}" />
		<xmlMapFile value="${toolMappingFile}" />
		<metaMapFile value="${metaMapFile}" />
		<toolAdapterClassname value="${toolAdapterClassname}" />
		<moduleFile value="${moduleFile}" />
	</component>

...


The model.xmi is the exported xml file by EA. The xmlMapFile is a XMI1.2 file calls ea41_xmi12_all-mod.xml.
Iam using own meta classes like public class Enumeration extends org.openarchitectureware.meta.uml.classifier.Class in all xpt,ext,chk files for generating customize classes.

Do you know how to generate a uml2 conform file via EA?
If i want to use oaw5, i have to remove all package dependens to org.openarchitectureware.meta.uml.* and org.openarchitectureware.core.frontends.xmi.*?

Thanks
Re: oAW 4 migration to oAW5 [message #654184 is a reply to message #654182] Mon, 14 February 2011 14:22 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
Hi,

the oAW built in uml2 metamodel is no longer supported. you could give eclipse uml2 (have a look at http://uml2ea.blogspot.com/ to find a exporter) a try,

~Christian
Re: oAW 4 migration to oAW5 [message #654191 is a reply to message #654184] Mon, 14 February 2011 14:44 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
Hi,

mhm I don't understand the problem.
EA can't export a UML2 diagramm so i have to transform it before eclipse can import it, right?
Re: oAW 4 migration to oAW5 [message #654197 is a reply to message #654191] Mon, 14 February 2011 14:53 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
Hi,

yes you have to "create" an eclipse uml2 conform export of you model. the best way to do this is (afaik) to use the Uml2Exporter from here (http://uml2ea.blogspot.com/) that is buiklt exactly for this purpose.

~ Christian
Re: oAW 4 migration to oAW5 [message #654201 is a reply to message #654197] Mon, 14 February 2011 15:02 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
Hi,

ah okay i will carry out a test.

And what i have to do with my own classes which extends from org.openarchitectureware.meta.uml.classifier.Class?
Re: oAW 4 migration to oAW5 [message #654202 is a reply to message #654201] Mon, 14 February 2011 15:06 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
hi,

you will have to migrate all of your code to work with eclipse uml2. this means: no self-created classes for stereotypes / tagged values etc. Eclipse Uml2 supports profiles but i cannot say how good these are supported by the exporter.

~Christian
Re: oAW 4 migration to oAW5 [message #654207 is a reply to message #654202] Mon, 14 February 2011 15:22 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
hi,

also if the exporter doesn't support the Sterotypes i have to change the uml tool?
Is there a good tutorial for UML2 how i can create own Sterotypes? Or is this different for every UML tool?

Is there a possibility to use oaw4 and eclipse 3.6?

[Updated on: Mon, 14 February 2011 15:26]

Report message to a moderator

Re: oAW 4 migration to oAW5 [message #654210 is a reply to message #654207] Mon, 14 February 2011 15:27 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
Hi, As i said before. just test what the exports creates for your profile. and yes there is an eclipse uml2 stereotypes/profile tutorial. http://www.eclipse.org/modeling/mdt/uml2/docs/articles/Intro duction_to_UML2_Profiles/article.html

~Christian
Re: oAW 4 migration to oAW5 [message #654323 is a reply to message #654210] Tue, 15 February 2011 07:50 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
okay thanks i will have a try Wink
Re: oAW 4 migration to oAW5 [message #655181 is a reply to message #654210] Fri, 18 February 2011 15:11 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
okay now i export my profile and my model as UML2. Can i use my sterotypes in java for util check Classes? Some checks are very difficult.
Re: oAW 4 migration to oAW5 [message #655189 is a reply to message #655181] Fri, 18 February 2011 15:34 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
Hi,

no you do not get java classes / interfaces generated but you can of course directly work with java - this just works with means of reflection

e.g.
org.eclipse.uml2.uml.Element.getAppliedStereotype(String)
org.eclipse.uml2.uml.Element.getValue(Stereotype, String)

~Christian
Re: oAW 4 migration to oAW5 [message #655446 is a reply to message #655189] Mon, 21 February 2011 08:16 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
ah okay i see =).

1 question more. Are there precast xpand or xtend templates, which do normal stuff e.g setter and getter generation?

thanks

EDIT: i found a documentation
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .xpand.doc/help/ch01s03.html

[Updated on: Mon, 21 February 2011 10:23]

Report message to a moderator

Re: oAW 4 migration to oAW5 [message #655533 is a reply to message #655446] Mon, 21 February 2011 16:04 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
Hi,

i get always a error and i don't know why.

The mwe workflow:
<?xml version="1.0" encoding="UTF-8"?>
<workflow>
	<property file="workflow.properties" />
	
	<bean class="org.eclipse.emf.mwe.utils.StandaloneSetup" platformUri=".."/>
	<bean class="org.eclipse.xtend.typesystem.uml2.Setup" standardUML2Setup="true" />
	
		<!-- Metamodel-Definition -->
	<bean id="EmfMM" class="org.eclipse.xtend.typesystem.emf.EmfMetaModel" 
		metaModelPackage ="org.eclipse.emf.ecore.EcorePackage"/>
	<bean id="UmlMM" class="org.eclipse.xtend.typesystem.uml2.UML2MetaModel"/>
	<bean id="${profile.name}MM" class="org.eclipse.xtend.typesystem.uml2.profile.ProfileMetaModel">
		<profile value="${uml.dir}${profile.name}.profile.uml" />
	</bean>

	<component class="org.eclipse.xtend.typesystem.emf.XmiReader">
		<modelFile value="src/tools/model/model.uml" />
		<outputSlot value="model"/>
	</component>
	
	<component class="org.eclipse.emf.mwe.utils.DirectoryCleaner" directory="${srcGenPath}/"/>

	<component class="org.eclipse.xpand2.Generator"
			   skipOnErrors="true" fileEncoding ="ISO-8859-1">
		<metaModel idRef="EmfMM"/>		
		<metaModel idRef="UmlMM"/>
		<metaModel idRef="${profile.name}MM"/>
		<expand value="Root::Root FOR Model" />
		<outlet path="${srcGenPath}"/>
		<beautifier class="org.eclipse.xpand2.output.JavaBeautifier" />
    </component>


and the error message is:
5125 INFO Generator: generating 'Root::Root FOR Model' => src/main/generated
5453 ERROR Error in Component of type org.eclipse.xpand2.Generator:
EvaluationException : Couldn't find type or property 'Model'
[45,5] on line 1 'Model'

5453 ERROR Workflow interrupted. Reason: Couldn't find type or property 'Model'
5453 ERROR [ERROR]: Couldn't find type or property 'Model'(Element: Model; Reported by: Generator: generating 'Root::Root FOR Model' => src/main/generated)
5453 ERROR [ERROR]: Couldn't find type or property 'Model'(Element: EXPAND Root::Root FOR Model; Reported by: Generator: generating 'Root::Root FOR Model' => src/main/generated

Do you have an idea?


Re: oAW 4 migration to oAW5 [message #655534 is a reply to message #655533] Mon, 21 February 2011 16:05 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
Hi,

model != Model

you write to the slot model but try to read from the slot Model

~Christian

[Updated on: Mon, 21 February 2011 16:36]

Report message to a moderator

Re: oAW 4 migration to oAW5 [message #655655 is a reply to message #655534] Tue, 22 February 2011 07:56 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
You are right.T

That's awful. It makes me ashamed Wink
Re: oAW 4 migration to oAW5 [message #655668 is a reply to message #655655] Tue, 22 February 2011 09:09 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
I have a Names.ext File: Looks like:
String toSetter(uml::Property property):
	"set"+property.name.toFirstUpper();


error message
" couldn't find operation toFirstUpper()' for type java::lang::String"

mhm?!?!

[Updated on: Tue, 22 February 2011 09:16]

Report message to a moderator

Re: oAW 4 migration to oAW5 [message #655673 is a reply to message #655668] Tue, 22 February 2011 09:30 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
Hi,

maybe this has to do with the order od the stuff in the workflow.
maybe you should put <metaModel idRef="EmfMM"/> at the third position in the workflow.

if this does not work you may have to write a java extensuion for the toFirstUpper

~Christian
Re: oAW 4 migration to oAW5 [message #655706 is a reply to message #655673] Tue, 22 February 2011 11:45 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
okay I get it.

In the projekt properties --> Xtend/Xpand Enable project specific . And then I set the UML2 profiles on first place.

[Updated on: Tue, 22 February 2011 12:11]

Report message to a moderator

Re: oAW 4 migration to oAW5 [message #655718 is a reply to message #655706] Tue, 22 February 2011 12:38 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6315
Registered: July 2009
Senior Member
Ah,

you did not say that this was an UI issue - You always have to differentiate between errors you get in the ui and errors that you get from the workflow.

~ Christian
Re: oAW 4 migration to oAW5 [message #655771 is a reply to message #655718] Tue, 22 February 2011 15:31 Go to previous message
Sir Wayne is currently offline Sir Wayne
Messages: 211
Registered: July 2009
Senior Member
Yes sorry my fault =)
Previous Topic:[Acceleo3]Generating a C macro definition
Next Topic:[Acceleo] Papyrus UML Profiles
Goto Forum:
  


Current Time: Sun Sep 21 22:27:38 GMT 2014

Powered by FUDForum. Page generated in 0.03018 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software