Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » Wrong version of org.eclipse.core.resources bundle in the 3.6.1 p2 repository?
Wrong version of org.eclipse.core.resources bundle in the 3.6.1 p2 repository? [message #653511] Thu, 10 February 2011 02:13 Go to next message
Eclipse UserFriend
Originally posted by: victor.lenet.gmail.com

Hello,

First, I am sorry for posting to two newsgroups, I was not sure which is
the right one.

I am trying to make a local mirror of the official 3.6.1 p2 repository
using org.eclipse.sdk feature. I am planing to use this local repository
as a base of my IDE product build and as a set of plugins against which
to compile my plugins.

For creating the local mirror I am using the following p2.mirror task:

<target name="mirror">
<property name="mirrorFolder" value="${basedir}/mirrored" />
<p2.mirror source="http://download.eclipse.org/eclipse/updates/3.6"
destination="file:${mirrorFolder}">
<iu id="org.eclipse.sdk.feature.group"/>
<slicingoptions platformFilter="win32,win32,x86" latestVersionOnly="true" />
</p2.mirror>
</target>

The mirroring task finishes without any complaints. However, for some
reason, it mirrors an older version of core.resources bundle:
org.eclipse.core.resources_3.6.0.v20100526-0737.jar
instead of
org.eclipse.core.resources_3.6.0.R36x_v20100825-0600.jar
which is a part of Platform 3.6.1 repository.

The platform feature version is the same in both cases:
org.eclipse.platform_3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnv z0JWNTeb6fue6896L.jar

Even when I try to mirror only the core.resources bundle from the
updates repository, the result is the same.

Of course the product build complains about the wrong bundle version:
generateFeature:
[eclipse.generateFeature] Some inter-plug-in dependencies have not been
satisfied.
[eclipse.generateFeature] Bundle org.eclipse.core.resources:
[eclipse.generateFeature] Another singleton version selected:
org.eclipse.core.resources_3.6.0.v20100526-0737

and later on:
BUILD FAILED
....\workspace\adt.feature.builder\buildADT.xml:48: The following error
occurred while executing this line:
....\eclipse\plugins\org.eclipse.pde.build_3.6.1.R36x_v20100 823\scripts\productBuild\productBuild.xml:42:
The following error occurred while executing this line:
....\eclipse\plugins\org.eclipse.pde.build_3.6.1.R36x_v20100 823\scripts\build.xml:91:
The following error occurred while executing this line:
....\workspace\adt.feature.builder\builder\customTargets.xml :12: The
following error occurred while executing this line:
....\eclipse\plugins\org.eclipse.pde.build_3.6.1.R36x_v20100 823\scripts\productBuild\allElements.xml:20:
The following error occurred while executing this line:
....\eclipse\plugins\org.eclipse.pde.build_3.6.1.R36x_v20100 823\scripts\genericTargets.xml:107:
Processing inclusion from feature org.eclipse.platform: Bundle
org.eclipse.core.resources_3.6.0.R36x_v20100825-0600 failed to resolve.:
Another singleton version selected:
org.eclipse.core.resources_3.6.0.v20100526-0737

Am I doing something wrong here or is there a problem in the Eclipse
3.6.1 update repository?

Thanks in advance,
Victor
Re: Wrong version of org.eclipse.core.resources bundle in the 3.6.1 p2 repository? [message #654010 is a reply to message #653511] Sat, 12 February 2011 22:25 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: victor.lenet.gmail.com

Apparently the problem is with 'latestVersionOnly="true"' parameter of
the 'slicingoptions' element. The bundle versions are compared using
string compare where "v20100526-0737" comes after "R36x_v20100825-0600".

The right option to use seems to be 'followStrict="true"'.

Cheers,
Victor
Re: Wrong version of org.eclipse.core.resources bundle in the 3.6.1 p2 repository? [message #654166 is a reply to message #654010] Mon, 14 February 2011 13:04 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

On 02/12/2011 05:25 PM, Victor Lenet wrote:
> Apparently the problem is with 'latestVersionOnly="true"' parameter of
> the 'slicingoptions' element. The bundle versions are compared using
> string compare where "v20100526-0737" comes after "R36x_v20100825-0600".
>
> The right option to use seems to be 'followStrict="true"'.

While there's a work-around, it begs the question: Why is their a
version of core.resources in 3.6.1 with 1) a different qualifier and not
a different number and 2) an incompatible qualifier

I doubt there's much that can be done at this point, but I've opened
https://bugs.eclipse.org/bugs/show_bug.cgi?id=337109

PW


--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Previous Topic:P2 director application - handling of optional dependencies
Next Topic:how to find source update site of a plugin at runtime?
Goto Forum:
  


Current Time: Fri Nov 28 13:44:36 GMT 2014

Powered by FUDForum. Page generated in 0.05478 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software