Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Polish users » Fedora 14 Web Page Editor - installation problem
Fedora 14 Web Page Editor - installation problem [message #653357] Wed, 09 February 2011 09:02 Go to next message
tomek  is currently offline tomek
Messages: 12
Registered: February 2011
Junior Member
PL
-----------------------------------
Mam Fedore 14.
Chcę zainstalować "Web Page Editor".

Help->Install new software

Dodaję
http://download.eclipse.org/releases/galileo/
wybieram
Web, XML and Java EE development → Web Page Editor
i klikam next.
Ale dostaję odpowoedź - zobacz niżej Eclipse Output 1.

Tak samo dla:
http://download.eclipse.org/webtools/updates
Web Tools Platform (WTP) 3.1.2 -> Web Page Editor
Ale dostaję odpowoedź - zobacz niżej Eclipse Output 2.

Na Debianie nie miałem takich problemów.

Proszę o pomoc.
-----------------------------------


EN
-----------------------------------
I have Fedora 14.
I want to install "Web Page Editor".

I add
http://download.eclipse.org/releases/galileo/
then select
Web, XML and Java EE development → Web Page Editor
and click next.
And I recieve message - see below Eclipse Output 1.

The same happens if I chose:
http://download.eclipse.org/webtools/updates
Web Tools Platform (WTP) 3.1.2 -> Web Page Editor
And I recieve message - see below Eclipse Output 2.

I have no such problem in Debian.

Please help.
-----------------------------------


Eclipse Output 1:
-----------------------------------
Cannot complete the install because of a conflicting dependency.
Software being installed: Web Page Editor (Optional) 2.2.2.v201001271707-43799oB5855B7A2242 (org.eclipse.jst.webpageeditor.feature.feature.group 2.2.2.v201001271707-43799oB5855B7A2242)
Software currently installed: Shared profile 1.0.0.1292415248356 (SharedProfile_PlatformProfile 1.0.0.1292415248356)
Only one of the following can be installed at once:
International Components for Unicode for Java (ICU4J) 4.2.1.v20100412 (com.ibm.icu 4.2.1.v20100412)
International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
International Components for Unicode for Java (ICU4J) 4.0.1.v20090415 (com.ibm.icu 4.0.1.v20090415)
Cannot satisfy dependency:
From: Shared profile 1.0.0.1292415248356 (SharedProfile_PlatformProfile 1.0.0.1292415248356)
To: com.ibm.icu
Cannot satisfy dependency:
From: Java EMF Model Utilities 2.0.200.v200905140200 (org.eclipse.jem.util 2.0.200.v200905140200)
To: bundle com.ibm.icu [3.8.1.1,4.1.0)
Cannot satisfy dependency:
From: Java EMF Model Utilities 2.0.201.v201001252130 (org.eclipse.jem.util 2.0.201.v201001252130)
To: bundle com.ibm.icu [3.8.1.1,4.1.0)
Cannot satisfy dependency:
From: JavaServer Faces Tools - Common UI 1.1.1.v20081209 (org.eclipse.jst.jsf.common.ui 1.1.1.v20081209)
To: bundle org.eclipse.wst.common.emf [1.1.103,2.0.0)
Cannot satisfy dependency:
From: JavaServer Faces Tools - Pagedesigner UI 1.1.4.v20100203 (org.eclipse.jst.pagedesigner.jsf.ui 1.1.4.v20100203)
To: bundle org.eclipse.jst.jsf.common.ui [1.1.0,2.0.0)
Cannot satisfy dependency:
From: Web Page Editor (Optional) 2.2.2.v201001271707-43799oB5855B7A2242 (org.eclipse.jst.webpageeditor.feature.feature.group 2.2.2.v201001271707-43799oB5855B7A2242)
To: org.eclipse.jst.pagedesigner.jsf.ui
Cannot satisfy dependency:
From: EMF Utilities 1.1.301.v200908181930 (org.eclipse.wst.common.emf 1.1.301.v200908181930)
To: bundle org.eclipse.jem.util [2.0.100,3.0.0)
-----------------------------------


Eclipse Output 2:
-----------------------------------
Cannot complete the install because of a conflicting dependency.
Software being installed: Web Page Editor (Optional) 2.2.2.v201001271707-43799oB5855B7A2242 (org.eclipse.jst.webpageeditor.feature.feature.group 2.2.2.v201001271707-43799oB5855B7A2242)
Software currently installed: Shared profile 1.0.0.1292415248356 (SharedProfile_PlatformProfile 1.0.0.1292415248356)
Only one of the following can be installed at once:
International Components for Unicode for Java (ICU4J) 4.2.1.v20100412 (com.ibm.icu 4.2.1.v20100412)
International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
International Components for Unicode for Java (ICU4J) 4.0.1.v20090415 (com.ibm.icu 4.0.1.v20090415)
Cannot satisfy dependency:
From: Shared profile 1.0.0.1292415248356 (SharedProfile_PlatformProfile 1.0.0.1292415248356)
To: com.ibm.icu
Cannot satisfy dependency:
From: Java EMF Model Utilities 2.0.200.v200905140200 (org.eclipse.jem.util 2.0.200.v200905140200)
To: bundle com.ibm.icu [3.8.1.1,4.1.0)
Cannot satisfy dependency:
From: Java EMF Model Utilities 2.0.201.v201001252130 (org.eclipse.jem.util 2.0.201.v201001252130)
To: bundle com.ibm.icu [3.8.1.1,4.1.0)
Cannot satisfy dependency:
From: JavaServer Faces Tools - Common UI 1.1.1.v20081209 (org.eclipse.jst.jsf.common.ui 1.1.1.v20081209)
To: bundle org.eclipse.wst.common.emf [1.1.103,2.0.0)
Cannot satisfy dependency:
From: JavaServer Faces Tools - Pagedesigner UI 1.1.4.v20100203 (org.eclipse.jst.pagedesigner.jsf.ui 1.1.4.v20100203)
To: bundle org.eclipse.jst.jsf.common.ui [1.1.0,2.0.0)
Cannot satisfy dependency:
From: Web Page Editor (Optional) 2.2.2.v201001271707-43799oB5855B7A2242 (org.eclipse.jst.webpageeditor.feature.feature.group 2.2.2.v201001271707-43799oB5855B7A2242)
To: org.eclipse.jst.pagedesigner.jsf.ui [1.1.4.v20100203]
Cannot satisfy dependency:
From: EMF Utilities 1.1.301.v200908181930 (org.eclipse.wst.common.emf 1.1.301.v200908181930)
To: bundle org.eclipse.jem.util [2.0.100,3.0.0)
-----------------------------------
Re: Fedora 14 Web Page Editor - installation problem [message #653407 is a reply to message #653357] Wed, 09 February 2011 11:35 Go to previous messageGo to next message
Mariusz P. is currently offline Mariusz P.
Messages: 85
Registered: February 2010
Member
W logach masz napisane, że chodzi o konflikt zależności. Tylko jeden z następujących elementów może być zainstalowany:

"Only one of the following can be installed at once:
International Components for Unicode for Java (ICU4J) 4.2.1.v20100412 (com.ibm.icu 4.2.1.v20100412)
International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
International Components for Unicode for Java (ICU4J) 4.0.1.v20090415 (com.ibm.icu 4.0.1.v20090415)"

Albo zaznaczyłeś coś za dużo, albo masz już coś zainstalowane. Sprawdź. Poniżej w logach dalej stoi, że nie może uzupełnić satysfakcjonujących zależności. Może spróbuj je najpierw zainstalować? Brak dodatkowych repozytoriów w Eclipse? Chwilowa niedostępność na serwerach?
Re: Fedora 14 Web Page Editor - installation problem [message #653456 is a reply to message #653407] Wed, 09 February 2011 15:27 Go to previous messageGo to next message
tomek  is currently offline tomek
Messages: 12
Registered: February 2011
Junior Member
PL
-------------------------
Eclipsa zainstalowałem yumem.
I odrazu po jego uruchomieniu chciałem zainstalować Web Page Editor.
Nic więcej nie robiłem.
Czy można w jakiś sposób usunąć ten com.ibm.icu ?
To chyba nie jest problem z chwilową niedostępnością serwerów eclipsa - bo mam tak cały dzień.
Podkreślam jeszcze raz że na Debianie Squeeze postępowałem w ten sam sposób i nie miałem takich problemów.
Chętnie podeśle więcej informacji - tylko powiedzcie jakie.
-------------------------

EN
-------------------------
I installed eclipse with yum.
Immediately after its start up i wanted to install Web Page Editor.
And I have not done enything before it.
Can I somehow remove this com.ibm.icu from eclipse?
It rather is not problem with eclipse server unavailability - situation with unsatisfied dependencies exist all day.
I remaind that in Debian Squeeze I done all in the same way and i had no such problems.
I will gladly give more information - just instruct me what information.
-------------------------
Re: Fedora 14 Web Page Editor - installation problem [message #653463 is a reply to message #653456] Wed, 09 February 2011 15:39 Go to previous messageGo to next message
Tomasz Zarna is currently offline Tomasz Zarna
Messages: 163
Registered: July 2009
Senior Member
Którą wersję Eclipse zainstalował Ci yum? Jak jakąś prehistoryczną to spróbuj ściagnąć coś świeższego z download.eclipse.org.

Jakiś czas temu doinstalowywałem Web Editor do Eclipse Classic i nie było problemów. Tyle tylko że ja pracuję na nocnych buildach Wink
Re: Fedora 14 Web Page Editor - installation problem [message #653466 is a reply to message #653463] Wed, 09 February 2011 15:44 Go to previous messageGo to next message
tomek  is currently offline tomek
Messages: 12
Registered: February 2011
Junior Member
Version: 3.6.1
Build id: M20100909-0800
Re: Fedora 14 Web Page Editor - installation problem [message #653635 is a reply to message #653466] Thu, 10 February 2011 08:44 Go to previous messageGo to next message
tomek  is currently offline tomek
Messages: 12
Registered: February 2011
Junior Member
PL
------------------------
OK.
Odinstalowałem eclipsa yumem.
Uruchomiłem tego pobranego z http://www.eclipse.org/downloads/
i mogę sobie zainstalować Web Page Editor.
Zauważyłem różnicę: w wersju z yuma w źródłach oprogramowanie jest release/galileo a w tym pobranym release/helios.

Wniosek jest taki - nie instalować eclipsa z repo - tylko pobrać.

Powiedzcie mi jeszcze gdzie najlepiej mam umieścić rozpakowany katalog z eclipsem, czy dodać jakieś zmienne do shella ??
------------------------

EN
------------------------
OK.
I uninstalled eclipse with yum.
I run version downloaded from http://www.eclipse.org/downloads/ and I can snagless install Web Page Editor.
I notice difference: in version installed with yum in software sources I have release/galileo but in downloaded version I have release/helios.

My conclusion is - do not install eclipse with yum - but download it.

I would like to also know where should I put eclipse catalog best, should I add some shell variables?
------------------------

[Updated on: Thu, 10 February 2011 08:53]

Report message to a moderator

Re: Fedora 14 Web Page Editor - installation problem [message #653646 is a reply to message #653635] Thu, 10 February 2011 09:22 Go to previous message
Mariusz P. is currently offline Mariusz P.
Messages: 85
Registered: February 2010
Member
Mylisz się. W Fedorze 14 w repozytoriach yuma też jest Eclipse Helios. Ja tam mam. Może zostało Ci coś z poprzednich wersji Fedory jeśli robiłeś jakieś aktualizacje (choć ja tak robię od niepamiętnych czasów i nic się nie dzieje Smile ). Katalog z Eclipse umieszczasz gdzie chcesz np. w /opt. Do samego Eclipse zmienne środowiskowe raczej Ci niepotrzebne.

[Updated on: Thu, 10 February 2011 09:23]

Report message to a moderator

Previous Topic:Edytory RCP
Next Topic:[SWT] Minimalizacja tylko do ikony - jak?
Goto Forum:
  


Current Time: Thu Apr 17 20:48:36 EDT 2014

Powered by FUDForum. Page generated in 0.01994 seconds