Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Migrating 3.x RCP Applications on Eclipse 4 SDK(does backward compatibility layers supports to run my 3.x RCP on e4 without any changes?)
Migrating 3.x RCP Applications on Eclipse 4 SDK [message #653056] Tue, 08 February 2011 09:51 Go to next message
Praveen  is currently offline Praveen
Messages: 86
Registered: July 2009
Member
I would like to migrate my existing 3.x RCP application to Eclipse 4.1 SDK. However, when I run the application in e4, the launch fails with unavailability of Application Model file (Application.e4xmi). Do I really need to create the Application Model file for my 3.x RCP application ?

I was under impression that backward compatibility layer should take care of launching 3.x RCP applications. Are there any best practices or rules required for the migration ?

PS: The main intention of migration is to understand the e4 architecture so that we can contribute back to e4 both in terms of reporting broken functionality and contribute patches to make e4 more stable.
Re: Migrating 3.x RCP Applications on Eclipse 4 SDK [message #653061 is a reply to message #653056] Tue, 08 February 2011 10:04 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5422
Registered: July 2009
Senior Member
Hi,

You need to have a minimal e4xmi like shown here:
http://thomaskratz.blogspot.com/2010/11/uhh-we-have-color-ru nning-legacy-app-on.html

And a description here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=317912

But we should definately document this on the wiki.

Tom

Am 08.02.11 10:51, schrieb Praveen:
> I would like to migrate my existing 3.x RCP application to Eclipse 4.1
> SDK. However, when I run the application in e4, the launch fails with
> unavailability of Application Model file (Application.e4xmi). Do I
> really need to create the Application Model file for my 3.x RCP
> application ?
>
> I was under impression that backward compatibility layer should take
> care of launching 3.x RCP applications. Are there any best practices or
> rules required for the migration ?
>
> PS: The main intention of migration is to understand the e4 architecture
> so that we can contribute back to e4 both in terms of reporting broken
> functionality and contribute patches to make e4 more stable.
Previous Topic:Resetting a .xwt resource DataContext
Next Topic:Changes with e4 4.1 m5
Goto Forum:
  


Current Time: Fri Oct 24 11:30:40 GMT 2014

Powered by FUDForum. Page generated in 0.01604 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software