Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » project text encoding resetted each time(project text encoding resetted each time)
project text encoding resetted each time [message #652828] Mon, 07 February 2011 09:06 Go to next message
chen thierry is currently offline chen thierry
Messages: 24
Registered: June 2010
Junior Member
Hi evreybody
I face a problem with Eclipse since I use utf-8 encoding for the default workbench: I set old projects properties to iso-8859-1 and it works fine until next session.
When I restart the project the next day encoding switched back to utf-8 again while the .settings/core.eclipse.resources.prefs shows:
#Thu Feb 03 15:01:21 CET 2011
eclipse.preferences.version=1
encoding/<project>=ISO-8859-1


I have to re-define text encoding each time I re-open the project and if I forget it I get bad transcoded caracters when I save a file. Realy boring Evil or Very Mad

[Updated on: Mon, 07 February 2011 09:08]

Report message to a moderator

Re: project text encoding resetted each time [message #652979 is a reply to message #652828] Mon, 07 February 2011 19:35 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
On 2/7/2011 4:06 AM, frms@webologix.com wrote:
> Hi evreybody
> I face a problem with Eclipse since I use utf-8 encoding I set old
> projects properties to iso-8859-1 and it works fine until next session.
> When I restart the project the next day encoding switched back to utf-8
> again while the .settings/core.eclipse.resources.prefs shows:
> #Thu Feb 03 15:01:21 CET 2011
> eclipse.preferences.version=1
> encoding/<project>=ISO-8859-1
>
> I have to re-define text encoding each time I re-open the project and if
> I forget it I get bad transcoded caracters. Realy boring :evil:

I have not heard of this problem before, but to check the obvious ... is
this a "shared" project? could a team mate be changing it back?
I assume you have not other software/plugins installed that might be
changing it back?

Also, I have seen some recent bugs about encoding preferences not
"taking", see bug 202384,
https://bugs.eclipse.org/bugs/show_bug.cgi?id=202384
but think that had to do with closing/reopening a project.

You might search the platform's bugs and see if any matches, and if not,
perhaps open one, if you can provide reproducible steps, on a clean
install of just Eclipse code.
Re: project text encoding resetted each time [message #658613 is a reply to message #652979] Wed, 09 March 2011 09:23 Go to previous message
chen thierry is currently offline chen thierry
Messages: 24
Registered: June 2010
Junior Member
I face the same problem since eclipse 3.1 until now with Eclipse 3.5.2 and PHP Development Tools (PDT) SDK Feature 2.1.1.v20090707-1108-51584QACJCRCUeNRkNYbOJecWK9O :

Posted many times about that subject. No solutions found.

Each time I open a project I have to reset again and again resource text encoding to iso-8859-1. Sometimes I forget and get bad transcoded characters in all files I edited. I get mad with that. Twisted Evil
Previous Topic:Tomcat 7 in Indigo.
Next Topic:Failed to start server, but server is started
Goto Forum:
  


Current Time: Tue Sep 23 22:31:00 GMT 2014

Powered by FUDForum. Page generated in 0.02010 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software