Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » application can't start after exported
application can't start after exported [message #652584] Fri, 04 February 2011 10:53 Go to next message
Luiz E. is currently offline Luiz E.
Messages: 97
Registered: September 2010
Member
hi all!
i'm really messed up here...my app works fine inside eclipse, but when exported, the app throws a error like this:

!SESSION 2011-02-04 13:45:50.718 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0-ea
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=pt_BR
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY fiscal-modelos 4 0 2011-02-04 13:45:51.406
!MESSAGE 
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.osgi; bundle-version="3.6.1"
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1313)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1297)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:309)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:370)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1068)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:557)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:464)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:248)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:445)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

!ENTRY org.eclipse.osgi 4 0 2011-02-04 13:45:51.406
!MESSAGE Bundle initial@reference:file:plugins/fiscal-modelos_0.2.0.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2011-02-04 13:45:51.406
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:613)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1407)

!ENTRY org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.registry_3.5.0.v20100503.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.equinox.registry 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing imported package org.eclipse.osgi.service.localization_1.1.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle initial@reference:file:plugins/fiscal-modelos_0.2.0.jar/ was not resolved.
!SUBENTRY 2 fiscal-modelos 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.osgi_3.6.1.

!ENTRY org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle fiscal-modelos_0.2.0 [3] was not resolved.
!SUBENTRY 2 fiscal-modelos 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.osgi_3.6.1.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle fiscal-ui_0.1.0 [4] was not resolved.
!SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.ui.intro_3.4.0.
!SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.runtime_0.0.0.
!SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.swt.layout.grouplayout_1.1.0.
!SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.ui.views.log_1.0.100.
!SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle fiscal-modelos_0.2.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.core.contenttype_3.4.100.v20100505-1235 [10] was not resolved.
!SUBENTRY 2 org.eclipse.core.contenttype 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.core.expressions_3.4.200.v20100505 [15] was not resolved.
!SUBENTRY 2 org.eclipse.core.expressions 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.3.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.core.runtime_3.6.0.v20100505 [17] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing imported package org.eclipse.core.internal.runtime.auth_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.core.runtime.compatibility.registry_3.3.0.v20100520 [18] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime.compatibility.registry 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing host org.eclipse.equinox.registry_[3.5.0,3.6.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.equinox.app_1.3.1.R36x_v20100803 [19] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.app 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.equinox.app 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing imported package org.osgi.service.event_1.0.0.
!SUBENTRY 2 org.eclipse.equinox.app 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing imported package org.osgi.service.event_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.equinox.registry_3.5.0.v20100503 [22] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.registry 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing imported package org.eclipse.osgi.service.localization_1.1.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.help_3.5.0.v20100524 [23] was not resolved.
!SUBENTRY 2 org.eclipse.help 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.6.0,4.0.0).
!SUBENTRY 2 org.eclipse.help 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.expressions_[3.4.200,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.swt.layout.grouplayout_1.1.0 [36] was not resolved.
!SUBENTRY 2 org.eclipse.swt.layout.grouplayout 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 2 org.eclipse.swt.layout.grouplayout 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.runtime_0.0.0.
!SUBENTRY 2 org.eclipse.swt.layout.grouplayout 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.swt.widgets.baseline_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.swt.widgets.baseline_1.1.0 [37] was not resolved.
!SUBENTRY 2 org.eclipse.swt.widgets.baseline 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.runtime_0.0.0.
!SUBENTRY 2 org.eclipse.swt.widgets.baseline 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.ui_3.6.1.M20100826-1330 [39] was not resolved.
!SUBENTRY 2 org.eclipse.ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.ui.workbench_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.expressions_[3.4.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
!MESSAGE Bundle org.eclipse.ui.forms_3.5.2.r36_v20100702 [40] was not resolved.
!SUBENTRY 2 org.eclipse.ui.forms 2 0 2011-02-04 13:45:51.421
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.6.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.forms 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing optionally required bundle org.eclipse.ui_[3.6.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.437
!MESSAGE Bundle org.eclipse.ui.intro_3.4.0.v20100427 [41] was not resolved.
!SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.6.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.help_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing optionally required bundle org.eclipse.help.base_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.ui_[3.6.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.ui.forms_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.core.expressions_3.4.200.
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.437
!MESSAGE Bundle org.eclipse.ui.views.log_1.0.100.v20100423 [42] was not resolved.
!SUBENTRY 2 org.eclipse.ui.views.log 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.views.log 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing optionally required bundle org.eclipse.core.filesystem_[1.1.0,2.0.0).
!SUBENTRY 2 org.eclipse.ui.views.log 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.ui_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.views.log 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_[3.3.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.437
!MESSAGE Bundle org.eclipse.ui.workbench_3.6.1.M20100826-1330 [43] was not resolved.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.6.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.help_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2011-02-04 13:45:51.437
!MESSAGE Missing required bundle org.eclipse.core.expressions_[3.4.0,4.0.0).


my app have three plugins: fiscal-modelos (the models, daos, entitymanager, etc), and fisca-ui (views, editors, listeners, product, etc).

and my fiscal-model dependencies:
http://i.imgur.com/2OPxK.png
Re: application can't start after exported [message #653792 is a reply to message #652584] Fri, 11 February 2011 03:55 Go to previous message
Ivan Larionov is currently offline Ivan Larionov
Messages: 37
Registered: July 2009
Member
Hi Luiz Eduardo,

It seems to be some problem with your plugin's dependencies. How did you
export the application? Have you created a product configuration and
populated it with your plugin and all its required dependencies?

Regards,
Ivan

On 04.02.2011 17:53, Luiz Eduardo K. wrote:
> hi all!
> i'm really messed up here...my app works fine inside eclipse, but when
> exported, the app throws a error like this:
>
>
> !SESSION 2011-02-04 13:45:50.718
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.7.0-ea
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=pt_BR
> Command-line arguments: -os win32 -ws win32 -arch x86
>
> !ENTRY fiscal-modelos 4 0 2011-02-04 13:45:51.406
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.osgi;
> bundle-version="3.6.1"
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolverError(AbstractBundle.java:1313)
>
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolutionFailureException(AbstractBundle.java:1297)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:309)
>
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:370)
>
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1068)
>
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:557)
>
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:464)
>
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:248)
>
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:445)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:227)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:337)
>
>
> !ENTRY org.eclipse.osgi 4 0 2011-02-04 13:45:51.406
> !MESSAGE Bundle initial@reference:file:plugins/fiscal-modelos_0.2.0.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2011-02-04 13:45:51.406
> !MESSAGE Application error
> !STACK 1
> java.lang.IllegalStateException: Unable to acquire application service.
> Ensure that the org.eclipse.core.runtime bundle is resolved and started
> (see config.ini).
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:74)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:57)
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:43)
>
> at java.lang.reflect.Method.invoke(Method.java:613)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 619)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
>
> !ENTRY org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE One or more bundles are not resolved because the following root
> constraints are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle
> initial@reference :file:plugins/org.eclipse.equinox.registry_3.5.0.v20100503.j ar/
> was not resolved.
> !SUBENTRY 2 org.eclipse.equinox.registry 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing imported package
> org.eclipse.osgi.service.localization_1.1.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle initial@reference:file:plugins/fiscal-modelos_0.2.0.jar/
> was not resolved.
> !SUBENTRY 2 fiscal-modelos 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.osgi_3.6.1.
>
> !ENTRY org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE The following is a complete list of bundles which are not
> resolved, see the prior log entry for the root cause if it exists:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle fiscal-modelos_0.2.0 was not resolved.
> !SUBENTRY 2 fiscal-modelos 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.osgi_3.6.1.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle fiscal-ui_0.1.0 was not resolved.
> !SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.ui.intro_3.4.0.
> !SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
> !SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.core.runtime_0.0.0.
> !SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.swt.layout.grouplayout_1.1.0.
> !SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.ui.views.log_1.0.100.
> !SUBENTRY 2 fiscal-ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle fiscal-modelos_0.2.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.core.contenttype_3.4.100.v20100505-1235
> was not resolved.
> !SUBENTRY 2 org.eclipse.core.contenttype 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle
> org.eclipse.equinox.registry_[3.2.0,4.0.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.core.expressions_3.4.200.v20100505 was
> not resolved.
> !SUBENTRY 2 org.eclipse.core.expressions 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.core.runtime_[3.3.0,4.0.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.core.runtime_3.6.0.v20100505 was not
> resolved.
> !SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle
> org.eclipse.equinox.registry_[3.4.0,4.0.0).
> !SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle
> org.eclipse.core.contenttype_[3.3.0,4.0.0).
> !SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing optionally required bundle
> org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).
> !SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).
> !SUBENTRY 2 org.eclipse.core.runtime 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing imported package
> org.eclipse.core.internal.runtime.auth_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle
> org.eclipse.core.runtime.compatibility.registry_3.3.0.v20100 520 was
> not resolved.
> !SUBENTRY 2 org.eclipse.core.runtime.compatibility.registry 2 0
> 2011-02-04 13:45:51.421
> !MESSAGE Missing host org.eclipse.equinox.registry_[3.5.0,3.6.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.equinox.app_1.3.1.R36x_v20100803 was
> not resolved.
> !SUBENTRY 2 org.eclipse.equinox.app 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle
> org.eclipse.equinox.registry_[3.4.0,4.0.0).
> !SUBENTRY 2 org.eclipse.equinox.app 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing imported package org.osgi.service.event_1.0.0.
> !SUBENTRY 2 org.eclipse.equinox.app 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing imported package org.osgi.service.event_1.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.equinox.registry_3.5.0.v20100503 was
> not resolved.
> !SUBENTRY 2 org.eclipse.equinox.registry 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing imported package
> org.eclipse.osgi.service.localization_1.1.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.help_3.5.0.v20100524 was not resolved.
> !SUBENTRY 2 org.eclipse.help 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.core.runtime_[3.6.0,4.0.0).
> !SUBENTRY 2 org.eclipse.help 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle
> org.eclipse.core.expressions_[3.4.200,4.0.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.swt.layout.grouplayout_1.1.0 was not
> resolved.
> !SUBENTRY 2 org.eclipse.swt.layout.grouplayout 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
> !SUBENTRY 2 org.eclipse.swt.layout.grouplayout 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.core.runtime_0.0.0.
> !SUBENTRY 2 org.eclipse.swt.layout.grouplayout 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.swt.widgets.baseline_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.swt.widgets.baseline_1.1.0 was not
> resolved.
> !SUBENTRY 2 org.eclipse.swt.widgets.baseline 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.core.runtime_0.0.0.
> !SUBENTRY 2 org.eclipse.swt.widgets.baseline 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.ui_3.6.1.M20100826-1330 was not resolved.
> !SUBENTRY 2 org.eclipse.ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.core.runtime_[3.2.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.ui.workbench_[3.5.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle
> org.eclipse.core.expressions_[3.4.0,4.0.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.421
> !MESSAGE Bundle org.eclipse.ui.forms_3.5.2.r36_v20100702 was not
> resolved.
> !SUBENTRY 2 org.eclipse.ui.forms 2 0 2011-02-04 13:45:51.421
> !MESSAGE Missing required bundle org.eclipse.core.runtime_[3.6.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.forms 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing optionally required bundle org.eclipse.ui_[3.6.0,4.0.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.437
> !MESSAGE Bundle org.eclipse.ui.intro_3.4.0.v20100427 was not resolved.
> !SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.core.runtime_[3.6.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.help_[3.5.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing optionally required bundle
> org.eclipse.help.base_[3.5.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.ui_[3.6.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.ui.forms_[3.5.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.intro 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.core.expressions_3.4.200.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.437
> !MESSAGE Bundle org.eclipse.ui.views.log_1.0.100.v20100423 was not
> resolved.
> !SUBENTRY 2 org.eclipse.ui.views.log 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.core.runtime_[3.2.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.views.log 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing optionally required bundle
> org.eclipse.core.filesystem_[1.1.0,2.0.0).
> !SUBENTRY 2 org.eclipse.ui.views.log 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.ui_[3.3.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.views.log 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing optionally required bundle
> org.eclipse.ui.ide_[3.3.0,4.0.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-02-04 13:45:51.437
> !MESSAGE Bundle org.eclipse.ui.workbench_3.6.1.M20100826-1330 [43] was
> not resolved.
> !SUBENTRY 2 org.eclipse.ui.workbench 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.core.runtime_[3.6.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.workbench 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle org.eclipse.help_[3.2.0,4.0.0).
> !SUBENTRY 2 org.eclipse.ui.workbench 2 0 2011-02-04 13:45:51.437
> !MESSAGE Missing required bundle
> org.eclipse.core.expressions_[3.4.0,4.0.0).
>
>
> my app have three plugins: fiscal-modelos (the models, daos,
> entitymanager, etc), and fisca-ui (views, editors, listeners, product,
> etc).
>
> and my fiscal-model dependencies:
>
Previous Topic:How can I enable/disable main tool bar buttons?
Next Topic:Plugin does not seem to start when running exported product
Goto Forum:
  


Current Time: Tue Jul 22 21:48:25 EDT 2014

Powered by FUDForum. Page generated in 0.02224 seconds