Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » [HUTN] Problem with EAnnotations from Ecore
[HUTN] Problem with EAnnotations from Ecore [message #652299] Thu, 03 February 2011 09:13 Go to next message
Jes is currently offline Jes
Messages: 9
Registered: November 2010
Junior Member
Hi!

I'm defining a model with HUTN and I'm having problemas with one element (TableHeader) that inherits from EModelElement (class from Ecore).

That element has a property (eAnnotations) whose type is EAnnotation (from Ecore metamodel).

I can't instantiate the EAnnotation object, shows me this error:

[Line: 150, Column: 46, Reason: Cannot instantiate the enumeration or data type: EAnnotation, Line: 150, Column: 32, Reason: Expected EAnnotation for: eAnnotations]

Could you help me?

Thanks.

PS: If you give me an email address I send you the metamodel and the HUTN model.
Re: [HUTN] Problem with EAnnotations from Ecore [message #652309 is a reply to message #652299] Thu, 03 February 2011 09:42 Go to previous messageGo to next message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 833
Registered: July 2009
Senior Member
Hi,

Could you please send us your metamodel and HUTN file at epsilon.devs gmail com?

Cheers,
Dimitris
Re: [HUTN] Problem with EAnnotations from Ecore [message #652327 is a reply to message #652299] Thu, 03 February 2011 10:31 Go to previous messageGo to next message
Jes is currently offline Jes
Messages: 9
Registered: November 2010
Junior Member
I have already sent you the files.

Waiting for your response.

Thanks.
Re: [HUTN] Problem with EAnnotations from Ecore [message #652402 is a reply to message #652327] Thu, 03 February 2011 13:33 Go to previous messageGo to next message
Louis Rose is currently offline Louis Rose
Messages: 439
Registered: July 2009
Location: York, United Kingdom
Senior Member
Hi Jesús,

EAnnotation is defined in the Ecore metamodel, and so the HUTN document must import both your metamodel and the Ecore metamodel:

@Spec {
	metamodel "0.1.0" {
		nsUri: "http:///es.cv.gvcase.mdt.sketcher/0.1.0"
	}
	metamodel "ecore" {
		nsUri: "http://www.eclipse.org/emf/2002/Ecore"
	}
}


That should fix the problem.

Cheers,
Louis.
Re: [HUTN] Problem with EAnnotations from Ecore [message #652417 is a reply to message #652299] Thu, 03 February 2011 14:44 Go to previous message
Jes is currently offline Jes
Messages: 9
Registered: November 2010
Junior Member
Problem fixed.

Thank you very much! Smile
Previous Topic:Questions Regarding EVL extension in order to navigate to workspace resource (Folder, File, etc)
Next Topic:Code Beautifier
Goto Forum:
  


Current Time: Thu Aug 21 23:59:37 EDT 2014

Powered by FUDForum. Page generated in 0.01678 seconds