Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Y axis showing exponential value
Y axis showing exponential value [message #652231] Thu, 03 February 2011 04:55 Go to next message
sandy
Messages: 13
Registered: October 2010
Junior Member
Hi,

we have a chart where the y axis values range between 0 to thousands. When the chart is rendered the Y axis step labels are displaying with exponential value..

ex. 6E-301, 2E-300, etc.

The y xis step labels display vary
for e.x. for one set of report parameters, with this format

yAxis.setFormatSpecifier( JavaNumberFormatSpecifierImpl.create("$###.##") );

the dollar is displayed. But with the same format for another set of parameters , the dollar is not displayed.

How to change it so that it is displayed without exponents and decimals?

[Updated on: Thu, 03 February 2011 05:10]

Report message to a moderator

Re: Y axis showing exponential value [message #652366 is a reply to message #652231] Thu, 03 February 2011 11:45 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Are you using auto scaling or do you have a manual scale in?
There is a format button on the y-axis node in the chart wizard. Have
you tried it?

Jason

On 2/3/2011 4:55 AM, sandy wrote:
> Hi,
>
> we have a chart where the y axis values range between 0 to thousands.
> When the chart is rendered the Y axis step labels are displaying with
> exponential value..
>
> ex. 6E-301, 2E-300, etc.
> How to change it so that it is displayed without exponents and decimals?


Jason Weathersby

BIRT Exchange
Re: Y axis showing exponential value [message #652856 is a reply to message #652366] Mon, 07 February 2011 07:02 Go to previous messageGo to next message
sandy
Messages: 13
Registered: October 2010
Junior Member
The Y-axis display format is Auto and the Scaling is Manual with No of Steps=10.

Any idea?
Re: Y axis showing exponential value [message #652983 is a reply to message #652856] Mon, 07 February 2011 14:04 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Did you try to set a format?
What version of BIRT are you using?

Jason

On 2/7/2011 7:02 AM, sandy wrote:
> The Y-axis display format is Auto and the Scaling is Manual with No of
> Steps=10.
>
> Any idea?


Jason Weathersby

BIRT Exchange
Previous Topic:Formatting date in Dynamic text
Next Topic:Best practice for dynamically modifying a report
Goto Forum:
  


Current Time: Sun Apr 20 12:23:46 EDT 2014

Powered by FUDForum. Page generated in 0.02504 seconds