Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » RCP dependant OS executables
RCP dependant OS executables [message #651194] Fri, 28 January 2011 05:41 Go to next message
Lowebb  is currently offline Lowebb
Messages: 3
Registered: October 2010
Junior Member
I've hit an issue with a 64-bit JVM on the windows platform. I cannot run my RCP exe via the 32bit (win32,win32,x86) deliverable (JVM Exit Code=-1)

However though I can happily build 64 bit linux versions, I cannot workout how to build a 64 bit version for windows.

Am I missing something here or is this a known issue?
Re: RCP dependant OS executables [message #651253 is a reply to message #651194] Fri, 28 January 2011 10:06 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

On 01/28/2011 05:41 AM, Lowebb wrote:
> I've hit an issue with a 64-bit JVM on the windows platform. I cannot
> run my RCP exe via the 32bit (win32,win32,x86) deliverable (JVM Exit
> Code=-1)

If you have a 64-bit JVM, you need to run the 64-bit eclipse
(win32,win32,x86_64) ... does that work?

PW


--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Re: RCP dependant OS executables [message #654252 is a reply to message #651194] Mon, 14 February 2011 13:55 Go to previous message
Lowebb  is currently offline Lowebb
Messages: 3
Registered: October 2010
Junior Member
The issue was in my build_rcp.properties. It didn't contain a reference to win32.x86_64. Sufficient googling produced the missing entry and that allowed me to build a 64bit specific windows exe.

Smile
Previous Topic:how to open an empty editor at startup
Next Topic:How to reuse the Properties View?
Goto Forum:
  


Current Time: Sat Aug 23 09:38:04 EDT 2014

Powered by FUDForum. Page generated in 0.02132 seconds