Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » Unable to create a new database connection in DSE
Unable to create a new database connection in DSE [message #651114] Thu, 27 January 2011 14:55 Go to next message
Daniel Ceregatti is currently offline Daniel Ceregatti
Messages: 2
Registered: July 2009
Junior Member
Hi,

I've added a Postgresql 8.4 driver definition, but DSE fails to create a DB connection when I use the dialog. I input the appropriate values, and even use test connection, which reports "ping successful!", but when I click finish, it just silently fails. No new connection is added to DSE.

I'm using DTP 1.8.1 on 64 bit Eclipse Version: 3.6.1 Build id: M20100909-0800 on Linux, Fedora 13.

One thing I noticed that if I press next instead of finish, I'm shown the summary screen, which shows "Name" and "Description" at the top, but they're blank. I can find no place to add these properties anywhere in the previous dialog.

Thanks,

Daniel
Re: Unable to create a new database connection in DSE [message #651628 is a reply to message #651114] Mon, 31 January 2011 18:19 Go to previous messageGo to next message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
Hi Daniel

That's definitely odd. I don't have any way of testing the 64 bit
version of Eclipse here, nor do I have any Postgres databases to test
against.

The Postgres support is located in the enablement plugins:

* org.eclipse.datatools.enablement.postgresql
* org.eclipse.datatools.enablement.postgresql.dbdefinition
* org.eclipse.datatools.enablement.postgresql.ui

The wizard doesn't seem to be contributing anything beyond what's in the
generic UI - uid, pwd, url, database name. So you might start with
what's there and see if you can get anywhere.

--Fitz

Daniel Ceregatti wrote:
> Hi,
>
> I've added a Postgresql 8.4 driver definition, but DSE fails to create a
> DB connection when I use the dialog. I input the appropriate values, and
> even use test connection, which reports "ping successful!", but when I
> click finish, it just silently fails. No new connection is added to DSE.
>
> I'm using DTP 1.8.1 on 64 bit Eclipse Version: 3.6.1 Build id:
> M20100909-0800 on Linux, Fedora 13.
>
> One thing I noticed that if I press next instead of finish, I'm shown
> the summary screen, which shows "Name" and "Description" at the top, but
> they're blank. I can find no place to add these properties anywhere in
> the previous dialog.
>
> Thanks,
>
> Daniel
Re: Unable to create a new database connection in DSE [message #651629 is a reply to message #651114] Mon, 31 January 2011 18:21 Go to previous messageGo to next message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
Is it by chance that you're using a 32 bit JDBC driver on a 64-bit
machine and it's having issues that way? Not knowing how 64-bit OSes
would affect Eclipse and therefore DTP really hampers my knowing what
might happen there.

Can you write code against the Postgres JDBC driver outside of DTP that
can connect to a database successfully?

It doesn't seem that the driver would be the issue however based on what
you've said here.

--Fitz

Daniel Ceregatti wrote:
> Hi,
>
> I've added a Postgresql 8.4 driver definition, but DSE fails to create a
> DB connection when I use the dialog. I input the appropriate values, and
> even use test connection, which reports "ping successful!", but when I
> click finish, it just silently fails. No new connection is added to DSE.
>
> I'm using DTP 1.8.1 on 64 bit Eclipse Version: 3.6.1 Build id:
> M20100909-0800 on Linux, Fedora 13.
>
> One thing I noticed that if I press next instead of finish, I'm shown
> the summary screen, which shows "Name" and "Description" at the top, but
> they're blank. I can find no place to add these properties anywhere in
> the previous dialog.
>
> Thanks,
>
> Daniel
Re: Unable to create a new database connection in DSE [message #651641 is a reply to message #651114] Mon, 31 January 2011 20:39 Go to previous message
Daniel Ceregatti is currently offline Daniel Ceregatti
Messages: 2
Registered: July 2009
Junior Member
I've figured out the problem:

DSE -> "Database Connections" -> (Right click) New

!=

DSE -> "New connection profile" (icon in the DSE view toolbar)

The latter has a page for adding the Name and Description, the former does not. Once I used the latter, I was able to add the new connection.

Daniel
Previous Topic:Usage of DTP - Questions
Next Topic:Oracle DB URL failure, must have slash
Goto Forum:
  


Current Time: Sun Apr 20 09:36:43 EDT 2014

Powered by FUDForum. Page generated in 0.01893 seconds