Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Beginner setup problems(JDBC / JDK issues)
Beginner setup problems [message #650037] Fri, 21 January 2011 14:14 Go to next message
Tori  is currently offline Tori
Messages: 18
Registered: July 2009
Junior Member
Hi,

I can't seem to get EclipseLink Workbench to run correctly. I 'think' i have setup files setup correctly but obviously I am missing something...

I get two main errors.

1) cannot find teh mysql jdbc driver
2) on startup it throws a jdk error... "[: 15: /usr/lib/jvm/java-6-openjdk: unexpected operator"

Basically... workbench starts...but command line shows above error.
I try to connect to MySQL and i cannot. The JDBC driver does exist at location I specify...Netbeans can connect to MySQL etc...

Any help much appreciated. I am using LinuxMint 9 OS.

Please see my setenv.sh, workbench.sh and my LinuxMint /etc/environment file pasted below...


Thanks,
T
setenv.sh:

#!/bin/sh

# User MUST set DRIVER_CLASSPATH to point to their desired driver jar(s), such as JDBC and J2C. For example:
# DRIVER_CLASSPATH=/some_dir/jdbc/ojdbc14.jar:/some_other_dir/ j2c/aqapi.jar; export DRIVER_CLASSPATH
#
# Note: DRIVER_CLASSPATH should NOT contain any classes for your persistent business objects - these are
# configured in the Mapping Workbench project.
DRIVER_CLASSPATH=/usr/share/java/mysql-connector-java-5.1.10 .jar; export JDBC_CLASSPATH
# User MUST set INSTALL_JAVA_HOME to point a supported JRE. If none
# is provided for INSTALL_JAVA_HOME then the system JAVA_HOME
# value will be used
INSTALL_JAVA_HOME=/usr/lib/jvm/java-6-openjdk/;
if [ "$JAVA_HOME" == "" ]; then
JAVA_HOME=$INSTALL_JAVA_HOME; export JAVA_HOME
fi

workbench.sh
#!/bin/sh
#. `dirname $0`../../../bin/setenv.sh

/home/brian/installed/eclipselink/bin/setenv.sh

# User may increase Java memory setting(s) if desired:
JVM_ARGS=-Xmx256m

# Please do not change any of the following lines:
CLASSPATH=`dirname $0`/../jlib/xercesImpl.jar:\
`dirname $0`/../jlib/connector.jar:\
`dirname $0`/../../../jlib/eclipselink.jar:\
`dirname $0`/../jlib/elmwcore.jar:\
`dirname $0`/../jlib/eclipselinkmw.jar:\
`dirname $0`/../../../jlib/jpa/javax.persistence_1.0.0.jar:\
`dirname $0`/../config:\
${DRIVER_CLASSPATH}

WORKBENCH_ARGS=-open "$@"

${JAVA_HOME}/bin/java ${JVM_ARGS} -cp ${CLASSPATH} \
org.eclipse.persistence.tools.workbench.Main ${WORKBENCH_ARGS}

/etc/environment
PATH=" /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin :/usr/games:/usr/lib/jvm/java-6-openjdk/bin "
GWT_HOME="/home/brian/Code/libraries/GWT SDK/gwt-2.0.4"
GIT_SSH="gitssh"
ECLIPSELINK_HOME="/home/brian/installed/eclipselink"
JAVA_HOME="/usr/lib/jvm/java-6-openjdk"
Re: Beginner setup problems [message #650367 is a reply to message #650037] Mon, 24 January 2011 16:17 Go to previous messageGo to next message
Chris Delahunt is currently offline Chris Delahunt
Messages: 1026
Registered: July 2009
Senior Member
I cannot comment on the openjdk error, but there is a space before the ".jar' in the "mysql-connector-java-5.1.10 .jar" that might have been a cut+paste error and could cause the problem with the driver. Have you tried a different JDK or is there more to the error that pops up that might help debug it?

Best Regards,
Chris
Re: Beginner setup problems [message #650440 is a reply to message #650367] Mon, 24 January 2011 21:17 Go to previous message
Tori  is currently offline Tori
Messages: 18
Registered: July 2009
Junior Member
Hi Chris..

Thanks for the reply...
The forum font made it look like a space... unfortunately there is none. Also there are no other errors!!..

I haven't tried a different JDK but I will...

Cheers
T
Previous Topic:eclipselink.ddl-generation - best practice
Next Topic:@postload problem : never called
Goto Forum:
  


Current Time: Thu Oct 02 12:38:13 GMT 2014

Powered by FUDForum. Page generated in 0.02121 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software