Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Technology Project and PMC » "IllegalArgumentException:Argument cannot be null" at startup
"IllegalArgumentException:Argument cannot be null" at startup [message #65144] Fri, 13 August 2004 05:34 Go to next message
Eclipse User
Originally posted by: cj.hotmail.com

Hello,

sorry for the post to several groups, but we are hitting the wall trying to
figure out why this exception is being thrown and thus preventing Eclipse
3.0 from starting up. Can anyone help?

We are trying to run Eclipse 3.0 on Solaris while connecting to it from
Windows XP pro using Reflection.
We are calling it with:

<eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M

The splash screen comes up, then there is a dialog box indicating that there
was an error and that the details have been saved into a log file in the
../configuration directory. Here is the contents of such file:

!SESSION Aug 12, 2004
18:10:16.784 ---------------------------------------------
eclipse.buildId=I200406251208
java.version=1.4.2_05
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en

!ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
!MESSAGE Application error
!STACK 1
java.lang.IllegalArgumentException: Argument cannot be null
at org.eclipse.swt.SWT.error(SWT.java:2677)
at org.eclipse.swt.SWT.error(SWT.java:2616)
at org.eclipse.swt.SWT.error(SWT.java:2587)
at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
at
org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.java:412)
at
org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:430)
at
org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
at
org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
at
org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:182)
at
org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
at
org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.java:93)
at org.eclipse.jface.window.Window.create(Window.java:348)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
at org.eclipse.jface.window.Window.open(Window.java:637)
at
org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDialog.java:65)
at
org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication.java:314)
at
org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplication.java:219)
at
org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:335)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
at org.eclipse.core.launcher.Main.run(Main.java:644)
at org.eclipse.core.launcher.Main.main(Main.java:628)
Re: "IllegalArgumentException:Argument cannot be null" at startup [message #65167 is a reply to message #65144] Fri, 13 August 2004 07:42 Go to previous messageGo to next message
Eclipse User
Originally posted by: fayth.4xdamage.com

You know... I run into a similar problem on Windows XP if I pass the
-vmargs -Xm512M also. Drop that out of your statement to start. I've
never gotten eclipse to run when I pass that from the commandline.

Vic Hanson


cj wrote:
> Hello,
>
> sorry for the post to several groups, but we are hitting the wall trying to
> figure out why this exception is being thrown and thus preventing Eclipse
> 3.0 from starting up. Can anyone help?
>
> We are trying to run Eclipse 3.0 on Solaris while connecting to it from
> Windows XP pro using Reflection.
> We are calling it with:
>
> <eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M
>
> The splash screen comes up, then there is a dialog box indicating that there
> was an error and that the details have been saved into a log file in the
> ./configuration directory. Here is the contents of such file:
>
> !SESSION Aug 12, 2004
> 18:10:16.784 ---------------------------------------------
> eclipse.buildId=I200406251208
> java.version=1.4.2_05
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en
>
> !ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
> !MESSAGE Application error
> !STACK 1
> java.lang.IllegalArgumentException: Argument cannot be null
> at org.eclipse.swt.SWT.error(SWT.java:2677)
> at org.eclipse.swt.SWT.error(SWT.java:2616)
> at org.eclipse.swt.SWT.error(SWT.java:2587)
> at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
> at
> org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.java:412)
> at
> org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:430)
> at
> org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
> at
> org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
> at
> org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:182)
> at
> org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
> at
> org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.java:93)
> at org.eclipse.jface.window.Window.create(Window.java:348)
> at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
> at org.eclipse.jface.window.Window.open(Window.java:637)
> at
> org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDialog.java:65)
> at
> org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication.java:314)
> at
> org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplication.java:219)
> at
> org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
> at
> org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:335)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:324)
> at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
> at org.eclipse.core.launcher.Main.run(Main.java:644)
> at org.eclipse.core.launcher.Main.main(Main.java:628)
>
>
>
>
Re: "IllegalArgumentException:Argument cannot be null" at startup [message #65190 is a reply to message #65167] Fri, 13 August 2004 14:35 Go to previous messageGo to next message
Carolyn MacLeod is currently offline Carolyn MacLeod
Messages: 149
Registered: July 2009
Senior Member
I use -vmargs -Xmx400m
I think you need the 'x'.
If that's not it, then maybe this link might help:
http://www.eclipse.org/documentation/html/plugins/org.eclips e.platform.doc.user/doc/tasks/running_eclipse.htm

Good luck,
Carolyn

"Vic Hanson" <fayth@4xdamage.com> wrote in message
news:cfhr8e$apt$1@eclipse.org...
> You know... I run into a similar problem on Windows XP if I pass the
> -vmargs -Xm512M also. Drop that out of your statement to start. I've
> never gotten eclipse to run when I pass that from the commandline.
>
> Vic Hanson
>
>
> cj wrote:
> > Hello,
> >
> > sorry for the post to several groups, but we are hitting the wall trying
to
> > figure out why this exception is being thrown and thus preventing
Eclipse
> > 3.0 from starting up. Can anyone help?
> >
> > We are trying to run Eclipse 3.0 on Solaris while connecting to it from
> > Windows XP pro using Reflection.
> > We are calling it with:
> >
> > <eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M
> >
> > The splash screen comes up, then there is a dialog box indicating that
there
> > was an error and that the details have been saved into a log file in the
> > ./configuration directory. Here is the contents of such file:
> >
> > !SESSION Aug 12, 2004
> > 18:10:16.784 ---------------------------------------------
> > eclipse.buildId=I200406251208
> > java.version=1.4.2_05
> > java.vendor=Sun Microsystems Inc.
> > BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en
> >
> > !ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
> > !MESSAGE Application error
> > !STACK 1
> > java.lang.IllegalArgumentException: Argument cannot be null
> > at org.eclipse.swt.SWT.error(SWT.java:2677)
> > at org.eclipse.swt.SWT.error(SWT.java:2616)
> > at org.eclipse.swt.SWT.error(SWT.java:2587)
> > at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
> > at
> >
org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.ja
va:412)
> > at
> >
org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:
430)
> > at
> >
org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
> > at
> > org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
> > at
> >
org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:
182)
> > at
> > org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
> > at
> >
org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.jav
a:93)
> > at org.eclipse.jface.window.Window.create(Window.java:348)
> > at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
> > at org.eclipse.jface.window.Window.open(Window.java:637)
> > at
> >
org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDial
og.java:65)
> > at
> >
org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication
..java:314)
> > at
> >
org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplicat
ion.java:219)
> > at
> > org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
> > at
> >
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.
java:335)
> > at
> >
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
> > at
> >
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
> > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> > at
> >
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39
)
> > at
> >
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl
..java:25)
> > at java.lang.reflect.Method.invoke(Method.java:324)
> > at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
> > at org.eclipse.core.launcher.Main.run(Main.java:644)
> > at org.eclipse.core.launcher.Main.main(Main.java:628)
> >
> >
> >
> >
Re: "IllegalArgumentException:Argument cannot be null" at startup [message #65211 is a reply to message #65190] Fri, 13 August 2004 15:18 Go to previous messageGo to next message
Eclipse User
Originally posted by: Chris_Laffra.ca.ibm.com

Try passing in -data <workspace-location> and see if that helps
(do this before the -vmArgs arg)

Chris

"Carolyn MacLeod" <Carolyn_MacLeod@ca.ibm.com> wrote in message
news:cfijfl$i8f$1@eclipse.org...
> I use -vmargs -Xmx400m
> I think you need the 'x'.
> If that's not it, then maybe this link might help:
>
http://www.eclipse.org/documentation/html/plugins/org.eclips e.platform.doc.user/doc/tasks/running_eclipse.htm
>
> Good luck,
> Carolyn
>
> "Vic Hanson" <fayth@4xdamage.com> wrote in message
> news:cfhr8e$apt$1@eclipse.org...
> > You know... I run into a similar problem on Windows XP if I pass the
> > -vmargs -Xm512M also. Drop that out of your statement to start. I've
> > never gotten eclipse to run when I pass that from the commandline.
> >
> > Vic Hanson
> >
> >
> > cj wrote:
> > > Hello,
> > >
> > > sorry for the post to several groups, but we are hitting the wall
trying
> to
> > > figure out why this exception is being thrown and thus preventing
> Eclipse
> > > 3.0 from starting up. Can anyone help?
> > >
> > > We are trying to run Eclipse 3.0 on Solaris while connecting to it
from
> > > Windows XP pro using Reflection.
> > > We are calling it with:
> > >
> > > <eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M
> > >
> > > The splash screen comes up, then there is a dialog box indicating that
> there
> > > was an error and that the details have been saved into a log file in
the
> > > ./configuration directory. Here is the contents of such file:
> > >
> > > !SESSION Aug 12, 2004
> > > 18:10:16.784 ---------------------------------------------
> > > eclipse.buildId=I200406251208
> > > java.version=1.4.2_05
> > > java.vendor=Sun Microsystems Inc.
> > > BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en
> > >
> > > !ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
> > > !MESSAGE Application error
> > > !STACK 1
> > > java.lang.IllegalArgumentException: Argument cannot be null
> > > at org.eclipse.swt.SWT.error(SWT.java:2677)
> > > at org.eclipse.swt.SWT.error(SWT.java:2616)
> > > at org.eclipse.swt.SWT.error(SWT.java:2587)
> > > at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
> > > at
> > >
>
org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.ja
> va:412)
> > > at
> > >
>
org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:
> 430)
> > > at
> > >
>
org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
> > > at
> > > org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
> > > at
> > >
>
org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:
> 182)
> > > at
> > >
org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
> > > at
> > >
>
org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.jav
> a:93)
> > > at org.eclipse.jface.window.Window.create(Window.java:348)
> > > at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
> > > at org.eclipse.jface.window.Window.open(Window.java:637)
> > > at
> > >
>
org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDial
> og.java:65)
> > > at
> > >
>
org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication
> .java:314)
> > > at
> > >
>
org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplicat
> ion.java:219)
> > > at
> > > org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
> > > at
> > >
>
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.
> java:335)
> > > at
> > >
>
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
> > > at
> > >
>
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
> > > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> > > at
> > >
>
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39
> )
> > > at
> > >
>
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl
> .java:25)
> > > at java.lang.reflect.Method.invoke(Method.java:324)
> > > at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
> > > at org.eclipse.core.launcher.Main.run(Main.java:644)
> > > at org.eclipse.core.launcher.Main.main(Main.java:628)
> > >
> > >
> > >
> > >
>
>
Re: "IllegalArgumentException:Argument cannot be null" at startup [message #65760 is a reply to message #65144] Wed, 22 September 2004 12:52 Go to previous message
Eclipse User
Originally posted by: krayspam.arcor.de

What do you mean by connecting to it from WinXp? Off hand id say you were
running the wrong native libraries, But i dont know what you mean exactly.


"cj" <cj@hotmail.com> wrote in message news:cfhjoa$1ft$1@eclipse.org...
> Hello,
>
> sorry for the post to several groups, but we are hitting the wall trying
> to
> figure out why this exception is being thrown and thus preventing Eclipse
> 3.0 from starting up. Can anyone help?
>
> We are trying to run Eclipse 3.0 on Solaris while connecting to it from
> Windows XP pro using Reflection.
> We are calling it with:
>
> <eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M
>
> The splash screen comes up, then there is a dialog box indicating that
> there
> was an error and that the details have been saved into a log file in the
> ./configuration directory. Here is the contents of such file:
>
> !SESSION Aug 12, 2004
> 18:10:16.784 ---------------------------------------------
> eclipse.buildId=I200406251208
> java.version=1.4.2_05
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en
>
> !ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
> !MESSAGE Application error
> !STACK 1
> java.lang.IllegalArgumentException: Argument cannot be null
> at org.eclipse.swt.SWT.error(SWT.java:2677)
> at org.eclipse.swt.SWT.error(SWT.java:2616)
> at org.eclipse.swt.SWT.error(SWT.java:2587)
> at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
> at
> org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.java:412)
> at
> org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:430)
> at
> org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
> at
> org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
> at
> org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:182)
> at
> org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
> at
> org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.java:93)
> at org.eclipse.jface.window.Window.create(Window.java:348)
> at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
> at org.eclipse.jface.window.Window.open(Window.java:637)
> at
> org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDialog.java:65)
> at
> org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication.java:314)
> at
> org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplication.java:219)
> at
> org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
> at
> org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:335)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:324)
> at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
> at org.eclipse.core.launcher.Main.run(Main.java:644)
> at org.eclipse.core.launcher.Main.main(Main.java:628)
>
>
>
>
Re: "IllegalArgumentException:Argument cannot be null" at startup [message #597898 is a reply to message #65144] Fri, 13 August 2004 07:42 Go to previous message
Vic Hanson is currently offline Vic Hanson
Messages: 23
Registered: July 2009
Junior Member
You know... I run into a similar problem on Windows XP if I pass the
-vmargs -Xm512M also. Drop that out of your statement to start. I've
never gotten eclipse to run when I pass that from the commandline.

Vic Hanson


cj wrote:
> Hello,
>
> sorry for the post to several groups, but we are hitting the wall trying to
> figure out why this exception is being thrown and thus preventing Eclipse
> 3.0 from starting up. Can anyone help?
>
> We are trying to run Eclipse 3.0 on Solaris while connecting to it from
> Windows XP pro using Reflection.
> We are calling it with:
>
> <eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M
>
> The splash screen comes up, then there is a dialog box indicating that there
> was an error and that the details have been saved into a log file in the
> ./configuration directory. Here is the contents of such file:
>
> !SESSION Aug 12, 2004
> 18:10:16.784 ---------------------------------------------
> eclipse.buildId=I200406251208
> java.version=1.4.2_05
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en
>
> !ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
> !MESSAGE Application error
> !STACK 1
> java.lang.IllegalArgumentException: Argument cannot be null
> at org.eclipse.swt.SWT.error(SWT.java:2677)
> at org.eclipse.swt.SWT.error(SWT.java:2616)
> at org.eclipse.swt.SWT.error(SWT.java:2587)
> at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
> at
> org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.java:412)
> at
> org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:430)
> at
> org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
> at
> org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
> at
> org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:182)
> at
> org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
> at
> org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.java:93)
> at org.eclipse.jface.window.Window.create(Window.java:348)
> at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
> at org.eclipse.jface.window.Window.open(Window.java:637)
> at
> org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDialog.java:65)
> at
> org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication.java:314)
> at
> org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplication.java:219)
> at
> org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
> at
> org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:335)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:324)
> at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
> at org.eclipse.core.launcher.Main.run(Main.java:644)
> at org.eclipse.core.launcher.Main.main(Main.java:628)
>
>
>
>
Re: "IllegalArgumentException:Argument cannot be null" at startup [message #597906 is a reply to message #65167] Fri, 13 August 2004 14:35 Go to previous message
Carolyn MacLeod is currently offline Carolyn MacLeod
Messages: 149
Registered: July 2009
Senior Member
I use -vmargs -Xmx400m
I think you need the 'x'.
If that's not it, then maybe this link might help:
http://www.eclipse.org/documentation/html/plugins/org.eclips e.platform.doc.user/doc/tasks/running_eclipse.htm

Good luck,
Carolyn

"Vic Hanson" <fayth@4xdamage.com> wrote in message
news:cfhr8e$apt$1@eclipse.org...
> You know... I run into a similar problem on Windows XP if I pass the
> -vmargs -Xm512M also. Drop that out of your statement to start. I've
> never gotten eclipse to run when I pass that from the commandline.
>
> Vic Hanson
>
>
> cj wrote:
> > Hello,
> >
> > sorry for the post to several groups, but we are hitting the wall trying
to
> > figure out why this exception is being thrown and thus preventing
Eclipse
> > 3.0 from starting up. Can anyone help?
> >
> > We are trying to run Eclipse 3.0 on Solaris while connecting to it from
> > Windows XP pro using Reflection.
> > We are calling it with:
> >
> > <eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M
> >
> > The splash screen comes up, then there is a dialog box indicating that
there
> > was an error and that the details have been saved into a log file in the
> > ./configuration directory. Here is the contents of such file:
> >
> > !SESSION Aug 12, 2004
> > 18:10:16.784 ---------------------------------------------
> > eclipse.buildId=I200406251208
> > java.version=1.4.2_05
> > java.vendor=Sun Microsystems Inc.
> > BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en
> >
> > !ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
> > !MESSAGE Application error
> > !STACK 1
> > java.lang.IllegalArgumentException: Argument cannot be null
> > at org.eclipse.swt.SWT.error(SWT.java:2677)
> > at org.eclipse.swt.SWT.error(SWT.java:2616)
> > at org.eclipse.swt.SWT.error(SWT.java:2587)
> > at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
> > at
> >
org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.ja
va:412)
> > at
> >
org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:
430)
> > at
> >
org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
> > at
> > org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
> > at
> >
org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:
182)
> > at
> > org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
> > at
> >
org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.jav
a:93)
> > at org.eclipse.jface.window.Window.create(Window.java:348)
> > at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
> > at org.eclipse.jface.window.Window.open(Window.java:637)
> > at
> >
org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDial
og.java:65)
> > at
> >
org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication
..java:314)
> > at
> >
org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplicat
ion.java:219)
> > at
> > org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
> > at
> >
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.
java:335)
> > at
> >
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
> > at
> >
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
> > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> > at
> >
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39
)
> > at
> >
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl
..java:25)
> > at java.lang.reflect.Method.invoke(Method.java:324)
> > at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
> > at org.eclipse.core.launcher.Main.run(Main.java:644)
> > at org.eclipse.core.launcher.Main.main(Main.java:628)
> >
> >
> >
> >
Re: "IllegalArgumentException:Argument cannot be null" at startup [message #597916 is a reply to message #65190] Fri, 13 August 2004 15:18 Go to previous message
Chris Laffra is currently offline Chris Laffra
Messages: 253
Registered: July 2009
Senior Member
Try passing in -data <workspace-location> and see if that helps
(do this before the -vmArgs arg)

Chris

"Carolyn MacLeod" <Carolyn_MacLeod@ca.ibm.com> wrote in message
news:cfijfl$i8f$1@eclipse.org...
> I use -vmargs -Xmx400m
> I think you need the 'x'.
> If that's not it, then maybe this link might help:
>
http://www.eclipse.org/documentation/html/plugins/org.eclips e.platform.doc.user/doc/tasks/running_eclipse.htm
>
> Good luck,
> Carolyn
>
> "Vic Hanson" <fayth@4xdamage.com> wrote in message
> news:cfhr8e$apt$1@eclipse.org...
> > You know... I run into a similar problem on Windows XP if I pass the
> > -vmargs -Xm512M also. Drop that out of your statement to start. I've
> > never gotten eclipse to run when I pass that from the commandline.
> >
> > Vic Hanson
> >
> >
> > cj wrote:
> > > Hello,
> > >
> > > sorry for the post to several groups, but we are hitting the wall
trying
> to
> > > figure out why this exception is being thrown and thus preventing
> Eclipse
> > > 3.0 from starting up. Can anyone help?
> > >
> > > We are trying to run Eclipse 3.0 on Solaris while connecting to it
from
> > > Windows XP pro using Reflection.
> > > We are calling it with:
> > >
> > > <eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M
> > >
> > > The splash screen comes up, then there is a dialog box indicating that
> there
> > > was an error and that the details have been saved into a log file in
the
> > > ./configuration directory. Here is the contents of such file:
> > >
> > > !SESSION Aug 12, 2004
> > > 18:10:16.784 ---------------------------------------------
> > > eclipse.buildId=I200406251208
> > > java.version=1.4.2_05
> > > java.vendor=Sun Microsystems Inc.
> > > BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en
> > >
> > > !ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
> > > !MESSAGE Application error
> > > !STACK 1
> > > java.lang.IllegalArgumentException: Argument cannot be null
> > > at org.eclipse.swt.SWT.error(SWT.java:2677)
> > > at org.eclipse.swt.SWT.error(SWT.java:2616)
> > > at org.eclipse.swt.SWT.error(SWT.java:2587)
> > > at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
> > > at
> > >
>
org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.ja
> va:412)
> > > at
> > >
>
org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:
> 430)
> > > at
> > >
>
org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
> > > at
> > > org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
> > > at
> > >
>
org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:
> 182)
> > > at
> > >
org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
> > > at
> > >
>
org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.jav
> a:93)
> > > at org.eclipse.jface.window.Window.create(Window.java:348)
> > > at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
> > > at org.eclipse.jface.window.Window.open(Window.java:637)
> > > at
> > >
>
org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDial
> og.java:65)
> > > at
> > >
>
org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication
> .java:314)
> > > at
> > >
>
org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplicat
> ion.java:219)
> > > at
> > > org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
> > > at
> > >
>
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.
> java:335)
> > > at
> > >
>
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
> > > at
> > >
>
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
> > > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> > > at
> > >
>
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39
> )
> > > at
> > >
>
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl
> .java:25)
> > > at java.lang.reflect.Method.invoke(Method.java:324)
> > > at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
> > > at org.eclipse.core.launcher.Main.run(Main.java:644)
> > > at org.eclipse.core.launcher.Main.main(Main.java:628)
> > >
> > >
> > >
> > >
>
>
Re: "IllegalArgumentException:Argument cannot be null" at startup [message #598080 is a reply to message #65144] Wed, 22 September 2004 12:52 Go to previous message
Eclipse User
Originally posted by: krayspam.arcor.de

What do you mean by connecting to it from WinXp? Off hand id say you were
running the wrong native libraries, But i dont know what you mean exactly.


"cj" <cj@hotmail.com> wrote in message news:cfhjoa$1ft$1@eclipse.org...
> Hello,
>
> sorry for the post to several groups, but we are hitting the wall trying
> to
> figure out why this exception is being thrown and thus preventing Eclipse
> 3.0 from starting up. Can anyone help?
>
> We are trying to run Eclipse 3.0 on Solaris while connecting to it from
> Windows XP pro using Reflection.
> We are calling it with:
>
> <eclipse_dir>$ ./eclipse -vm <java_1.4.2_dir>/bin/java -vmargs -Xm512M
>
> The splash screen comes up, then there is a dialog box indicating that
> there
> was an error and that the details have been saved into a log file in the
> ./configuration directory. Here is the contents of such file:
>
> !SESSION Aug 12, 2004
> 18:10:16.784 ---------------------------------------------
> eclipse.buildId=I200406251208
> java.version=1.4.2_05
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=solaris, ARCH=sparc, WS=motif, NL=en
>
> !ENTRY org.eclipse.osgi Aug 12, 2004 18:10:16.787
> !MESSAGE Application error
> !STACK 1
> java.lang.IllegalArgumentException: Argument cannot be null
> at org.eclipse.swt.SWT.error(SWT.java:2677)
> at org.eclipse.swt.SWT.error(SWT.java:2616)
> at org.eclipse.swt.SWT.error(SWT.java:2587)
> at org.eclipse.swt.graphics.Font.<init>(Font.java:106)
> at
> org.eclipse.jface.resource.FontRegistry.calculateDefaultFont (FontRegistry.java:412)
> at
> org.eclipse.jface.resource.FontRegistry.defaultFontRecord(Fo ntRegistry.java:430)
> at
> org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRe gistry.java:519)
> at
> org.eclipse.jface.resource.FontRegistry.get(FontRegistry.jav a:472)
> at
> org.eclipse.jface.resource.JFaceResources.getDialogFont(JFac eResources.java:182)
> at
> org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialo g.java:778)
> at
> org.eclipse.jface.dialogs.TitleAreaDialog.createContents(Tit leAreaDialog.java:93)
> at org.eclipse.jface.window.Window.create(Window.java:348)
> at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:925)
> at org.eclipse.jface.window.Window.open(Window.java:637)
> at
> org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(Cho oseWorkspaceDialog.java:65)
> at
> org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspac e(IDEApplication.java:314)
> at
> org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLoca tion(IDEApplication.java:219)
> at
> org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:83)
> at
> org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:335)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:324)
> at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
> at org.eclipse.core.launcher.Main.run(Main.java:644)
> at org.eclipse.core.launcher.Main.main(Main.java:628)
>
>
>
>
Previous Topic:Preference scopes and FieldEditorPreferencePage
Next Topic:CVS Success Stories?
Goto Forum:
  


Current Time: Sat Oct 25 05:51:18 GMT 2014

Powered by FUDForum. Page generated in 0.03760 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software