Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » Import modular maven project and associate with SVN repo
Import modular maven project and associate with SVN repo [message #648784] Fri, 14 January 2011 09:04
Fhomasp Peeters is currently offline Fhomasp Peeters
Messages: 4
Registered: January 2011
Junior Member

I first asked here...

http://www.eclipse.org/forums/index.php?t=msg&goto=64875 4&S=30b4625a11f91b8f8c2c08dda0ed6134#msg_648754

My troubles are not just maven related, but anyways, here it goes.

After working for clients who have been using IntelliJ I now need to get acquainted with Eclipse for my new client. However things are not as I expected. I'll clarify. Also keep in mind that I might have been going about this the wrong way.

So I have a java project which has modules and is built using Maven. This project also has other directories with resources.


When I select "new project from SVN" it might go better, but it doesn't. It imports the root of the project as a java project just fine, BUT, the modules are NOT configured as Java project and I can't seem to find an easy way to do this.

But I mean, come on! I do this using IntelliJ in one minute, seriously. One selects new project -> maven -> <browse to project pom> and that is it! It's working there as it should with all nessessary associations to Spring, Hibernate, Maven, SVN, ...

Sorry but I'm seriously frustrated. If anyone knows how to properly do this, by all means, enlighten me.

I tried several approaches:

+ file --> new project --> from existing sources.
- This results in one java project with several directories. Those are not recognized as Java modules and I cannot do any actions related to that (junit, maven, svn, ...)

+ directly taken from SVN
- Same as above

+ File -> Import
--> General / Existing Projects into Workspace
--> Select root directory: the root pom.xml of the modular project
- Now I do have a modular structure but there is no trace of the root pom.xml (I do need to work on that too) and it is not being resolved by eclipse either. So 300+ errors as a result.


I can't seem to associate the project with SVN either. There are .svn folders, of course, but that isn't getting picked up by eclipse.

Previous Topic:run maven command through eclipse
Next Topic:Adding New Modules to a Multi-Module Project with Subclipse
Goto Forum:
  


Current Time: Fri Aug 01 06:04:09 EDT 2014

Powered by FUDForum. Page generated in 0.01354 seconds