Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Parameter in XPATH DataSet
Parameter in XPATH DataSet [message #647296] Wed, 05 January 2011 15:35 Go to next message
No real name is currently offline No real name
Messages: 1
Registered: January 2011
Junior Member
Hi,
I saw the video that shows how to use parameters with SQL Queries.
http://www.eclipse.org/birt/phoenix/examples/reports/paramet ers/

I tried the same with a XPATH query but it doesn't seem to be working. Adding a "?" to the XPATH Query results in an error "Unrecognized Toke {}45".

What do I have to do, to parameterize XPATH Queries?
Re: Parameter in XPATH DataSet [message #647316 is a reply to message #647296] Wed, 05 January 2011 16:03 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

You need to use:
"{?p1?}"
see
http://www.eclipse.org/birt/phoenix/project/notable2.5.php#j ump_10

Jason

On 1/5/2011 10:35 AM, konnew_ads@gmx.de wrote:
> Hi,
> I saw the video that shows how to use parameters with SQL Queries.
> http://www.eclipse.org/birt/phoenix/examples/reports/paramet ers/
>
> I tried the same with a XPATH query but it doesn't seem to be working.
> Adding a "?" to the XPATH Query results in an error "Unrecognized Toke
> {}45".
>
> What do I have to do, to parameterize XPATH Queries?
Previous Topic:finding modified files for eclipse BIRT bug fixes
Next Topic:help with multiple parameter drill through using php/java bridge
Goto Forum:
  


Current Time: Thu Oct 30 17:45:31 GMT 2014

Powered by FUDForum. Page generated in 0.06463 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software