Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Trigger Problems(Trigger does not recycle between states properly)
Trigger Problems [message #646747] Thu, 30 December 2010 12:40
St Clair Clarke is currently offline St Clair Clarke
Messages: 118
Registered: March 2010
Senior Member
Hello,
I have observed a persistent problems with XWT Trigger mechanism.

Consider Trigger1 snippet from org.eclipse.e4.xwt.samples.triggers.Trigger1.xwt

<Composite xmlns="http://www.eclipse.org/xwt/presentation" xmlns:x="http://www.eclipse.org/xwt" x:Class="org.eclipse.e4.xwt.tests.xaml.Name">
	<Composite.layout>
		<GridLayout numColumns="2"/>
	</Composite.layout>
	<Button x:Style="CHECK" text="Unselected">
		<Button.triggers>
			<Trigger property="Selection" value="true">
				<Setter property="Text" value="Selected"/>
			</Trigger>
		</Button.triggers>
	</Button>
</Composite>


When the application is executed "Unselected" is displayed beside the CheckBox. Now:
1. checking the box correctely displays the "Selected" text.
2. unchecking the box also correctly displaye "Unselected" again.
3. checking the checkbox again does nothing - the checkbox should now be displaying "Selected" again.

I find this problem in all of the Trigger example tests.

It seems that after one complete cycle, the listener mechanism simply stops and so no changes gets propogated to the widget.

I think this needs to be corrected.

Thanks
Previous Topic:HowTo use NE operator on a Combo
Next Topic:could E4 team change the schedule to make E4 better now
Goto Forum:
  


Current Time: Fri Aug 01 22:34:27 EDT 2014

Powered by FUDForum. Page generated in 0.01427 seconds