Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Deploy WAR File to Virgo via Eclipse or STS(Legacy WAR file deploys to <install>/pickup directory but not via STS.)
Deploy WAR File to Virgo via Eclipse or STS [message #646569] Tue, 28 December 2010 20:13 Go to next message
Jason M. Hanna is currently offline Jason M. HannaFriend
Messages: 8
Registered: July 2009
Junior Member
Hi All,

Wondering if there is something special I need to do in order to get a legacy web application deployed to my Virgo Web Server through STS/Eclipse?

I have a WAR-packaged web application that I can successfully deploy by dropping into the <virgo-install>/pickup directory.

If I attempt to deploy this project to the Virgo Web Server configured w/in STS (v.2.5.1) , however, I get dependency resolution errors.

Doesn't seem like I should have to modify the project w/in STS, but I've tried a number of different settings combinations I can't seem to get it right.

Virgo does seem to notice edits to the MANIFEST.MF file, which leads me to believe I may need to modify the project to get this deploying correctly from w/in STS.

Guidance is greatly appreciated.

Regards,
-jmh

[Updated on: Tue, 28 December 2010 20:20]

Report message to a moderator

Re: Deploy WAR File to Virgo via Eclipse or STS [message #646612 is a reply to message #646569] Wed, 29 December 2010 08:25 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
You shouldn't need to make changes to get the project deploying from STS. Perhaps if you chase one of the unresolved dependencies you'll get more of a clue as to what is going on. For example, perhaps STS is automatically generating the manifest and adding dependencies that were not visible in the original manifest.

[Updated on: Thu, 30 December 2010 08:39]

Report message to a moderator

Re: Deploy WAR File to Virgo via Eclipse or STS [message #646684 is a reply to message #646612] Wed, 29 December 2010 21:16 Go to previous messageGo to next message
Jason M. Hanna is currently offline Jason M. HannaFriend
Messages: 8
Registered: July 2009
Junior Member
Thanks Glyn.

I did, and it turns out my WEB-INF/lib directory is missing three jar files that are expressed correctly in my Maven dependencies.

They show up in my command line build or if I run a 'maven package' goal from STS. They're strangely absent in the project deployed to my embedded Virgo Web Server, however.

One of them is my OpenJPA jar file, which is what I'm getting complaints about when I startup the embedded server.

I made a more detailed post here...

http://www.eclipse.org/forums/index.php?t=msg&goto=64667 8&S=6bcd7e172d674c684817691c26b0d890#msg_646678

Thanks!
-jmh
Re: Deploy WAR File to Virgo via Eclipse or STS [message #646700 is a reply to message #646684] Thu, 30 December 2010 08:45 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
So this looks like a tooling issue. If you can reproduce the behaviour with a simple project, perhaps you could raise a bugzilla. Please note we are in the process of donating the Virgo tooling to Eclipse, so I don't expect anyone will be able to work on the bugzilla for a while as the donation is the priority.

(BTW I didn't understand "EclipseRT Virgo Server - OSGi Bundle 1.0" in the other post since Virgo first shipped at version 2.1.0.RELEASE.)
Re: Deploy WAR File to Virgo via Eclipse or STS [message #646739 is a reply to message #646700] Thu, 30 December 2010 16:56 Go to previous messageGo to next message
Jason M. Hanna is currently offline Jason M. HannaFriend
Messages: 8
Registered: July 2009
Junior Member
Thanks Glyn. When I mentioned Eclipse OSGi Bundle v1.0 I was referring to the Project Facet under Eclipse RT Virgo Server called 'EclipseRT OSGi Bundle' which is v1.0.

I am running Virgo Web Server v2.1 as you mention.

For others that might happen upon this thread, I've just filed a bug against the Virgo Project for this issue.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=333343

Thanks!
Re: Deploy WAR File to Virgo via Eclipse or STS [message #646741 is a reply to message #646739] Thu, 30 December 2010 16:59 Go to previous message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Thanks for the clarification. I've asked Chris to take a look at your bug in case there is a simple workaround he's aware of. But, failing that, it will go into the backlog for fixing after the tools are donated to Eclipse.
Previous Topic:Re: Virgo integration with ECF remote services
Next Topic:Corrupted server after deployment
Goto Forum:
  


Current Time: Fri Dec 19 10:16:24 GMT 2014

Powered by FUDForum. Page generated in 0.04611 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software