Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Question on Graphiti 0.8 release
Question on Graphiti 0.8 release [message #646254] Wed, 22 December 2010 22:04 Go to next message
Shenxue Zhou is currently offline Shenxue ZhouFriend
Messages: 50
Registered: July 2009
Member
I noticed GEF 0.7 dependency has been introduced into Graihiti source tree around Dec 14. Does that mean Graphiti 0.8 release will only support Eclipse Indigo? Is it possible for Graphiti 0.8 release to support both Helios and Indigo?

The reason I ask is we have had the convention of making a major release of our product to support two versions of Eclipse in the past. So our next release in the summer of 2011 is supposed to support both Eclipse Helios and Eclipse Indigo.

Thank you for your consideration!

Shenxue
Re: Question on Graphiti 0.8 release [message #646635 is a reply to message #646254] Wed, 29 December 2010 13:32 Go to previous messageGo to next message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1640
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Shenxue,

we had to fix the required version for GEF to the newest Indigo version for M4 because we use some internal stuff from GEF that has changed between 3.6 and 3.7. For M5 we plan to remove that internal stuff so that we can and will open up the dependency range to enable everything starting from GEF 3.6 again.

Michael
Re: Question on Graphiti 0.8 release [message #646922 is a reply to message #646635] Mon, 03 January 2011 08:29 Go to previous messageGo to next message
Jos Warmer is currently offline Jos WarmerFriend
Messages: 108
Registered: October 2010
Senior Member
Michael, that would be great. We are moving to use Graphiti this month (starting today Smile) for a large project. Because of multiple other dependencies there is no way we can go to Indigo, we need to stay with Helios.

I updated to the lates6t sources for Graphiti, but I see no compile time problems with using GEF 3.6, except for some of the examples (testtool.sketch), so I wonder where the 3.7+ dependency with GEF is.

Jos
Re: Question on Graphiti 0.8 release [message #647896 is a reply to message #646922] Mon, 10 January 2011 11:18 Go to previous messageGo to next message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1640
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Jos,

as I wrote, we will re-enable GEF 3.6 with M5 and we target to be Eclipse
3.6 compatible with our Indigo release.

The issues that forced us to require GEF 3.7 came in just before M4 so I
don't know the details any more. I will have a detailed look into this issue
this week (see Bugzilla https://bugs.eclipse.org/bugs/show_bug.cgi?id=327669
for details and progress) .

Michael


"Jos Warmer" <jos.warmer@openmodeling.nl> wrote in message
news:ifs140$5qv$1@news.eclipse.org...
> Michael, that would be great. We are moving to use Graphiti this month
> (starting today :)) for a large project. Because of multiple other
> dependencies there is no way we can go to Indigo, we need to stay with
> Helios.
>
> I updated to the lates6t sources for Graphiti, but I see no compile time
> problems with using GEF 3.6, except for some of the examples
> (testtool.sketch), so I wonder where the 3.7+ dependency with GEF is.
>
> Jos
Re: Question on Graphiti 0.8 release [message #647963 is a reply to message #647896] Mon, 10 January 2011 15:54 Go to previous messageGo to next message
Jos Warmer is currently offline Jos WarmerFriend
Messages: 108
Registered: October 2010
Senior Member
Michael, good to hear this.

In the mean I have managed to use Graphiti with the old GEF again. For people who need this too, here is how I did it. All I had to do was to change the method getDescription() in GFMarqueeToolEnrty.java as follows:
	public String getDescription() {
		String description = super.getDescription();
		if (description != null)
			return description;

		Object value = getToolProperty(MarqueeSelectionTool.PROPERTY_MARQUEE_BEHAVIOR);
		if (value instanceof Integer) {
			int selectionType = ((Integer) value).intValue();
			if (selectionType == MarqueeSelectionTool.BEHAVIOR_NODES_CONTAINED_AND_RELATED_CONNECTIONS)
				return GEFMessages.MarqueeTool_Nodes_Contained_And_Related_Connections_Desc;
			if (selectionType == MarqueeSelectionTool.BEHAVIOR_CONNECTIONS_TOUCHED)
				return GEFMessages.MarqueeTool_Connections_Touched_Desc;
		}
		return GEFMessages.MarqueeTool_Nodes_Touched_Desc;
	}


And also take out the version number of the GEF bundle in the various MANIFEST.MF files. This is a hack of course, but I am stick with 3.6 and need Graphiti to work.

Jos
Re: Question on Graphiti 0.8 release [message #648263 is a reply to message #647963] Wed, 12 January 2011 07:58 Go to previous message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1640
Registered: July 2009
Location: Walldorf, Germany
Senior Member
In the meamtime Graphiti head is again capable of running against GEF 3.6
and GEF 3.7.

Michael


"Jos Warmer" <jos.warmer@openmodeling.nl> wrote in message
news:igf9qa$gng$1@news.eclipse.org...
> Michael, good to hear this.
>
> In the mean I have managed to use Graphiti with the old GEF again. For
> people who need this too, here is how I did it. All I had to do was to
> change the method getDescription() in GFMarqueeToolEnrty.java as follows:
> public String getDescription() {
> String description = super.getDescription();
> if (description != null)
> return description;
>
> Object value =
> getToolProperty(MarqueeSelectionTool.PROPERTY_MARQUEE_BEHAVI OR);
> if (value instanceof Integer) {
> int selectionType = ((Integer) value).intValue();
> if (selectionType ==
> MarqueeSelectionTool.BEHAVIOR_NODES_CONTAINED_AND_RELATED_CO NNECTIONS)
> return
> GEFMessages.MarqueeTool_Nodes_Contained_And_Related_Connecti ons_Desc;
> if (selectionType == MarqueeSelectionTool.BEHAVIOR_CONNECTIONS_TOUCHED)
> return GEFMessages.MarqueeTool_Connections_Touched_Desc;
> }
> return GEFMessages.MarqueeTool_Nodes_Touched_Desc;
> }
>
>
> And also take out the version number of the GEF bundle in the various
> MANIFEST.MF files. This is a hack of course, but I am stick with 3.6 and
> need Graphiti to work.
> Jos
Previous Topic:Tutorial License
Next Topic:Regressions with Graphiti 0.8.0M4 and GEF 3.7
Goto Forum:
  


Current Time: Mon Dec 22 20:55:34 GMT 2014

Powered by FUDForum. Page generated in 0.02146 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software