Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » NoSuchMethodError - Display#setAppVersion on a vanilla RCP
NoSuchMethodError - Display#setAppVersion on a vanilla RCP [message #645678] Sun, 19 December 2010 19:25 Go to next message
Aashish Patil is currently offline Aashish PatilFriend
Messages: 3
Registered: July 2009
Junior Member
Note: Please ignore - problem solved (see reply for solution)


Fresh Eclipse 3.6.1 IDE RCP + RAP
OSX - Snow Leopard with Java 1.6.0_22
Deleted my old Eclipse directory and then installed this one pointing to old workspace.

No additional plugins installed

Created a vanilla RCP application template (With a view)
Did not add any code to the created project
Should work and show me a sample view

Instead when I click on "Launch Eclipse Application" from plugin.xml, I get the mentioned error error (full stack trace pasted at the end).

Tried deleting the project and different RCP templates. No luck- same result.

My older RCP project that used to work just fine in the previous version is also now broken and shows the same error.

Stack Trace:
!SESSION 2010-12-19 11:12:13.359 -----------------------------------------------
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86, WS=cocoa, NL=en_US
Framework arguments: -product com.aashishpatil.notesnmore.product
Command-line arguments: -product com.aashishpatil.notesnmore.product -data /Users/aashishpatil/Documents/workspace/../runtime-notesnmor e.product -dev file:/Users/aashishpatil/Documents/workspace/.metadata/.plug ins/org.eclipse.pde.core/notesnmore.product/ -os macosx -ws cocoa -arch x86

!ENTRY org.eclipse.osgi 4 0 2010-12-19 11:12:14.914
!MESSAGE Application error
java.lang.NoSuchMethodError: org.eclipse.swt.widgets.Display.setAppVersion(Ljava/lang/Str ing;)V
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.ja va:692)
at org.eclipse.ui.PlatformUI.createDisplay(
at com.aashishpatil.notesnmore.NotesNMoreApp.start(NotesNMoreAp
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe
at java.lang.reflect.Method.invoke(
at org.eclipse.equinox.launcher.Main.invokeFramework( 619)
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(

[Updated on: Sun, 19 December 2010 19:52]

Report message to a moderator

Re: NoSuchMethodError - Display#setAppVersion on a vanilla RCP [message #645682 is a reply to message #645678] Sun, 19 December 2010 19:51 Go to previous message
Aashish Patil is currently offline Aashish PatilFriend
Messages: 3
Registered: July 2009
Junior Member
Please ignore the above post

Problem solved.

I was still using an older RCP Delta pack. After upgrading to the 3.6.1 delta pack the error went away.

Previous Topic:how to screen lock
Next Topic:Can I show a Hyperlink in a tooltip?
Goto Forum:

Current Time: Tue Oct 13 13:43:07 GMT 2015

Powered by FUDForum. Page generated in 0.01821 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software