Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » [PDEBuild] Missing <buildDirectory>/features/ compiling with repoBaseLocation, the build fails)
[PDEBuild] Missing <buildDirectory>/features/ [message #645328] Thu, 16 December 2010 16:20
Ponyno  is currently offline Ponyno Friend
Messages: 3
Registered: November 2010
Junior Member

My headless build generates a product by building it against a P2 repository (I use baseRepoLocation to reference the parent directory of this repository).

The problem is that PDEBuild does not find the file <buildDirectory>/features/ This file does not exist. Why ?

In classical builds (without repoBaseLocation), this file exists and the build works fine.

Thank you for help.

Here is a slice of the stacktrace : D:\build-directory\features\org.eclipse\build.xml (Le fichier spÚcifiÚ est introuvable)

        at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)

[Updated on: Thu, 16 December 2010 16:28]

Report message to a moderator

Previous Topic:root files mechanism does not copy empty directories
Next Topic:How to always invoke a builder
Goto Forum:

Current Time: Sat Oct 10 12:43:47 GMT 2015

Powered by FUDForum. Page generated in 0.01831 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software