Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » root files mechanism does not copy empty directories
root files mechanism does not copy empty directories [message #645312] Thu, 16 December 2010 15:26
No real name is currently offline No real nameFriend
Messages: 1
Registered: December 2010
Junior Member
I'm using a feature-based target platform export. In the feature's build.properties I set some directories to be included statically in the target platform. This mechanism and its properties is described in [1] and [2].

The problem is, I have several empty directories that do not get copied. But I need them copied. Is there a way to accomplish that easily?

It feels like the Ant task used for copying these root files has its includeemptydirs attribute set to false. Can anyone confirm this?

Kind Regards,
Alexander

[1] .. http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .pde.doc.user/reference/pde_feature_generating_build.htm

[2] .. http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .pde.doc.user/tasks/pde_rootfiles.htm
Previous Topic:Contribute/extend manifest editor functionality?
Next Topic:[PDEBuild] Missing <buildDirectory>/features/org.eclipse.pde.build.container/build.xml
Goto Forum:
  


Current Time: Sun May 28 22:35:42 GMT 2017

Powered by FUDForum. Page generated in 0.06379 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software