Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Similar Connector installation issue, but on Windows XP with helios
icon8.gif  Similar Connector installation issue, but on Windows XP with helios [message #645221] Thu, 16 December 2010 03:57 Go to next message
narke is currently offline narkeFriend
Messages: 4
Registered: July 2009
Junior Member
I also cannot install the connector after the subversive discovery window pops up. I tried either the JavaHL 1.6.5 or the SVN Kit 1.3.2 implementation, all the same:

Problems occurred while performing installation: Operation details

See error log for details.

----log----
!SESSION 2010-12-16 11:42:37.730 -----------------------------------------------
eclipse.buildId=M20100909-0800
java.version=1.6.0_22
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product

!ENTRY org.eclipse.team.svn.core.svnnature 4 0 2010-12-16 11:43:08.763
!MESSAGE Problems occurred while performing installation: Operation details
!STACK 1
org.eclipse.core.runtime.CoreException: Operation details
at org.eclipse.team.svn.ui.discovery.PrepareInstallProfileJob_3 _6.resolve(PrepareInstallProfileJob_3_6.java:129)
at org.eclipse.team.svn.ui.discovery.PrepareInstallProfileJob_3 _6.run(PrepareInstallProfileJob_3_6.java:97)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)
Contains: Cannot complete the install because one or more required items could not be found.
Contains: Software being installed: Subversive SVN Connectors 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.feature.group 2.2.2.I20101203-1700)
Contains: Missing requirement: Subversive SVN Connectors 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.feature.group 2.2.2.I20101203-1700) requires 'org.eclipse.team.svn.feature.group [0.7.9.I20101001-1700,1.0.0)' but it could not be found
!SUBENTRY 1 org.eclipse.equinox.p2.operations 4 0 2010-12-16 11:43:08.763
!MESSAGE Operation details
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2010-12-16 11:43:08.763
!MESSAGE Cannot complete the install because one or more required items could not be found.
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2010-12-16 11:43:08.763
!MESSAGE Software being installed: Subversive SVN Connectors 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.feature.group 2.2.2.I20101203-1700)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2010-12-16 11:43:08.763
!MESSAGE Missing requirement: Subversive SVN Connectors 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.feature.group 2.2.2.I20101203-1700) requires 'org.eclipse.team.svn.feature.group [0.7.9.I20101001-1700,1.0.0)' but it could not be found
----------------------------------------------------
Re: Similar Connector installation issue, but on Windows XP with helios [message #645499 is a reply to message #645221] Fri, 17 December 2010 14:02 Go to previous messageGo to next message
haaskon is currently offline haaskonFriend
Messages: 1
Registered: December 2010
Junior Member
same issue for me on windows 7 and a clean helios installation
Re: Similar Connector installation issue, but on Windows XP with helios [message #646312 is a reply to message #645499] Thu, 23 December 2010 09:57 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 1
Registered: December 2010
Junior Member
eclipse has become a sad joke.
Re: Similar Connector installation issue, but on Windows XP with helios [message #646997 is a reply to message #646312] Mon, 03 January 2011 22:16 Go to previous messageGo to next message
Glenview Jeff is currently offline Glenview JeffFriend
Messages: 79
Registered: September 2010
Member
Same here. Has someone found a workaround?
Re: Similar Connector installation issue, but on Windows XP with helios [message #647001 is a reply to message #646312] Mon, 03 January 2011 22:25 Go to previous messageGo to next message
Glenview Jeff is currently offline Glenview JeffFriend
Messages: 79
Registered: September 2010
Member
In order to avoid installation issues please use "Early Access" site:
http://download.eclipse.org/technology/subversive/0.7/update -site/

The reason why it fails for Helios is explained here:
http://www.eclipse.org/subversive/downloads.php#faq
Re: Similar Connector installation issue, but on Windows XP with helios [message #647135 is a reply to message #647001] Tue, 04 January 2011 17:23 Go to previous messageGo to next message
Bradley Schmerl is currently offline Bradley SchmerlFriend
Messages: 26
Registered: July 2009
Junior Member
I get the error: No software site found
Re: Similar Connector installation issue, but on Windows XP with helios [message #648299 is a reply to message #647135] Wed, 12 January 2011 10:19 Go to previous messageGo to next message
Zlatko Kostadinow is currently offline Zlatko KostadinowFriend
Messages: 2
Registered: January 2011
Junior Member
Bradley Schmerl wrote on Tue, 04 January 2011 12:23
I get the error: No software site found

This is because of a ' ' in the url - remove it and it works

http://download.eclipse.org/technology/subversive/0.7/update -site/
Re: Similar Connector installation issue, but on Windows XP with helios [message #648300 is a reply to message #648299] Wed, 12 January 2011 10:22 Go to previous messageGo to next message
Zlatko Kostadinow is currently offline Zlatko KostadinowFriend
Messages: 2
Registered: January 2011
Junior Member
Sorry, looks like this space is added automatically, here it is without space:
http://download.eclipse.org/technology/subversive/0.7/update-site/
Re: Similar Connector installation issue, but on Windows XP with helios [message #649633 is a reply to message #645221] Thu, 20 January 2011 01:31 Go to previous message
Chris Markle is currently offline Chris MarkleFriend
Messages: 6
Registered: October 2009
Junior Member
I had all the same issues described in this post and I found it very challenging to get them resolved. I thought I'd document what finally worked for me...

Basically in a fresh Helios install I first installed the Subversive SVN Team Provider from the early access location (which as of 2011-01-19 was: http://download.eclipse.org/technology/subversive/0.7/update -site/).

(This is as opposed to installing it from the Helios update site, which did NOT work.)

Then when Helios restarted, when I went to the SVN Repository Viewing perspective, and was presented with the Connector Location dialogue, which worked when I used it.

Net-net, first get the Subversive SVN Team Provider from the early access site, and the rest of things should "just work".

Chris

[Updated on: Thu, 20 January 2011 01:33]

Report message to a moderator

Previous Topic:SVN password dialog appearing on every operation
Next Topic:Shortcuts doesn't work
Goto Forum:
  


Current Time: Fri Dec 19 04:08:33 GMT 2014

Powered by FUDForum. Page generated in 0.02093 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software