Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Deployment and dependant project issue(Dependant project not appearing in WEB-INF/lib)
icon5.gif  Deployment and dependant project issue [message #643609] Tue, 07 December 2010 16:08 Go to next message
Andre John Mas is currently offline Andre John Mas
Messages: 11
Registered: July 2009
Junior Member
I have an issue where a project that my main project depends on is not appearing as a JAR in the WEB-INF/lib folder of my deployed application.

Details:

The project (project2) that my main project (project1) depends on is added to the projects tab of the "Java Build Path" of project1. It is also added to the "deployment assembly" entry and appears as:

source: project2
deploy path: /WEB-INF/lib/project2.jar

This project also makes use of IvyDE for libraries that are needed. When I go to publish the project in my application server (Tomcat 5.5 in the "severs" view), I see (by looking in the WEB-INF/lib folder) that the the libraries referenced by the IvyDE classpath container are deployed, but not the one representing project2.

What step am I missing to get the project2.jar generated and placed in the WEB-INF/lib folder?
Re: Deployment and dependant project issue [message #644482 is a reply to message #643609] Sun, 12 December 2010 01:15 Go to previous messageGo to next message
snistas is currently offline snistas
Messages: 1
Registered: December 2010
Junior Member
Andre John Mas wrote on Tue, 07 December 2010 11:08
I have an issue where a project that my main project depends on is not appearing as a JAR in the WEB-INF/lib folder of my deployed application.

Details:

The project (project2) that my main project (project1) depends on is added to the projects tab of the "Java Build Path" of project1. It is also added to the "deployment assembly" entry and appears as:

source: project2
deploy path: /WEB-INF/lib/project2.jar

This project also makes use of IvyDE for libraries that are needed. When I go to publish the project in my application server (Tomcat 5.5 in the "severs" view), I see (by looking in the WEB-INF/lib folder) that the the libraries referenced by the IvyDE classpath container are deployed, but not the one representing project2.

What step am I missing to get the project2.jar generated and placed in the WEB-INF/lib folder?


Same problem here. Could somebody point us to the right direction?

Thanks in advance.
Re: Deployment and dependant project issue [message #644978 is a reply to message #643609] Wed, 15 December 2010 03:12 Go to previous message
Andre John Mas is currently offline Andre John Mas
Messages: 11
Registered: July 2009
Junior Member
Things seem to work now. I went into Eclipse and checked for updates and updated anything that was out of date. Amongst those updates was stuff for Eclipse and IvyDE.

Give that a go and see if that helps.
Previous Topic:JavaScript Project debugging fails connection refused
Next Topic: Create a new XML web service
Goto Forum:
  


Current Time: Mon Sep 22 10:30:50 GMT 2014

Powered by FUDForum. Page generated in 0.10034 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software