Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Problems with 2 webapps in one BEA Weblogic
Problems with 2 webapps in one BEA Weblogic [message #643305] Mon, 06 December 2010 08:07 Go to next message
Juergen Schwarz is currently offline Juergen Schwarz
Messages: 11
Registered: July 2009
Junior Member
Hi,

at a customer we have 2 webapps using BIRT 2.5 installed in one BEA. On
startup, one app can create the BIRT report engine without problems, the
other gives an error "Can not startup the OSGI framework".

After that we set an entry like "osgi.configuration.area=/xxxx" into one
apps config.ini (for a directory with write permission) and after that
we get another error message about problems with the log manager.

Is there any solution for that that can be setup in config.ini? Looks
like the 2 webapps seem to collide somehow.

Thanks,
Juergen
Re: Problems with 2 webapps in one BEA Weblogic [message #643433 is a reply to message #643305] Mon, 06 December 2010 14:51 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Juergen,

Can you open a bug with the error?
Also is using the BIRT tag libraries an option? That way you could
deploy the viewer once and just use it to run the reports you want from
either app.

Jason

On 12/6/2010 8:07 AM, Juergen Schwarz wrote:
> Hi,
>
> at a customer we have 2 webapps using BIRT 2.5 installed in one BEA. On
> startup, one app can create the BIRT report engine without problems, the
> other gives an error "Can not startup the OSGI framework".
>
> After that we set an entry like "osgi.configuration.area=/xxxx" into one
> apps config.ini (for a directory with write permission) and after that
> we get another error message about problems with the log manager.
>
> Is there any solution for that that can be setup in config.ini? Looks
> like the 2 webapps seem to collide somehow.
>
> Thanks,
> Juergen
>


Jason Weathersby

BIRT Exchange
Previous Topic:Runtime connection string problem
Next Topic:Can't get BIRT installed on TurnKey Linux VM
Goto Forum:
  


Current Time: Thu Apr 17 17:30:30 EDT 2014

Powered by FUDForum. Page generated in 0.01606 seconds